Bug 176514 - non-latin shortcut keys does not work
Summary: non-latin shortcut keys does not work
Status: RESOLVED DUPLICATE of bug 375518
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-30 02:52 UTC by Praveen A
Modified: 2021-03-26 16:09 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Praveen A 2008-11-30 02:52:28 UTC
Version:            (using Devel)
Installed from:    Compiled sources

I could see a similar bug closed with REMIND as resolution.https://bugs.kde.org/show_bug.cgi?id=60075

I would really like to see this addressed and fixed. GNOME already have support for keyboard shortcuts in any language and we have decided to use that instead of english short cuts in bracket only to see this broke in KDE.
Comment 1 Michael Jansen 2009-05-17 21:33:24 UTC
Please give me instructions how to see this problems.

In example switch to xy locale and do ...

Mike
Comment 2 Praveen A 2009-05-19 09:00:09 UTC
1. Open Konqueror with Malayalam locale
LANG=ml_IN konqueror

2. Change keyboard layout
 Open a terminal window

run
setxkbmap us
setxkbmap ml

3. Test keyboard shortcut for Go (alt+ല ie, alt+n)
Test keyboard shortcut for Bookmarks (alt+ ഓ ie, alt+shift+a)

This is working so far.

Now repeat the same test with India->Malayalam layout selected from System Settings -> Regional & Language -> Keyboard Layout

The shortcut keys does not work. So I guess the issue is with the interface between kde and X (libxklaviour and xkbfile interfaces).
Comment 3 Jean Delvare 2010-03-01 11:12:32 UTC
This could be the same problem as bug #167428.
Comment 4 Andreas Hartmetz 2010-09-17 21:36:25 UTC

*** This bug has been marked as a duplicate of bug 167428 ***
Comment 5 Nate Graham 2021-03-26 16:09:39 UTC

*** This bug has been marked as a duplicate of bug 375518 ***