Bug 16270 - configure the headers visible in the reader pane
Summary: configure the headers visible in the reader pane
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: UI (show other bugs)
Version: 4.9.3
Platform: unspecified Linux
: NOR wishlist with 844 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 44131 50049 59477 64829 101051 141321 141658 154743 (view as bug list)
Depends on:
Blocks:
 
Reported: 2000-11-29 21:33 UTC by Christian Na
Modified: 2013-03-07 08:18 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Na 2000-11-29 19:42:35 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: 1.1.99 (KDE 2.0)
Severity: wishlist
Compiler: gcc version 2.95.2 20000220 (Debian GNU/Linux)
OS: Linux 2.2.17 i586 (compiled sources)

Hi!
I would like to add to the wishlist:
- Make it possible to choose which headers are shown in a mail when reading it.
I for example like the standard headers (like in "Vier/Fancy Headers") plus the
"X-Mailer:"-header. Balsa which I used before kmail had the option to select the
headers that are shown.

Thank you
Christian
Comment 1 Ingo Klöcker 2003-03-24 12:04:14 UTC
*** Bug 56308 has been marked as a duplicate of this bug. ***
Comment 2 Ingo Klöcker 2003-03-24 22:09:17 UTC
*** Bug 44131 has been marked as a duplicate of this bug. ***
Comment 3 Ingo Klöcker 2003-03-24 22:09:47 UTC
*** Bug 50049 has been marked as a duplicate of this bug. ***
Comment 4 Ingo Klöcker 2003-06-07 20:19:52 UTC
*** Bug 59477 has been marked as a duplicate of this bug. ***
Comment 5 Amit Shah 2003-12-05 12:51:27 UTC
Also, the date in the fancy header being displayed could be in the local timezone format of the sender (if it reports 00:00 -1:00, 23:00 could be shown there), while maintaining the date/time in local timezone format in the summary view.
Comment 6 Gerald Young 2003-12-06 03:42:02 UTC
I'd like to be able to see the "To" AND "From" at the same time. I use the "To" to filter messages for spam, and it's easier to browse and sort by and delete if I know to whom a message might be addressed.

Why can't I change view Sender/Recipient in Inbox, but I can in all the other folders?
Comment 7 Matthieu Pupat 2004-02-09 19:30:05 UTC
Could be nice also to display headers generated by SpamAssasin to test his efficiency.
Comment 8 Dan Allen 2004-02-29 21:26:09 UTC
It would make sense to make this an XSLT setting to be used just like in Kopete messages.  This way, any user can create a custom "fancy" header for the message.  Of course, the message headers would have to be placed into XML for parsing, but it is an idea.
Comment 9 Tom Albers 2004-08-07 13:29:26 UTC
*** Bug 64829 has been marked as a duplicate of this bug. ***
Comment 10 Christian Loose 2005-03-08 10:20:23 UTC
*** Bug 101051 has been marked as a duplicate of this bug. ***
Comment 11 Holger Levsen 2005-09-22 13:44:31 UTC
It would also be great to add extra headers when composing mails, see and vote for bug #57392
Comment 12 Tristan Miller 2006-06-14 02:26:03 UTC
Gerald Young, recent versions of KMail show both the To: and From: headers.  However, I agree that it would be nice if the user could toggle display of other headers, such as X-Accept-Language:.

Note that KNode already has this capability.
Comment 13 Martin Steigerwald 2006-10-25 10:46:55 UTC
Configuring additional headers to be displayed could be really handy at times. For example for configuring KMail to display X-CRM114-Status without having to resort to full header display (see "crm114 support in KMail antispam wizard", bug #136261).
Comment 14 Christoph 2006-11-26 00:40:25 UTC
The xslt-way would be nice. One could write themes.
I for example would like to set the fancy-header position:absolute so that it
is always visible even when I have scrolled to the end of the mail.
Comment 15 Thomas McGuire 2007-02-07 15:55:03 UTC
*** Bug 141321 has been marked as a duplicate of this bug. ***
Comment 16 Thomas McGuire 2007-02-14 00:01:34 UTC
*** Bug 141658 has been marked as a duplicate of this bug. ***
Comment 17 Maciej Pilichowski 2007-02-14 08:44:19 UTC
There is of course fancy, standard, long, etc. but nothing really fits 100%. So it would be great to have the ability to customize the headers and have one more extra -- the user one. 
 The template could look like this: 
 
 %bg:grey %subject 
 %bg:blue %from 
 %to 
 %bg:yellow %sent_date 
 
 So something similar to composer templates, but to customize needed info and style when viewing mails.
Comment 18 Thomas McGuire 2007-12-28 14:18:17 UTC
*** Bug 154743 has been marked as a duplicate of this bug. ***
Comment 19 Sascha Lucas 2008-06-18 11:53:36 UTC
Huhu! Someone working on this? After 7+ years waiting I still can't find an option to display custom headers in the message reading window (kmail-1.9.9).
Comment 20 Maciej Pilichowski 2008-06-18 12:27:01 UTC
Sascha, that's because everybody was patiently waiting for some help. So... would you help to add this feature to KMail? 

The fact is the number of developers is limited -- developers already work on a lot of issues, thus only saying the feature is not yet just increasing noise to signal ratio. Thank you in advance for understanding the situation.
Comment 21 Sascha Lucas 2008-06-18 16:53:51 UTC
I wish I could help, but I do not even understand all this C++/Qt stuff. I found that Klas Kalass allready had a patch¹ for this feature in 2003. Unfortunately it does not apply any more.

Of course I understand the developers situation. At least I know now that this bug is not forgotten ... :-). Thanks.

¹ http://lists.kde.org/?l=kmail-devel&m=106249227324074&w=2
Comment 22 Cyril Brulebois 2008-10-17 05:04:24 UTC
People interested in adding a given header could add it in kdepim/kmail/headerstrategy.cpp as a workaround (I'm personally *very* interested in having Message-ID displayed).

For more in-depth stuff, one should note that there's also a CustomHeaderStrategy class defined in that file, that apparently only needs to be used. I'm looking at kdepim/kmail 3.5.9 (yeah, that's old, I know, but so is this bug :p), but it looks like this still holds for current trunk, given that there's no match for “custom” in the headerstyle.cpp file.
Comment 23 Tristan Miller 2009-04-25 23:46:07 UTC
Confirming feature is still missing from KDE 4.2.2.
Comment 24 pgnet 2009-11-15 21:35:16 UTC
still n/a in kontact-4.3.3-168.3.x86_64
Comment 25 pgnet 2010-02-11 01:02:26 UTC
after almost 9 1/2 years after the bug was originally filed, @ #31 on the "charts", http://tinyurl.com/l5fg7m, 

  n/a in kmail-4.4.0-197.2.x86_64
Comment 26 pgnet 2010-02-11 01:08:08 UTC
for a completely functional, well thought through example of how workflow can be handled that's been around for years, see Mnenhy for Thunderbird ...

  http://mnenhy.mozdev.org/customheaders.html
Comment 27 Martin Steigerwald 2010-02-11 11:38:43 UTC
Thanks for the link to a working example, that could help implementation of such a feature in KMail.

However I don't think that complaining in such a tone will help getting the bug fixed. Quite the contrary: If I were a KMail developer with skills to fix this bug, I think I wouldn't draw motivation out of comments like your sarcastic "look, it's still unfixed". Anyone knows that by just looking at the bug report. So IMHO no need to reiterate that.
Comment 28 Myriam Schweingruber 2012-08-18 07:51:27 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 29 Luigi Toscano 2012-08-19 01:13:48 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.
Comment 30 Bernd Oliver Sünderhauf 2012-11-22 20:47:13 UTC
Confirm this is still the case in kmail2 on KDE 4.9.3.
Should be component "UI", I guess.
Comment 31 Luigi Toscano 2012-11-22 21:17:34 UTC
*** This bug has been confirmed by popular vote. ***
Comment 32 Laurent Montel 2013-03-07 08:18:07 UTC
Git commit 67f1dbeffd9c2c04d882eaa9fe52cdb3eddd4180 by Montel Laurent.
Committed on 07/03/2013 at 09:17.
Pushed by mlaurent into branch 'master'.

Fix Bug 16270 - configure the headers visible in the reader pane

FIXED-IN: 4.11

M  +5    -5    messageviewer/customheadersettingwidget.cpp
M  +3    -1    messageviewer/customheadersettingwidget.h

http://commits.kde.org/kdepim/67f1dbeffd9c2c04d882eaa9fe52cdb3eddd4180