Bug 143419 - KWD (kde-window-decorator) crashed and caused the signal 11 (SIGSEV)
Summary: KWD (kde-window-decorator) crashed and caused the signal 11 (SIGSEV)
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 148974 150112 150208 150271 150654 150821 151168 152057 152395 152792 153601 154809 155166 157415 157622 158351 161184 161485 161636 161889 220902 227452 228407 229127 229797 231233 231893 232914 233465 264199 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-24 11:38 UTC by Mike Whincup
Modified: 2011-01-25 20:43 UTC (History)
32 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Generated bug kcrash report (3.19 KB, application/octet-stream)
2008-03-19 22:52 UTC, Thomas Lottmann
Details
New crash information added by DrKonqi (3.91 KB, text/plain)
2010-03-22 15:16 UTC, enet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Whincup 2007-03-24 11:38:25 UTC
Version:           0.4-15 (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs
OS:                Linux

Hello

After logging to KDE, window decorations are seen initially, and then, after a few seconds, the decorations disappear, with the following backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1225079088 (LWP 4622)]
[KCrash handler]
#9  0xb777a062 in QWidget::~QWidget () from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb77d400d in QButton::~QButton () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0xb7ed3fa7 in KCommonDecorationButton::~KCommonDecorationButton ()
   from /opt/kde3/lib/libkdecorations.so.1
#12 0xb6d74554 in KWinSUSE2::SUSE2Button::~SUSE2Button ()
   from /opt/kde3/lib/kde3/kwin3_SUSE2.so
#13 0xb7ed6bc4 in KCommonDecoration::~KCommonDecoration ()
   from /opt/kde3/lib/libkdecorations.so.1
#14 0xb6d700bd in KWinSUSE2::SUSE2Client::~SUSE2Client ()
   from /opt/kde3/lib/kde3/kwin3_SUSE2.so
#15 0x0805a7b6 in KWD::Window::~Window ()
#16 0x08052ca9 in KWD::Decorator::handleWindowRemoved ()
#17 0x08050bc6 in KWD::Decorator::qt_invoke ()
#18 0xb773ff1d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb7d6ab81 in KWinModule::windowRemoved ()
   from /opt/kde3/lib/libkdecore.so.4
#20 0xb7d704f7 in KWinModulePrivate::removeClient ()
   from /opt/kde3/lib/libkdecore.so.4
#21 0xb7d60792 in NETRootInfo::update () from /opt/kde3/lib/libkdecore.so.4
#22 0xb7d614c0 in NETRootInfo::event () from /opt/kde3/lib/libkdecore.so.4
#23 0xb7d715f4 in KWinModulePrivate::x11Event ()
   from /opt/kde3/lib/libkdecore.so.4
#24 0xb7e38773 in KApplication::x11EventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#25 0x080532bd in KWD::Decorator::x11EventFilter ()
#26 0xb766ef54 in qt_x11EventFilter () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb767e893 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb768f98a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb76f77f0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb76f7686 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb76e057f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x08051992 in main ()

If I type...

kde-window-decorator --replace &

I can get the window decorations back, but they may disappear again sometime later in the session.

I haven't figured out how to recreate the problem.

I'm using Compiz, and SuperKaramba.

Thanks in advance...
Comment 1 Mike Whincup 2007-03-24 11:48:11 UTC
In the console window where I typed

kde-window-decorator --replace &

I occasionally get error/warning messages, e.g

~> X Error: BadWindow (invalid Window parameter) 3
  Major opcode:  20
  Minor opcode:  0
  Resource id:  0x3e00001
Comment 2 Lubos Lunak 2007-03-24 11:56:06 UTC
I probably want to complain to Compiz/KWD developers.
Comment 3 Ian 2007-05-16 19:36:44 UTC
This is the most frustrating bug I have encountered so far. I'm not a Linux expert by any means so any simple instructions on how to fix this would be greatly appreciated.
Comment 4 Lubos Lunak 2007-05-16 22:55:36 UTC
Sorry, that was supposed to be "You probably want to complain to Compiz/KWD developers", not I. KDE project does not develop KWD.
Comment 5 Philippe Devloo 2007-05-21 21:59:08 UTC
I had the same behaviour in mandriva 2007 spring edition
Comment 6 Brice Goglin 2007-08-09 09:24:24 UTC
Are we actually sure the bug is in kde-window-decorator and not in a KDE/QT library? This resolved/invalid status looks kind of fast and unexplained...
Comment 7 Lubos Lunak 2007-08-09 10:28:29 UTC
No, we are not sure. But we're also not sure it is in KDE/Qt. That's up to the KWD developers to find out and tell us if it's KDE/Qt problem.
Comment 8 Jyothi Swaroop Guntupalli 2007-08-10 17:34:50 UTC
So what's the solution now?? it says *resolved*!!
Comment 9 Lubos Lunak 2007-08-10 19:21:43 UTC
If it is a KDE/Qt problem after all, reopen and provide further information.
Comment 10 Mike Whincup 2007-08-12 00:23:49 UTC
Glad this thread hasn't died. If there is a resolution, I haven't heard of it...
I'll try to capture more details next time it happens.
Comment 11 Lubos Lunak 2007-08-23 13:16:59 UTC
*** Bug 148974 has been marked as a duplicate of this bug. ***
Comment 12 Lubos Lunak 2007-09-23 15:29:32 UTC
*** Bug 150112 has been marked as a duplicate of this bug. ***
Comment 13 Lubos Lunak 2007-09-26 11:05:42 UTC
*** Bug 150208 has been marked as a duplicate of this bug. ***
Comment 14 Lubos Lunak 2007-09-27 20:44:47 UTC
*** Bug 150271 has been marked as a duplicate of this bug. ***
Comment 15 Tommi Tervo 2007-10-10 10:45:55 UTC
*** Bug 150654 has been marked as a duplicate of this bug. ***
Comment 16 Lubos Lunak 2007-10-15 13:20:28 UTC
*** Bug 150821 has been marked as a duplicate of this bug. ***
Comment 17 Cláudio da Silveira Pinheiro 2007-10-30 01:02:43 UTC
It happens in AIGLX too.
I believe it's not a X's problem cause compiz runs fine in the same setup.

System here is:
Kubuntu 7.10 (amd64)
Athlon64 3500+
4GB RAM.
Video board: Nvidia 5700le 256MB
Comment 18 Lubos Lunak 2007-11-12 13:55:23 UTC
*** Bug 152057 has been marked as a duplicate of this bug. ***
Comment 19 johan 2007-11-13 16:28:20 UTC
I get the same type of message. It's random and it only appears when compiz is running
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1226041136 (LWP 6200)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb7ac9875 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7acb201 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb7b00e5c in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0x0000000b in ?? ()
#11 0xbfd8b384 in ?? ()
#12 0x00000400 in ?? ()
#13 0xb7bcb0c8 in ?? () from /lib/tls/i686/cmov/libc.so.6
#14 0x00000017 in ?? ()
#15 0xbfd8cc28 in ?? ()
#16 0x00000014 in ?? ()
#17 0xb7bcb0e1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#18 0x00000002 in ?? ()
#19 0xb7bcb13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#20 0x00000023 in ?? ()
#21 0xb7bcb0e5 in ?? () from /lib/tls/i686/cmov/libc.so.6
#22 0x00000004 in ?? ()
#23 0xbfd8b8fb in ?? ()
#24 0x00000008 in ?? ()
#25 0xb7bcb0eb in ?? () from /lib/tls/i686/cmov/libc.so.6
#26 0x00000005 in ?? ()
#27 0x08078610 in ?? ()
#28 0xb7a9ea2c in ?? () from /usr/lib/libXrender.so.1
#29 0x08078610 in ?? ()
#30 0x08073bd0 in ?? ()
#31 0xbfd8b2e8 in ?? ()
#32 0xb79e2250 in _XAllocID () from /usr/lib/libX11.so.6
#33 0xb7b08d65 in ?? () from /lib/tls/i686/cmov/libc.so.6
#34 0x00000002 in ?? ()
#35 0xb7bcb0c8 in ?? () from /lib/tls/i686/cmov/libc.so.6
#36 0xbfd8cc28 in ?? ()
#37 0xb7bcb13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#38 0xbfd8b8fb in ?? ()
#39 0x08074368 in ?? ()
#40 0xbfd8b8fb in ?? ()
#41 0x080a20e8 in ?? ()
#42 0xb7be6148 in ?? () from /lib/tls/i686/cmov/libc.so.6
#43 0x08073bd0 in ?? ()
#44 0xb7bcb13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#45 0xb79e46c4 in _XReply () from /usr/lib/libX11.so.6
#46 0xb7b0c800 in free () from /lib/tls/i686/cmov/libc.so.6
#47 0xb79e1d6d in XFree () from /usr/lib/libX11.so.6
#48 0xb6be1118 in CrystalClient::ClientWindows ()
   from /usr/lib/kde3/kwin3_crystal.so
#49 0xb6be1574 in CrystalClient::mouseWheelEvent ()
   from /usr/lib/kde3/kwin3_crystal.so
#50 0xb6be5dcd in CrystalClient::eventFilter ()
   from /usr/lib/kde3/kwin3_crystal.so
#51 0xb7487e40 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#52 0xb7487ebe in QObject::event () from /usr/lib/libqt-mt.so.3
#53 0xb74bf5b3 in QWidget::event () from /usr/lib/libqt-mt.so.3
#54 0xb741faf0 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#55 0xb7421f4a in QApplication::notify () from /usr/lib/libqt-mt.so.3
#56 0xb7ef7ca2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#57 0xb73b227d in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#58 0xb73a351b in QETWidget::translateWheelEvent ()
   from /usr/lib/libqt-mt.so.3
#59 0xb73b0522 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#60 0xb73aefcc in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#61 0x08055e0f in ?? ()
#62 0xb739e153 in ?? () from /usr/lib/libqt-mt.so.3
#63 0x0806d0f8 in ?? ()
#64 0xbfd8c6b8 in ?? ()
#65 0x00000004 in ?? ()
#66 0xb79508d0 in ?? () from /usr/lib/libqt-mt.so.3
#67 0xbfd8c6b8 in ?? ()
#68 0xb79508d0 in ?? () from /usr/lib/libqt-mt.so.3
#69 0xbfd8c558 in ?? ()
#70 0xb73ae8e2 in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC
Comment 20 Sascha Hlusiak 2007-11-13 17:04:00 UTC
The last one is a crash because of the Crystal window decoration and not related to KDE or kwin. Crystal was made to embed in kwin and it's own feature "scroll windows on wheel" crashes with kwd running under it when you use the scroll wheel on the decoration. Please disable the feature in the kwin decoration settings dialog and see if it goes away.

This bug in Crystal IS ALREADY fixed, but Kubuntu seems to ship an old version of kwin-style-crystal (or whatever it is called). Please feel free to upgrade to 1.0.5.
Comment 21 Lubos Lunak 2007-11-13 17:34:22 UTC
As already mentioned in comment #4, there's really no need to add anything here. KWD is developed by Compiz developers and not by the KDE project. And, as said in https://bugzilla.novell.com/show_bug.cgi?id=304184, there should be already a fix somewhere.
Comment 22 Lubos Lunak 2007-11-15 23:08:09 UTC
*** Bug 152395 has been marked as a duplicate of this bug. ***
Comment 23 Tommi Tervo 2007-12-07 09:21:14 UTC
*** Bug 153601 has been marked as a duplicate of this bug. ***
Comment 24 Pino Toscano 2007-12-29 14:10:01 UTC
*** Bug 154809 has been marked as a duplicate of this bug. ***
Comment 25 Pino Toscano 2008-01-06 12:49:30 UTC
*** Bug 155166 has been marked as a duplicate of this bug. ***
Comment 26 Mike Whincup 2008-01-09 20:40:52 UTC
Guys, 

I'm not sure whether to close this bug report now. 

Since I upgraded to Suse 10.3 (and have been running compiz) I don't think I've suffered this problem.

Lubos, what do you think?
Comment 27 bharatt 2008-01-09 21:22:50 UTC
hi,

thanks for mailing.

am still facing this problem

to bring it back to normalcy i logout and login again.

but the bug still exists.

regards
bharatt

On 9 Jan 2008 19:40:54 -0000, Mike Whincup <mwhincup@hotmail.com> wrote:

[bugs.kde.org quoted mail]
hi,<br><br>thanks for mailing.<br><br>am still facing this problem<br><br>to bring it back to normalcy i logout and login again.<br><br>but the bug still exists.<br><br>regards<br>bharatt<br><br><div class="gmail_quote">On 9 Jan 2008 19:40:54 -0000, Mike Whincup &lt;
<a href="mailto:mwhincup@hotmail.com">mwhincup@hotmail.com</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">
------- You are receiving this mail because: -------<br>You are on the CC list for the bug, or are watching someone who is.<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=143419" target="_blank">http://bugs.kde.org/show_bug.cgi?id=143419
</a><br><br><br><br><br></div>------- Additional Comments From mwhincup hotmail com &nbsp;2008-01-09 20:40 -------<br>Guys,<br><br>I&#39;m not sure whether to close this bug report now.<br><br>Since I upgraded to Suse 10.3 (and have been running compiz) I don&#39;t think I&#39;ve suffered this problem.
<br><br>Lubos, what do you think?<br></blockquote></div><br>
Comment 28 bharatt 2008-01-09 21:23:00 UTC
hi

didn't know whether i mentioned it or not.

am currently using fedora 8.



On 9 Jan 2008 19:40:54 -0000, Mike Whincup <mwhincup@hotmail.com> wrote:

[bugs.kde.org quoted mail]
hi<br><br>didn&#39;t know whether i mentioned it or not. <br><br>am currently using fedora 8.<br><br><br><br><div class="gmail_quote">On 9 Jan 2008 19:40:54 -0000, Mike Whincup &lt;<a href="mailto:mwhincup@hotmail.com">mwhincup@hotmail.com
</a>&gt; wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div class="Ih2E3d">------- You are receiving this mail because: -------<br>
You are on the CC list for the bug, or are watching someone who is.<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=143419" target="_blank">http://bugs.kde.org/show_bug.cgi?id=143419</a><br><br><br><br><br></div>------- Additional Comments From mwhincup hotmail com &nbsp;2008-01-09 20:40 -------
<br>Guys,<br><br>I&#39;m not sure whether to close this bug report now.<br><br>Since I upgraded to Suse 10.3 (and have been running compiz) I don&#39;t think I&#39;ve suffered this problem.<br><br>Lubos, what do you think?
<br></blockquote></div><br>
Comment 29 Lubos Lunak 2008-01-09 21:49:06 UTC
This is not a KDE problem and it's been already fixed in Compiz.
Comment 30 David Todd 2008-01-15 20:56:12 UTC
I am using Mandriva 2008 with KDE and Compiz and I STILL regularly get this bug.  Usually it happens at first login but sometimes, like just now, it happens after i have been logged in for quite a while.  It is VERY irritating!
Comment 31 Lubos Lunak 2008-01-23 00:00:27 UTC
*** Bug 151168 has been marked as a duplicate of this bug. ***
Comment 32 Mike Whincup 2008-01-23 21:30:07 UTC
Lubos - I have faith that you know what you're talking about, and that the problem lies with Compiz or KWD.

I'm just not sure how best to proceed - Others have the same symptoms. Can you give me a link so I can map this problem to KWD?...
Comment 33 Lubos Lunak 2008-01-23 23:59:39 UTC
All I know is that in this Novell/SUSE bugreport I helped to fix the problem : https://bugzilla.novell.com/show_bug.cgi?id=304184 . But for Compiz problems you have to ask Compiz developers, sorry.
Comment 34 Tommi Tervo 2008-02-08 13:36:02 UTC
*** Bug 157415 has been marked as a duplicate of this bug. ***
Comment 35 Tommi Tervo 2008-02-11 08:02:22 UTC
*** Bug 157622 has been marked as a duplicate of this bug. ***
Comment 36 Lubos Lunak 2008-02-24 21:33:32 UTC
*** Bug 158351 has been marked as a duplicate of this bug. ***
Comment 37 Thomas Lottmann 2008-03-19 22:52:13 UTC
Created attachment 23970 [details]
Generated bug kcrash report
Comment 38 Thomas Lottmann 2008-03-19 22:54:45 UTC
Running Mandriva 2008.0 with kernel 2.6.22.18

The kde-window-decorator crashed while rpmdrake finished successfully the installation of xine-faad package. This kind of crash is still very rare for me and this distribution apparently. 

Yet I attached my crash report on the comment above. 
Comment 39 Pino Toscano 2008-04-23 11:18:23 UTC
*** Bug 161184 has been marked as a duplicate of this bug. ***
Comment 40 Pino Toscano 2008-05-01 12:29:17 UTC
*** Bug 161485 has been marked as a duplicate of this bug. ***
Comment 41 Pino Toscano 2008-05-04 22:16:40 UTC
*** Bug 161636 has been marked as a duplicate of this bug. ***
Comment 42 Dvurechenski Pavel 2008-05-04 22:50:55 UTC
Я думаю это связано с программами в системном трее, в частности с kopete.
Comment 43 Pino Toscano 2008-05-10 14:23:21 UTC
*** Bug 161889 has been marked as a duplicate of this bug. ***
Comment 44 Frank Reininghaus 2008-11-13 21:50:35 UTC
*** Bug 152792 has been marked as a duplicate of this bug. ***
Comment 45 Martin Flöser 2009-09-03 21:01:02 UTC
*** Bug 206163 has been marked as a duplicate of this bug. ***
Comment 46 Martin Flöser 2010-01-01 17:51:18 UTC
*** Bug 220902 has been marked as a duplicate of this bug. ***
Comment 47 Christoph Feck 2010-02-18 00:33:35 UTC
*** Bug 227452 has been marked as a duplicate of this bug. ***
Comment 48 Christoph Feck 2010-02-25 04:47:39 UTC
*** Bug 228407 has been marked as a duplicate of this bug. ***
Comment 49 Christoph Feck 2010-03-02 23:45:40 UTC
*** Bug 229127 has been marked as a duplicate of this bug. ***
Comment 50 Christoph Feck 2010-03-09 03:33:03 UTC
*** Bug 229797 has been marked as a duplicate of this bug. ***
Comment 51 Christoph Feck 2010-03-18 17:27:03 UTC
*** Bug 231233 has been marked as a duplicate of this bug. ***
Comment 52 enet 2010-03-22 15:16:50 UTC
Created attachment 42183 [details]
New crash information added by DrKonqi

After every boot of KDE, I see this error.
I use compiz + emerald.
Comment 53 Martin Flöser 2010-03-22 15:37:12 UTC
(In reply to comment #52)
> After every boot of KDE, I see this error.
> I use compiz + emerald.
You should report this crash to the Compiz developers. Adding it here won't fix the issue. Btw you are not using emerald - the crash report says you are using kwd
Comment 54 Christoph Feck 2010-03-23 13:01:30 UTC
*** Bug 231893 has been marked as a duplicate of this bug. ***
Comment 55 Christoph Feck 2010-04-01 01:54:19 UTC
*** Bug 232914 has been marked as a duplicate of this bug. ***
Comment 56 Dario Andres 2010-04-11 00:13:28 UTC
Bug 232213 has a reference to the fix inside Compiz code for KDE4.4 code...
Comment 57 Martin Flöser 2011-01-22 14:33:03 UTC
*** Bug 233465 has been marked as a duplicate of this bug. ***
Comment 58 Christoph Feck 2011-01-24 21:24:22 UTC
*** Bug 264199 has been marked as a duplicate of this bug. ***
Comment 59 ct529 2011-01-25 09:49:56 UTC
(In reply to comment #58)
> *** Bug 264199 has been marked as a duplicate of this bug. ***

I do not think it is really a duplicate because:

1) I do not use compiz, I use kwin
2) The decorator crashes with segfault and restarts itself normally
Comment 60 ct529 2011-01-25 09:51:10 UTC
(In reply to comment #58)
> *** Bug 264199 has been marked as a duplicate of this bug. ***

Oh, and the platform is not at all OpenSUSE, it is kubuntu 1004 LTS.
Comment 61 Thomas Lübking 2011-01-25 16:18:41 UTC
(In reply to comment #59)
> (In reply to comment #58)
> I do not think it is really a duplicate because:
> 1) I do not use compiz, I use kwin

From bug #264199:
"Application: KDE Window Decorator (kde4-window-decorator), signal: Segmentation
fault"

You /do/ use compiz - running kde4-window-decorator together with kwin would be completely pointless and wrong.
Also a crash in kde4-window-decorator while kwin is your windowmanager (or virtually everything bug compiz) wouldn't lead to anything onscreen, but the crashreport - which you could safely ignore since "running kde4-window-decorator together with kwin would be completely pointless and wrong" ;-P

Most important is that the _reported_ crash is a crash in kde4-window-decorator and therefore it is (for now) a "duplicate" - even if the traces don't match exactly (still it's "outside", the reason are likely incompatible API/ABI versions)
If you experience other crashes (which are really in kwin) you'll have to report them :)
Comment 62 ct529 2011-01-25 17:14:03 UTC
(In reply to comment #61)
> (In reply to comment #59)
> > (In reply to comment #58)
> > I do not think it is really a duplicate because:
> > 1) I do not use compiz, I use kwin
> 
> From bug #264199:
> "Application: KDE Window Decorator (kde4-window-decorator), signal:
> Segmentation
> fault"
> 
> You /do/ use compiz - running kde4-window-decorator together with kwin would be
> completely pointless and wrong.
> Also a crash in kde4-window-decorator while kwin is your windowmanager (or
> virtually everything bug compiz) wouldn't lead to anything onscreen, but the
> crashreport - which you could safely ignore since "running
> kde4-window-decorator together with kwin would be completely pointless and
> wrong" ;-P
> 
> Most important is that the _reported_ crash is a crash in kde4-window-decorator
> and therefore it is (for now) a "duplicate" - even if the traces don't match
> exactly (still it's "outside", the reason are likely incompatible API/ABI
> versions)
> If you experience other crashes (which are really in kwin) you'll have to
> report them :)

Hi Thomas,

Thanks for coming back to me.

ps -ef | grep -i kwin 

reports kwin running, so does top (which actually shows xorg + kwin are consuming a vaste amount of resources).

compiz is not reported running.

Best,
What is going on here?
Comment 63 Thomas Lübking 2011-01-25 18:27:41 UTC
hard to say.
you probably ran compiz sometime in the past which successively launched kde4-window-decorator.

when you re-replaced compiz by kwin, the decorator was not shut down by compiz, stored with the session and restarted with every login (doing nothing but sucking some resources, it's not a window manager by its own but just a compiz "plugin", so there's no _real_ conflict with kwin)

at some point it then apparently crashed, but that should not have had any impact on kwin (the only result would be the crashdialog) - if there was really another issue (crash) with kwin in consequence it's not been in your report.
Comment 64 ct529 2011-01-25 20:43:16 UTC
Thanks Thomas.

I think I will clean up the installation and see what happens.

I agree w eshould consider it as invalid at this stage.