Bug 142609 - Column sizes in message list not preserved on restart or some configuration changes
Summary: Column sizes in message list not preserved on restart or some configuration c...
Status: RESOLVED DUPLICATE of bug 203251
Alias: None
Product: kmail
Classification: Applications
Component: message list (show other bugs)
Version: 1.9.9
Platform: Mandriva RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 182784 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-06 19:09 UTC by Andrey Borzenkov
Modified: 2009-09-02 00:41 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2007-03-06 19:09:58 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Mandriva RPMs
OS:                Linux

This is not the same as bug 134042.

When kmail is started, column width is automatically adjusted; as far as I understand, according to the longest items in every column. Unfortunately, it opts to show Sender and Date in full, and Subject is truncated. This leaves too little space for Subject to be able to read it in full (esp. for mailing lists that prepend list name like [SOME-LIST] or bugzilla numbers etc).

Every time I resize columns manually, but this gets lost when kmail is restarted. Once I went to options and changed option to display message MIME structure - and after that column width was reset again!

This is quite annoying. Usual behavior for GUI programs is to remember such settings automatically; but I do not see any way to save it even manually.
Comment 1 Thomas McGuire 2007-03-08 13:23:30 UTC
Related to bug #73415 I guess.
Comment 2 Thomas McGuire 2007-07-01 16:25:37 UTC
See also bug 147411.
Comment 3 Bassio 2008-06-01 22:50:14 UTC
I confirm this again. Same here Kmail 1.9.9 Using KDE 3.5.9

This occurs after changing Kmail settings.

see also this bug http://bugs.kde.org/show_bug.cgi?id=73415
Seems like a duplicate.
Comment 4 Michael Leupold 2009-03-15 11:54:44 UTC
I can no longer reproduce. KMail trunk r939506 seems to save the column width properly.
Comment 5 Michael Leupold 2009-03-15 12:20:10 UTC
*** Bug 182784 has been marked as a duplicate of this bug. ***
Comment 6 Felix Tiede 2009-08-28 10:48:03 UTC
I'm using kmail-1.12.0 from within kontact w/ IMAP/ssl.

I have the same problem when changing folders on slow connections. Also this appears on restarting kmail.
Date column is truncated and a disliked horizontal scrollbar appears. This is annoying for I have to resize subject column every time I change folders.
Comment 7 Martin Koller 2009-09-02 00:41:45 UTC

*** This bug has been marked as a duplicate of bug 203251 ***