Bug 147411 - marking and unmarking message as important leaves ugly dots instead of icon
Summary: marking and unmarking message as important leaves ugly dots instead of icon
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: message list (show other bugs)
Version: 1.9.7
Platform: OpenSUSE Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2007-07-01 09:08 UTC by Maciej Pilichowski
Modified: 2009-08-17 19:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dots (86.96 KB, image/png)
2007-07-01 12:49 UTC, Maciej Pilichowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2007-07-01 09:08:39 UTC
Version:            (using KDE KDE 3.5.7)
Installed from:    SuSE RPMs

The subject says it all. Happens every time.

The subject says it all. Happens every time.
Comment 1 Thomas McGuire 2007-07-01 11:32:10 UTC
Well, it doesn't happen for me, works fine here.
Can you perhaps attach a screenshot?
Maybe some special circumstances are causing this, it would be nice to know which.
Comment 2 Maciej Pilichowski 2007-07-01 12:48:31 UTC
I didn't describe the way to reproduce, I am sorry.

Run KMail, set mail as important, quit Kmail (!), unmark the mail.

Comment 3 Maciej Pilichowski 2007-07-01 12:49:00 UTC
Created attachment 21000 [details]
dots
Comment 4 Thomas McGuire 2007-07-01 16:28:12 UTC
Thanks for the screenshot, it cleared things up a bit.
The bug only happens when the "important" column is shown (it is hidden by default), and indeed only after restarting KMail.

The problem seems to be that KMail resizes the columns at every restart. So the "important" column gets resized as well. 
If something doesn't fit into a column, dots ("...") are displayed. The empty important flag doesn't fit for some reason, therefore you see the dots.

Probably very similar to bug 142609.
Comment 5 Maciej Pilichowski 2007-07-02 10:42:38 UTC
> If something doesn't fit into a column, dots ("...") are displayed. 

I didn't observe this -- if any icon does not fit, it is just cut-off.
Comment 6 Michael Leupold 2009-04-05 09:34:42 UTC
I don't observe this bug with the new message list any longer (trunk r948809). The original problem seems to be that removing the important mark resizes the column. This is no longer reproducible.

There are other quirks such as column order not being saved but these are already reported. Time to close this bug I guess.
Comment 7 Martin Koller 2009-08-17 19:42:58 UTC
Yep, let's close it