Bug 139563 - Support for MPD in Now Listening
Summary: Support for MPD in Now Listening
Status: RESOLVED INTENTIONAL
Alias: None
Product: kopete
Classification: Unclassified
Component: Now Listening Plugin (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
: 148950 162534 164080 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-03 17:58 UTC by Alex Merry
Modified: 2012-06-11 12:23 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch for Kopete SVN (including libmpdclient.{c,h}) (74.41 KB, patch)
2007-01-03 17:59 UTC, Alex Merry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Merry 2007-01-03 17:58:24 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

I use the Music Player Daemon (http://www.musicpd.org) to listen to music, not least because it allows me to maintain control of playback when switching users.  I'd really like to advertise the currently playing song to my IM contacts.

So, I wrote a patch for the Now Listening plugin to allow this.  Due to the feature freeze on 3.5, I'm not submitting a patch for that version, but I'm attaching the patch for the current SVN version.

One design issue that might crop up is the fact that I've simply dropped libmpdclient.{c,h} into the Now Listening directory.  Why this way?  Well, I didn't depend on it externally because the small size of the library means that distributions don't necessarily package it separately (mpd clients, including ncmpc at least, include it in their sources).  I didn't trim it down because that would increase the maintenance load for future updates (including bugfix releases) of libmpdclient.  I didn't depend on libmpd (a signal-based C++ version) instead because it seemed overkill for simply getting a bit of status info.

Unfortunately, this approach introduces a swathe of compiler warnings from libmpdclient.c.

I'm happy to make nlmpd.cpp self-contained (ie: not depending on libmpdclient) by extracting the relevant code from libmpdclient if you want me to.  I can also depend on libmpd instead if you like.
Comment 1 Alex Merry 2007-01-03 17:59:52 UTC
Created attachment 19095 [details]
Patch for Kopete SVN (including libmpdclient.{c,h})
Comment 2 Pino Toscano 2007-08-18 02:37:30 UTC
*** Bug 148950 has been marked as a duplicate of this bug. ***
Comment 3 Pino Toscano 2008-05-23 21:05:19 UTC
*** Bug 162534 has been marked as a duplicate of this bug. ***
Comment 4 Dennis Nienhüser 2008-06-14 18:22:32 UTC
*** Bug 164080 has been marked as a duplicate of this bug. ***
Comment 5 Dennis Schridde 2009-02-15 01:25:06 UTC
I agree that this would be a nice addition to the now-listening plugin. Is there any chance to integrate this into 4.3? (Or even 4.2.1?)
Comment 6 Alex Merry 2009-02-15 01:28:42 UTC
No chance for 4.2.1.

This reminds me, I was going to create a little library for remotely controlling media players.  I should get around to that soon, really.  It would be useful for both Kopete and the nowplaying engine in Plasma.
Comment 7 Zsolt Peter Basak 2009-06-14 11:05:13 UTC
Please add this feature to 4.3. I use GMPC + MPD. Works flawless. I dont want to switch to amarok just for this.. I somewhat hate sluggy and fat music players. Thanks.
Comment 8 Alex Merry 2009-06-14 12:02:53 UTC
Sorry, it's not going to happen for 4.3 - we're way past the feature freeze.

Hopefully I can find someone to help me hash out a design for a shared nowplaying/nowlistening library for the use of both Kopete and Plasma (and anything else that cares) at Akademy, and we can put something in 4.4... The Kopete guys seemed quite receptive to this idea.
Comment 9 Zsolt Peter Basak 2009-06-14 12:11:40 UTC
I don't get it.. I don't get it. Never look back, this is the future DE, etc.. bull.... Never look back, but don't even improve the applications? Great thinking.. congratulation (Nice way to mimic Gnome's ideology.. what made that DE FUBAR).

By the way 4.4 is Sooooo far away. I guess I'll just stick to LXDE until then. :-/
Comment 10 Alex Merry 2009-06-14 12:18:54 UTC
No... don't "improve" the applications just before you release them.  Otherwise you WILL break them.  Developers are only human, and therefore any code they write is almost certain to include bugs.  The feature freeze is to allow devs to work on removing the bugs, rather than adding more.
Comment 11 Zsolt Peter Basak 2009-06-14 12:35:52 UTC
I know what is feature freeze. But since this bug was opened in 3.5... its time to 'fix' it... So to say. And by just adding a libmpd ..break the app? That would be a bit strange. (It needs skills to break an app just with that.)
Comment 12 Lamarque V. Souza 2011-04-03 01:09:50 UTC
I think you can use http://mpd.wikia.com/wiki/Client:MpDris as a gateway between mpd and mpris. Now Listening plugin supports mpris music players, so it probably supports MpDris's mpris interface.

In my oppinion adding libmpdclient.{c,h} to Kopete source code is overkill to have just this feature.
Comment 13 Alex Merry 2012-06-11 12:23:25 UTC
Actually, I'd officially like to withdraw this, as I think the correct solution is to have MPRIS2 support and use a bridge between MPD and MPRIS2, like https://github.com/eonpatapon/mpDris2

I'm going to resolve this as WONTFIX, since the maintainer has shown no interest in this, and I was the original submitter.