Bug 127153 - Transfer files to directory where they've been dropped
Summary: Transfer files to directory where they've been dropped
Status: RESOLVED DUPLICATE of bug 176858
Alias: None
Product: amarok
Classification: Applications
Component: Collections/Media Devices (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-11 19:47 UTC by Elias Probst
Modified: 2009-08-03 12:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2006-05-11 19:47:47 UTC
Version:           SVN (539774) (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages

When using a generic Mass-Storage-Mediadevice, it would be nice to be able to transfer tracks to the folder, where they've been dropped.
For example, when using an USB-Stick which contains also data, you maybe have a folder structure like this:

Device
|
+--Data
|
+--MyMusic
|
+--MusicTransferredFromJohnDoesPC
|
+--MusicTransferredFromJacksPC

So one time, you drop the tracks to "MyMusic", another time you drop it to "MusicTransferredFromJacksPC" ... 
Currently, all transferred tracks are placed in the root directory or in the directory created by the grouping settings like "Artist/Album/Track.mp3".

Thank you!
Comment 1 Marco Laverdière 2006-08-05 21:32:05 UTC
I'm voting for this!  I have the same need here.
Comment 2 FACORAT Fabrice 2007-01-12 18:03:24 UTC
This is still valid as of today ( amarok-1.4.4, kde 3.5.5, Mandriva cooker rpm )

IMHO this is a very usefull feature.
At present amarok is customising too much things by itself ( mp3 file renaming bug #139980, default mp3 location bug #134860, ... ).

IMHO when doing the drag&drop, amarok should remember in the transfert queue the directory/location where the file was dropped and copy the file to this directory/location.

The ability to automate the directory where the songs can be put should only be enable on the user query in the media settings.
Comment 3 David Laban 2007-11-15 17:18:03 UTC
If you want to do crazy file-management tasks, you should really use a file-manager: Just drag and drop your files from amarok's playlist to a folder in konqueror (you can even get konq to automatically open when you plug in your device :D) and it will transfer instantly, without waiting for you to click okay.

*doesn't vote for this bug, as it would cause too many crazy things to happen, especially with things like ipods which don't have a directory structure as such*

I suppose a useful alternative to your solution (without having to leave amarok) would be to allow you to drop songs into the "files" tab to copy them there (and maybe a "browse here" button in the devices tab).
Comment 4 Elias Probst 2008-12-11 01:46:30 UTC
@David Laban: That's IMHO no crazy filemanagement task - it's just a drag'n'drop operation which currently doesn't behave as expected.

I don't see a problem about iPods here... the iPod plugin should just ignore the 'Path' attribute of objects in the transfer queue - that's all.

But as Amarok-1.4 isn't developed any further, we should wait a little bit until 2.x settles and how the portable device support will look like there.

Keeping this bug open for some further time....
Comment 5 Myriam Schweingruber 2009-08-03 12:09:09 UTC

*** This bug has been marked as a duplicate of bug 176858 ***