Bug 176858 - MTP: All files are stored in the root folder of the device
Summary: MTP: All files are stored in the root folder of the device
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/MTP player (show other bugs)
Version: 2.3-GIT
Platform: Compiled Sources Unspecified
: NOR normal with 25 votes (vote)
Target Milestone: 2.3.1
Assignee: Amarok Developers
URL:
Keywords:
: 127153 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-04 06:29 UTC by Rafael Tesser
Modified: 2011-12-20 11:45 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
output of amarok -d (94.04 KB, text/plain)
2008-12-04 06:30 UTC, Rafael Tesser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Tesser 2008-12-04 06:29:59 UTC
Version:           2.0-SVN (using Devel)
Installed from:    Compiled sources

When I transfer files to my mtp device (Sony NWZ S616F) using amarok they are stored in the root directory instead of in the MUSIC directory as it should be done.
Comment 1 Rafael Tesser 2008-12-04 06:30:48 UTC
Created attachment 29029 [details]
output of amarok -d
Comment 2 Alejandro Wainzinger 2008-12-09 08:16:05 UTC
Yes, people who have both the option of MTP and MSC have mentioned this but never got around to filing the bug for it.  Thanks for reporting.
Comment 3 Jonathan Herdt 2009-06-28 21:38:24 UTC
This bug is quite annoying since it makes my player unfillable while Amarok is running. Even worse, Amarok will automatically mount my player in MTP-mode and there is no way I can change back to normal-mode except plugging it out, closing Amarok and plugging it in again. If I could just choose not to automount my player in MTP-mode, everything would be fine again.
Comment 4 Myriam Schweingruber 2009-08-02 17:07:29 UTC
Alejandro, any news on this?
Comment 5 Myriam Schweingruber 2009-08-03 12:09:09 UTC
*** Bug 127153 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Herdt 2009-09-25 08:44:26 UTC
Still present in 2.2 RC1 (2.1.90).
How about providing an option where the user can give a pattern. According to that pattern, files would be transferred to the MTP-device (e.g. "MUSIC/%Interpret/%Album/%Filename"). Would be great to be able to fill my MTP-/UMS-device with music, using Amarok.
For me, even an option to not automount the device would suffice. Currently Amarok still must be closed to organize my files. If I start it, it will automount the device again (no matter if it's already mounted as an UMS-device).

If it would be of any help, I could send my device to someone (prefferably someone from Germany) and provide the means to sending it back again.
Comment 7 Myriam Schweingruber 2009-11-04 00:24:06 UTC
Changing version.
Comment 8 Myriam Schweingruber 2009-11-16 13:42:34 UTC
I can't reproduce this with my Sansa Clip on Amarok 2.2-git, assuming this is solved now in 2.2.1
Comment 9 Rafael Tesser 2009-11-17 19:28:00 UTC
This is not solved in 2.2.1 for me. The files continue to be stored in the root folder. The device is a Sony NWZ-S616F.
Comment 10 Rafael Tesser 2010-01-05 21:14:41 UTC
It seems that it's a bug in libmtp that is causing the problem for me. I reported the bug upstream but didn't get any response yet. Here's the link for the upstream bug:

http://sourceforge.net/tracker/index.php?func=detail&aid=2899346&group_id=158745&atid=809061
Comment 11 Rafael Tesser 2010-01-27 00:20:02 UTC
This may be fixed with the cvs version of libmtp, as you can see in the bug report I have linked in my previous comment. However, I wasn't able to test Amarok with this version. I guess you have to rebuild amarok to do so. With Rhythmbox it stored the files in the folder named "music" in the device. I think I'll have to wait for a new release o libmtp to try this with Amarok.
Comment 12 Rafael Tesser 2010-03-01 19:44:23 UTC
It was a bug in libmtp that caused this problem for me. It's fixed in libmtp-1.0.2. Now the files I copy to my device are correctly placed in the MUSIC folder.
Comment 13 Jonathan Herdt 2010-03-02 10:23:51 UTC
Yeah, right now the files get stored inside the MUSIC-folder but still, there are no (sub-)folders created for albums and artists. Well, I guess this has to go into a separate bug report (better: wish).