Bug 117809 - Written Data Check error with international characters' filenames
Summary: Written Data Check error with international characters' filenames
Status: RESOLVED DUPLICATE of bug 83315
Alias: None
Product: k3b
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-06 18:35 UTC by Aleksey Kontsevich
Modified: 2005-12-07 02:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Kontsevich 2005-12-06 18:37:38 UTC
Version:           0.12.8 (using KDE 3.4.2-1.2.kde, Fedora)
Compiler:          Target: athlon-redhat-linux
OS:                Linux (i686) release 2.6.13-1.1526_FC4

The same problem in all k3b versions over years: 
- k3b fails to check successfully written data when option "Verify written data" is on. Writing Data CD Dialog shows "Could not find file ..." message

- Window users see russian filenames like "________ ________" 

I have russian UTF8 locale. As I know CD filenames standard claims utf8 characters. So I don't realize even how this error could happen in UTF8 locale. May be you should add "utf-8" in "Force input charset" option or smth like this? 

The same problems descriptions you can find here: 

http://k3b.plainblack.com/message-board/international-chars-on-winxp-please-help#6Fg3PEWVhOZS7mdYYJwVww
http://k3b.plainblack.com/message-board/international-characters-on-windows-xp?layout=flat#zK75Fgl-EcQhAof2m2Gmuw
http://bugs.kde.org/show_bug.cgi?id=100646
http://bugs.kde.org/show_bug.cgi?id=113924
http://bugs.kde.org/show_bug.cgi?id=64990
http://bugs.kde.org/show_bug.cgi?id=90977
http://bugs.kde.org/show_bug.cgi?id=83315

And no acceptable response yet.

Best regards, 
Aleksey.
Comment 1 Sebastian Trueg 2005-12-06 19:00:36 UTC
> The same problems descriptions you can find here:
>
> http://k3b.plainblack.com/message-board/international-chars-on-winxp-please
>-help#6Fg3PEWVhOZS7mdYYJwVww
> http://k3b.plainblack.com/message-board/international-characters-on-windows
>-xp?layout=flat#zK75Fgl-EcQhAof2m2Gmuw
> http://bugs.kde.org/show_bug.cgi?id=100646
> http://bugs.kde.org/show_bug.cgi?id=113924
> http://bugs.kde.org/show_bug.cgi?id=64990
> http://bugs.kde.org/show_bug.cgi?id=90977
> http://bugs.kde.org/show_bug.cgi?id=83315


then why did you open yet another bug report for this??? I know this bug. It 
will be fixed eventually.
Comment 2 Aleksey Kontsevich 2005-12-06 20:20:23 UTC
>then why did you open yet another bug report for this???

I knew about 83315 during bug report and I did not want to abort my report. Also to show you how many people want this bug to be fixed and to remind about my past reports. And becasue problem not only with "Verifying written data" and also with international character filenames in Windows.

>eventually

I understand that k3b is free development but when will come this "eventually"? :) Its about one and a half year since http://bugs.kde.org/show_bug.cgi?id=83315 bug.
Comment 3 Sebastian Trueg 2005-12-06 20:35:47 UTC
I am only one man on all this and verification does not interest me that much. 
That's why I keep moving this bug down the todo list... but I will do it 
soon. I promise. :) please close the duplicate bug reports.
Comment 4 Aleksey Kontsevich 2005-12-06 21:39:09 UTC
>I am only one man on all this

It is sadly to hear such things about the most popular CD/DVD burning application in Linux 

>but I will do it soon. I promise. :) 

I trust You :)

>please close the duplicate bug reports.
The report is half duplicate ;) So I do not whant to close it. What about: "international-characters-on-windows" ?
Comment 5 Thiago Macieira 2005-12-07 02:52:12 UTC

*** This bug has been marked as a duplicate of 83315 ***