Bug 83315 - Verifycation fails when burning files with international characters
Summary: Verifycation fails when burning files with international characters
Status: RESOLVED FIXED
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 175 votes (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 117809 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-13 19:54 UTC by Oldřich Jedlička
Modified: 2006-11-16 12:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oldřich Jedlička 2004-06-13 19:54:35 UTC
Version:           0.11.10 (using KDE KDE 3.2.3)
Installed from:    Gentoo Packages
OS:                Linux

When burning on-the-fly file names in iso-8859-2, verifycation fails with an error - Could not find file (projects/datacd/k3bdataverifyingjob.cpp). I tried it on a DVD-RW and even with Force input charset iso-8859-2, verifycation fails.

Parameters: Rockridge and Joilet extensions on. Burning on-the-fly with verifycation. Defaults used. With and without Force input charset: iso-8859-2.
Comment 1 Jan Trmal 2004-06-13 20:29:51 UTC
I must confirm this bug. I have the ISO-8859-2 file system with internationalized file names (žšč...), too, and after burning on-the-fly or with intermediate image the verifying fails with "Could not find file XYZ" error message. I tested it on my CD-RW medium.
Comment 2 is 2004-06-29 17:52:05 UTC
I've also had this problem, but with an iso-8859-1 filesystem. I think the problem is that K3B always interprets filenames in the encoding in which it was started (UTF-8 in my case). 
Comment 3 Peter Volkov 2004-12-30 10:18:19 UTC
k3b-0.11.18 and it seems to me I have the same bug...
Comment 4 Gilles Schintgen 2005-04-01 11:49:00 UTC
Same problem here. I'm using 0.11.22 and it always fails with non-ASCII names. My system encoding is UTF-8, and I'm always burning Rockridge-only CDs. What's interesting is that, in the error message, the filename that cannot be found is shown correctly. When I have a look at the CD (in k3b itself) the file is there, and it's shown correctly.
Comment 5 Matthias Pospiech 2005-08-20 10:12:17 UTC
Here with Suse 9.3 Kde 3.4.2 and k3b 0.12.3 the same.
In my case its german umlaute that cause the problem.

Matthuas
Comment 6 cornel panceac 2005-09-06 11:35:23 UTC
since i remember k3b i remember unable to vrify non "standard" chars. ver 0.12.2 . 
i think the problem is, k3b is converting the chars when reading source only on verification stage only. i use only rockridge extension while allowing 103 chars joliet filenames and untranslated iso9660 filenames. iso level 2. and i do not force input charset.
Comment 7 Michael Stather 2005-09-17 13:45:17 UTC
I can conform that when burning with german umlauts the verification fails, but the files are present on the CD.
Please fix this as its very important IMHO
Comment 8 Jure Repinc 2005-10-09 13:31:19 UTC
I have the same problem here with special Slovenian characters and ISO-8859-2 charset. K3b 0.12.4a on KDE 3.4.2. When can we expect to see the fix?
Comment 9 Oldřich Jedlička 2005-10-10 10:59:23 UTC
I already lost my faith and hope. I thought that verification is very important feature, but maybe I was wrong.
Comment 10 Sebastian Trueg 2005-10-12 12:34:40 UTC
probably after I finished my diploma thesis...
Comment 11 Matthias Pospiech 2005-10-22 00:11:38 UTC
It still fails with 0.12.4a...

which esentially means that I can as well turn of testing because it fails always!

Matthias
Comment 12 Sebastian Trueg 2005-10-22 12:22:47 UTC
that's because I did not fix it yet. This is a bigger thing and I don't have 
the time right now...
Comment 13 Micho 2005-12-05 16:52:45 UTC
A YES/NO dialog asking for continue should fix temporarily this problem :)
Comment 14 Micho 2005-12-05 16:55:11 UTC
A simple YES/NO dialog asking for continue should temporarily fix this problem. At least it wont burn bad disk.
Comment 15 Sebastian Trueg 2005-12-05 17:46:49 UTC
how? what is k3b supposed to ask and based on what check?
Comment 16 Thiago Macieira 2005-12-07 02:52:14 UTC
*** Bug 117809 has been marked as a duplicate of this bug. ***
Comment 17 Sebastian Trueg 2005-12-10 13:54:33 UTC
SVN commit 487359 by trueg:

Copied iso9660 filename generation code from mkisofs. With it K3b is able
to determine the iso9660 names generated by mkisofs and use them for data
project verification.
The result is: no charset problems anymore.

BUG: 90974
BUG: 84544
BUG: 90977
BUG: 105649
BUG: 113052
BUG: 83315
BUG: 80593


 M  +620 -39   projects/datacd/k3bdatadoc.cpp  
 M  +2 -0      projects/datacd/k3bdatadoc.h  
 M  +11 -0     projects/datacd/k3bdataitem.cpp  
 M  +15 -3     projects/datacd/k3bdataitem.h  
 M  +1 -2      projects/datacd/k3bdataverifyingjob.cpp  
 M  +109 -29   tools/k3biso9660.cpp  
 M  +29 -2     tools/k3biso9660.h  
Comment 18 Oldřich Jedlička 2005-12-10 15:40:41 UTC
Great :-) Thanks a lot.

I'm looking forward to new release to try it :-)
Comment 19 Pavel Gurevich 2005-12-10 15:43:04 UTC
Thanks! Turning on verification again from the next release!
Comment 20 Aleksey Kontsevich 2005-12-10 20:45:41 UTC
Hurrah, Hurray!!! Thank you VERY VERY much!!! :) 

And how international caracters will look in Windows now? Correctly?
Comment 21 Sebastian Trueg 2005-12-11 04:06:17 UTC
On Saturday 10 December 2005 20:45, GladAlex wrote:
> And how international caracters will look in Windows now? Correctly?


That should not have changed. sorry.
Comment 22 Aleksey Kontsevich 2005-12-11 17:26:23 UTC
> > And how international caracters will look in Windows now? Correctly?
> That should not have changed. sorry.


Why? What about the future? Why international characters in CD recorded in 
windows look correctly in linux, but not vice versa?
Comment 23 Sebastian Trueg 2005-12-11 17:28:50 UTC
probably updating mkisofs fixes the problem. It did here. mkisofs 2.1 works.
Comment 24 Aleksey Kontsevich 2005-12-20 23:32:34 UTC
Verifycation STILL fails!!!
Comment 25 Sebastian Trueg 2005-12-21 01:17:16 UTC
hmm... not good.
which locale?
Could you also give me some filenames (that fail in verification) so I can recreate the problem here.
Comment 26 tropikhajma 2006-11-13 22:51:28 UTC
It is difficult to catch it, sometimes it works, sometimes not and I haven't found a reproducible setup yet. However it might be related that when running k3b from within a directory containing international characters in its name, the following error messages appear:

[hajma@localhost Písně Středozemě]$ LANGUAGE=C k3b --nofork
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory


I'm using cs_CZ (czech) locale with iso-8859-2
Comment 27 Sebastian Trueg 2006-11-16 12:35:08 UTC
K3b 1.0 will fix the problem once and for all.