Bug 117373 - Konqueror doesn't pass acid2 test anymore
Summary: Konqueror doesn't pass acid2 test anymore
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 118101 138939 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-11-30 19:30 UTC by Thomas Bettler
Modified: 2006-12-18 08:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
snapshot.jpg (44.33 KB, image/jpeg)
2005-11-30 21:02 UTC, Thomas Bettler
Details
Another Konqueror instance failing ACID2 (7.01 KB, image/png)
2005-11-30 23:19 UTC, Vadym Krevs
Details
test failed (34.15 KB, image/png)
2005-12-01 00:00 UTC, Anton
Details
snapshot2.jpg (12.73 KB, image/jpeg)
2005-12-01 01:21 UTC, Thomas Bettler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Bettler 2005-11-30 19:30:15 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Gentoo Packages
Compiler:          gcc-3.3.5 
OS:                Linux

Konqueror doesn't pass acid2 test anymore

I whish there was a backport from HEAD to 3.5 BRANCH

See Bug #109195 for more details
Comment 1 Tommi Tervo 2005-11-30 20:53:57 UTC
Works fine for me (3.5). Which error do you get?
Comment 2 Thomas Bettler 2005-11-30 21:02:17 UTC
Created attachment 13692 [details]
snapshot.jpg

Here you are
Comment 3 Maksim Orlovich 2005-11-30 21:31:37 UTC
Try lowering your minimal font size
Comment 4 Vadym Krevs 2005-11-30 23:19:29 UTC
Created attachment 13700 [details]
Another Konqueror instance failing ACID2

Running on Suse 10.0, with todays KDE 3.5 RPMs for SuSE 10.0 for x86

rpm -qf `which konqueror`=kdebase3-3.5.0-15
Comment 5 Anton 2005-12-01 00:00:45 UTC
Created attachment 13701 [details]
test failed

I can confirm the bug with my gentoo (~x86)
konqueror 3.5.0 release does not pass the acid2 test for some reason.

/etc/make.conf:

CHOST="i686-pc-linux-gnu"
CFLAGS="-Os -pipe -march=pentium4 -fomit-frame-pointer -fforce-addr"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

USE="-gtk -gnome qt kde kdeenablefinal alsa cdr nls nptl nptlonly wifi pcmcia
sdk xine irda sse sse2 mmx"
Comment 6 Thomas Bettler 2005-12-01 01:21:12 UTC
Created attachment 13702 [details]
snapshot2.jpg

It didn't help to change minimum font size, neither medium.

I use Helvetica 7 / 10 but neither changing to 5/10 nor to 7/12 changed things
remarkably. Then I switched to 120%, that displayed it nearly correctly the
face quasi matches, though the eyes still are excentric and the red bar bottom
left remains.

Any help is welcome.
What Font settings are you using for correct display?
Comment 7 Thiago Macieira 2005-12-01 04:26:43 UTC
Works fine on r477777.
Comment 8 Anton 2005-12-01 13:24:14 UTC
Ok, I manage to fix it in a half way.
It was really font settings. I changed it to the 7/14,
run new version of browser and it's ok. 
However red bar is still there.

Comment 9 Tommi Tervo 2005-12-01 13:40:34 UTC
I have 9/10 and it works fine on my work desktop too. Maybe you have your display DPI settings wrong? xdpyinfo |grep resolution should give something like this: 99x98 dots per inch.
Comment 10 Allan Sandfeld 2005-12-02 14:57:14 UTC
All the images in this bug-report are wrong font-sizes. PLEASE read the guide to the Acid2 test before report problems. It is a _VERY_ fragile test by design and the authors have refused to fix it.

If you do not have standard DPI or standard font-sizes it will break.
Comment 11 Thomas Bettler 2005-12-07 22:21:15 UTC
Yes, you are right. I didn't know that there is a relevance in the DPI setting. I now adjusted it to 100dpi and Acid2 smiles correct, exept the red bar below line 14 indicates there is still something wrong, but not the font setting.

Maybe that error is gentoo related? Can you report what distro you're using?
Thanks
Comment 12 Thomas Bettler 2005-12-07 22:25:23 UTC
Reopening bug, since after row 14 there are still errors
Comment 13 Thiago Macieira 2005-12-07 23:02:58 UTC
Still working. In fact, it has never stopped working. I've tested KHTML r477777 and r486450.

I'm running at 90dpi (which khtml raises to 96dpi when rendering) and font minimum/medium sizes at 9pt.
Comment 14 Thomas Bettler 2005-12-08 00:28:33 UTC
Ok. But you neither have an idea how to correct this behaviour? What might be the reason?
Comment 15 Thiago Macieira 2005-12-08 00:57:01 UTC
Try the same settings (DPI, font sizes, etc.).
Comment 16 Thomas Bettler 2005-12-09 13:24:07 UTC
I got it! Obviously it has something to do with the konqueror font config.
As Serif font use 'Serif' instead of 'Times' and the bug's gone!
Comment 17 Tommi Tervo 2005-12-11 11:48:00 UTC
*** Bug 118101 has been marked as a duplicate of this bug. ***
Comment 18 Tommi Tervo 2006-12-18 08:46:11 UTC
*** Bug 138939 has been marked as a duplicate of this bug. ***