Bug 444687

Summary: Gwenview crashes after clicking Network/SMB (even though no SMB share are defined or connected in the system)
Product: frameworks-kio Reporter: kde
Component: generalAssignee: KIO Bugs <kio-bugs-null>
Status: RESOLVED WORKSFORME    
Severity: crash CC: a.samirh78, kdelibs-bugs, nate
Priority: NOR Keywords: drkonqi
Version: 5.87.0   
Target Milestone: ---   
Platform: Neon Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description kde 2021-10-30 21:17:24 UTC
Application: gwenview (21.08.2)

Qt Version: 5.15.3
Frameworks Version: 5.87.0
Operating System: Linux 5.11.0-38-generic x86_64
Windowing System: X11
Distribution: KDE neon User - Plasma 25th Anniversary Edition
DrKonqi: 5.23.2 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
open gwenview, click on "Network in the right side, double click on "shared folders (smb), gwenview crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted

[New LWP 4472]
[New LWP 4473]
[New LWP 4476]
[New LWP 4477]
[New LWP 4478]
[New LWP 4479]
[New LWP 4485]
[New LWP 4498]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f73c0a3caff in __GI___poll (fds=0x7fff6a7e63f8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
__preamble__
[Current thread is 1 (Thread 0x7f73baca7c40 (LWP 4471))]

Thread 9 (Thread 0x7f73b35ae700 (LWP 4498)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c896210) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c8961c0, cond=0x55778c8961e8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c8961e8, mutex=0x55778c8961c0) at pthread_cond_wait.c:638
#3  0x00007f73c0dcf5cb in QWaitConditionPrivate::wait (deadline=..., this=0x55778c8961c0) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=this@entry=0x7f73b4003270, mutex=mutex@entry=0x7f73b4003268, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007f73c2d5d069 in Gwenview::ThumbnailGenerator::run (this=0x7f73b4003200) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  0x00007f73c0dc945c in QThreadPrivate::start (arg=0x7f73b4003200) at thread/qthread_unix.cpp:329
#7  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7f7399847700 (LWP 4485)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c4749e0) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c474990, cond=0x55778c4749b8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c4749b8, mutex=0x55778c474990) at pthread_cond_wait.c:638
#3  0x00007f73c0dcf5cb in QWaitConditionPrivate::wait (deadline=..., this=0x55778c474990) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=this@entry=0x55778c20ddd0, mutex=mutex@entry=0x55778c20ddc8, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007f73c2d5d069 in Gwenview::ThumbnailGenerator::run (this=0x55778c20dd60) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  0x00007f73c0dc945c in QThreadPrivate::start (arg=0x55778c20dd60) at thread/qthread_unix.cpp:329
#7  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f73a67fc700 (LWP 4479)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c3e9bf8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c3e9ba8, cond=0x55778c3e9bd0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c3e9bd0, mutex=0x55778c3e9ba8) at pthread_cond_wait.c:638
#3  0x00007f73b0933e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f73b0933a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f73a6ffd700 (LWP 4478)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c3e9bf8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c3e9ba8, cond=0x55778c3e9bd0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c3e9bd0, mutex=0x55778c3e9ba8) at pthread_cond_wait.c:638
#3  0x00007f73b0933e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f73b0933a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f73a77fe700 (LWP 4477)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c3e9bf8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c3e9ba8, cond=0x55778c3e9bd0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c3e9bd0, mutex=0x55778c3e9ba8) at pthread_cond_wait.c:638
#3  0x00007f73b0933e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f73b0933a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f73a7fff700 (LWP 4476)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55778c3e9bf8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55778c3e9ba8, cond=0x55778c3e9bd0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55778c3e9bd0, mutex=0x55778c3e9ba8) at pthread_cond_wait.c:638
#3  0x00007f73b0933e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f73b0933a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f73b8f39700 (LWP 4473)):
#0  0x00007f73c0a3caff in __GI___poll (fds=0x7f73ac012c10, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f73be44636e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f73be4464a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f73c100a61b in QEventDispatcherGlib::processEvents (this=0x7f73ac000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f73c0fae8ab in QEventLoop::exec (this=this@entry=0x7f73b8f38930, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f73c0dc82c2 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f73c126bf4b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f73c0dc945c in QThreadPrivate::start (arg=0x7f73c12efd80) at thread/qthread_unix.cpp:329
#8  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f73ba139700 (LWP 4472)):
#0  0x00007f73c0a3caff in __GI___poll (fds=0x7f73ba138868, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f73be3d5c1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f73be3d790a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f73ba887e88 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f73c0dc945c in QThreadPrivate::start (arg=0x55778bcebea0) at thread/qthread_unix.cpp:329
#5  0x00007f73bed59609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f73c0a49293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f73baca7c40 (LWP 4471)):
[KCrash Handler]
#4  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#5  0x00007f73c094c859 in __GI_abort () at abort.c:79
#6  0x00007f73c270102f in ?? () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#7  0x00007f73c281215b in ?? () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#8  0x00007f73c0fe6dce in QtPrivate::QSlotObjectBase::call (a=0x7fff6a7e76a0, r=0x7f73c2892520, this=0x55778c875d30) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#9  doActivate<false> (sender=0x55778c7bd7a0, signal_index=6, argv=0x7fff6a7e76a0) at kernel/qobject.cpp:3886
#10 0x00007f73c0fe0197 in QMetaObject::activate (sender=sender@entry=0x55778c7bd7a0, m=m@entry=0x7f73c1425720 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff6a7e76a0) at kernel/qobject.cpp:3946
#11 0x00007f73c13d0d10 in KJob::result (this=this@entry=0x55778c7bd7a0, _t1=<optimized out>, _t1@entry=0x55778c7bd7a0, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#12 0x00007f73c13d218b in KJob::finishJob (this=0x55778c7bd7a0, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:98
#13 0x00007f73c27b20f8 in KIO::SimpleJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#14 0x00007f73c27a844e in KIO::ListJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#15 0x00007f73c0fe6dce in QtPrivate::QSlotObjectBase::call (a=0x7fff6a7e78b0, r=0x55778c7bd7a0, this=0x55778c6d1b90) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#16 doActivate<false> (sender=0x55778bda8430, signal_index=7, argv=0x7fff6a7e78b0) at kernel/qobject.cpp:3886
#17 0x00007f73c277ed42 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#18 0x00007f73c277ca3f in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007f73c27859a2 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#20 0x00007f73c0fe6dce in QtPrivate::QSlotObjectBase::call (a=0x7fff6a7e7b20, r=0x55778bda8430, this=0x55778c7f51e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#21 doActivate<false> (sender=0x55778c89ec80, signal_index=3, argv=0x7fff6a7e7b20) at kernel/qobject.cpp:3886
#22 0x00007f73c0fdd949 in QObject::event (this=0x55778c89ec80, e=0x55778c89b480) at kernel/qobject.cpp:1314
#23 0x00007f73c1d71dc3 in QApplicationPrivate::notify_helper (this=this@entry=0x55778bce7960, receiver=receiver@entry=0x55778c89ec80, e=e@entry=0x55778c89b480) at kernel/qapplication.cpp:3632
#24 0x00007f73c1d7abb8 in QApplication::notify (this=0x7fff6a7e81e0, receiver=0x55778c89ec80, e=0x55778c89b480) at kernel/qapplication.cpp:3156
#25 0x00007f73c0fafdaa in QCoreApplication::notifyInternal2 (receiver=0x55778c89ec80, event=0x55778c89b480) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#26 0x00007f73c0fb26b1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55778bcc00d0) at kernel/qcoreapplication.cpp:1821
#27 0x00007f73c100afa7 in postEventSourceDispatch (s=0x55778bdb3b30) at kernel/qeventdispatcher_glib.cpp:277
#28 0x00007f73be44617d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f73be446400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f73be4464a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f73c100a602 in QEventDispatcherGlib::processEvents (this=0x55778bdae7b0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#32 0x00007f73c0fae8ab in QEventLoop::exec (this=this@entry=0x7fff6a7e80d0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#33 0x00007f73c0fb6a64 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#34 0x000055778b57d56d in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:202
[Inferior 1 (process 4471) detached]

The reporter indicates this bug may be a duplicate of or related to bug 341098, bug 412235.

Possible duplicates by query: bug 443651, bug 443460, bug 443069, bug 442652, bug 441542.

Reported using DrKonqi
Comment 1 Nate Graham 2021-11-08 17:35:55 UTC
Cannot reproduce. Crashing somewhere in KIO for you:

#11 0x00007f73c13d0d10 in KJob::result (this=this@entry=0x55778c7bd7a0, _t1=<optimized out>, _t1@entry=0x55778c7bd7a0, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:633
#12 0x00007f73c13d218b in KJob::finishJob (this=0x55778c7bd7a0, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:98
#13 0x00007f73c27b20f8 in KIO::SimpleJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#14 0x00007f73c27a844e in KIO::ListJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#15 0x00007f73c0fe6dce in QtPrivate::QSlotObjectBase::call (a=0x7fff6a7e78b0, r=0x55778c7bd7a0, this=0x55778c6d1b90) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#16 doActivate<false> (sender=0x55778bda8430, signal_index=7, argv=0x7fff6a7e78b0) at kernel/qobject.cpp:3886
#17 0x00007f73c277ed42 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#18 0x00007f73c277ca3f in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007f73c27859a2 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
Comment 2 Ahmad Samir 2021-11-28 02:35:55 UTC
Please install the relevant debuginfo packages and provide a backtrace again.
Comment 3 kde 2021-12-07 21:09:31 UTC
I am the first reporter. The crash happened on a very fresh install (2 days old). I can't reproduce the crash anymore on an updated KDE Neon. Thank you.
Comment 4 Nate Graham 2021-12-07 21:23:26 UTC
Cool, thanks for the update!