Bug 443069 - Gwenview crashes when opening jpeg (on Wayland)
Summary: Gwenview crashes when opening jpeg (on Wayland)
Status: RESOLVED DUPLICATE of bug 441121
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.1
Platform: Kubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-09-28 12:55 UTC by Syiad
Modified: 2021-10-03 21:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Syiad 2021-09-28 12:55:16 UTC
Application: gwenview (21.08.1)

Qt Version: 5.15.2
Frameworks Version: 5.86.0
Operating System: Linux 5.13.0-16-generic x86_64
Windowing System: Wayland
Distribution: Ubuntu Impish Indri (development branch)
DrKonqi: 5.22.90 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

I tried to open a jpeg file (exported from darktable) in dolphin. Gwenview crashes immediately without showing the image.

Gwenview also crashes when I start it and then try to open an edited jpeg file from within Gwenview.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted

[KCrash Handler]
#4  __pthread_kill_internal (signo=6, threadid=<optimized out>) at pthread_kill.c:45
#5  __GI___pthread_kill (threadid=<optimized out>, signo=signo@entry=6) at pthread_kill.c:62
#6  0x00007f47d3c32466 in __GI_raise (sig=sig@entry=6) at ../sysdeps/posix/raise.c:26
#7  0x00007f47d3c187b7 in __GI_abort () at abort.c:79
#8  0x00007f47d3eb5a31 in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#9  0x00007f47d3ec14ec in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#10 0x00007f47d3ec1557 in std::terminate() () from /lib/x86_64-linux-gnu/libstdc++.so.6
#11 0x00007f47d3ec17f9 in __cxa_throw () from /lib/x86_64-linux-gnu/libstdc++.so.6
#12 0x00007f47d3eb8448 in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#13 0x00007f47d39ed7fd in ?? () from /lib/x86_64-linux-gnu/libexiv2.so.27
#14 0x00007f47d398d12d in Exiv2::Xmpdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /lib/x86_64-linux-gnu/libexiv2.so.27
#15 0x00007f47d5f436d6 in Gwenview::ImageMetaInfoModel::setExiv2Image(Exiv2::Image const*) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#16 0x00007f47d5f08cd0 in Gwenview::Document::setExiv2Image(std::unique_ptr<Exiv2::Image, std::default_delete<Exiv2::Image> >) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#17 0x00007f47d5f13cab in ?? () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#18 0x00007f47d431dab3 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f47d4103f05 in QFutureWatcherBase::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x00007f47d504c6b3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#21 0x00007f47d42e61ba in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f47d42e92a7 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#23 0x00007f47d433ff57 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#24 0x00007f47d19cd8bb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f47d1a20f08 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f47d19cb003 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f47d433f5a8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f47d42e4aeb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#29 0x00007f47d42ed074 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x0000563a6cecd553 in ?? ()
#31 0x00007f47d3c19fd0 in __libc_start_call_main (main=main@entry=0x563a6ceccfe0, argc=argc@entry=2, argv=argv@entry=0x7ffe16034a38) at ../sysdeps/nptl/libc_start_call_main.h:58
#32 0x00007f47d3c1a07d in __libc_start_main_impl (main=0x563a6ceccfe0, argc=2, argv=0x7ffe16034a38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe16034a28) at ../csu/libc-start.c:409
#33 0x0000563a6cecdb75 in ?? ()
[Inferior 1 (process 19591) detached]

The reporter indicates this bug may be a duplicate of or related to bug 441121.

Possible duplicates by query: bug 441542, bug 441121, bug 434072, bug 427716, bug 421043.

Reported using DrKonqi
Comment 1 Tony 2021-10-03 21:20:06 UTC

*** This bug has been marked as a duplicate of bug 441121 ***