Bug 341098 - Crash connecting to NFS or SMB share using Gwenview
Summary: Crash connecting to NFS or SMB share using Gwenview
Status: RESOLVED WORKSFORME
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: Other (add details in bug description)
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
: 335845 373254 406018 412235 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-19 13:25 UTC by Jason
Modified: 2022-10-27 05:05 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason 2014-11-19 13:25:11 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.6-2-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:  Trying to open a NFS share on a Synology Diskstation.  The share is mapped by Dolphin.  Each time I try to connect to the share it crashes.  I am not very fluent with SUSE so I dont know where the log files are.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbf35868880 (LWP 4670))]

Thread 2 (Thread 0x7fbf1d986700 (LWP 4671)):
#0  0x00007fbf323353cd in poll () at /lib64/libc.so.6
#1  0x00007fbf2de76be4 in  () at /usr/lib64/libglib-2.0.so.0
#2  0x00007fbf2de76cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#3  0x00007fbf346e30de in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#4  0x00007fbf346b4e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#5  0x00007fbf346b5165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#6  0x00007fbf345b20bf in QThread::exec() () at /usr/lib64/libQtCore.so.4
#7  0x00007fbf34696783 in  () at /usr/lib64/libQtCore.so.4
#8  0x00007fbf345b479f in  () at /usr/lib64/libQtCore.so.4
#9  0x00007fbf2e7b00a4 in start_thread () at /lib64/libpthread.so.0
#10 0x00007fbf3233d7fd in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fbf35868880 (LWP 4670)):
[KCrash Handler]
#5  0x00007fbf34d70970 in  () at /usr/lib64/libkio.so.5
#6  0x00007fbf346ca1fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#7  0x00007fbf32a343e2 in KJob::result(KJob*) () at /usr/lib64/libkdecore.so.5
#8  0x00007fbf32a34420 in KJob::emitResult() () at /usr/lib64/libkdecore.so.5
#9  0x00007fbf34d5021a in KIO::SimpleJob::slotFinished() () at /usr/lib64/libkio.so.5
#10 0x00007fbf34d54c8e in KIO::ListJob::slotFinished() () at /usr/lib64/libkio.so.5
#11 0x00007fbf346ca1fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#12 0x00007fbf34deec66 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () at /usr/lib64/libkio.so.5
#13 0x00007fbf34dec78e in KIO::SlaveInterface::dispatch() () at /usr/lib64/libkio.so.5
#14 0x00007fbf34de14a6 in KIO::Slave::gotInput() () at /usr/lib64/libkio.so.5
#15 0x00007fbf346ca1fa in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () at /usr/lib64/libQtCore.so.4
#16 0x00007fbf34d1e3f1 in  () at /usr/lib64/libkio.so.5
#17 0x00007fbf346ce59e in QObject::event(QEvent*) () at /usr/lib64/libQtCore.so.4
#18 0x00007fbf32fae76c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#19 0x00007fbf32fb4cad in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQtGui.so.4
#20 0x00007fbf33cc6bda in KApplication::notify(QObject*, QEvent*) () at /usr/lib64/libkdeui.so.5
#21 0x00007fbf346b62ad in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib64/libQtCore.so.4
#22 0x00007fbf346b957d in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib64/libQtCore.so.4
#23 0x00007fbf346e38fe in  () at /usr/lib64/libQtCore.so.4
#24 0x00007fbf2de76a04 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#25 0x00007fbf2de76c48 in  () at /usr/lib64/libglib-2.0.so.0
#26 0x00007fbf2de76cec in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#27 0x00007fbf346e30be in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#28 0x00007fbf3304b676 in  () at /usr/lib64/libQtGui.so.4
#29 0x00007fbf346b4e6f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#30 0x00007fbf346b5165 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQtCore.so.4
#31 0x00007fbf346ba5b9 in QCoreApplication::exec() () at /usr/lib64/libQtCore.so.4
#32 0x0000000000429ded in  ()
#33 0x00007fbf32279b05 in __libc_start_main () at /lib64/libc.so.6
#34 0x000000000042a092 in _start ()

Reported using DrKonqi
Comment 1 Nate Graham 2017-09-09 04:00:53 UTC
*** Bug 373254 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2017-09-09 04:19:38 UTC
*** Bug 335845 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2019-10-07 03:21:53 UTC
*** Bug 406018 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2019-10-07 03:22:37 UTC
*** Bug 412235 has been marked as a duplicate of this bug. ***
Comment 5 Justin Zobel 2022-09-27 08:23:38 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 6 Bug Janitor Service 2022-10-12 04:54:50 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2022-10-27 05:05:10 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!