Bug 443651 - Crashing after adjusting EXIF data
Summary: Crashing after adjusting EXIF data
Status: RESOLVED DUPLICATE of bug 441121
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 19.12.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-12 23:28 UTC by gabrielrvargas
Modified: 2021-10-13 02:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gabrielrvargas 2021-10-12 23:28:38 UTC
Application: gwenview (19.12.3)

Qt Version: 5.12.8
Frameworks Version: 5.68.0
Operating System: Linux 5.4.0-88-generic x86_64
Windowing system: X11
Distribution: Ubuntu 20.04.3 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Selected to show more EXIF data (exposure, F number, camera model, etc). Then, it begun to crash when I open pictures that I have saved from web (not from camera) or a few from my phone camera. I try to revert the exibited data but no result, keep crashing.
- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcb59611440 (LWP 1986))]

Thread 8 (Thread 0x7fcb3ff34700 (LWP 1998)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fda30bf888) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fda30bf838, cond=0x55fda30bf860) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fda30bf860, mutex=0x55fda30bf838) at pthread_cond_wait.c:638
#3  0x00007fcb46834e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007fcb46834a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fcb40735700 (LWP 1997)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fda30bf888) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fda30bf838, cond=0x55fda30bf860) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fda30bf860, mutex=0x55fda30bf838) at pthread_cond_wait.c:638
#3  0x00007fcb46834e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007fcb46834a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fcb40f36700 (LWP 1996)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fda30bf888) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fda30bf838, cond=0x55fda30bf860) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fda30bf860, mutex=0x55fda30bf838) at pthread_cond_wait.c:638
#3  0x00007fcb46834e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007fcb46834a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fcb54bee700 (LWP 1995)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55fda30bf888) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55fda30bf838, cond=0x55fda30bf860) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55fda30bf860, mutex=0x55fda30bf838) at pthread_cond_wait.c:638
#3  0x00007fcb46834e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007fcb46834a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fcb559b2700 (LWP 1994)):
#0  futex_abstimed_wait_cancelable (private=<optimized out>, abstime=0x7fcb559b1a10, clockid=<optimized out>, expected=0, futex_word=0x55fda3292370) at ../sysdeps/nptl/futex-internal.h:320
#1  __pthread_cond_wait_common (abstime=0x7fcb559b1a10, clockid=<optimized out>, mutex=0x55fda3292320, cond=0x55fda3292348) at pthread_cond_wait.c:520
#2  __pthread_cond_timedwait (cond=0x55fda3292348, mutex=0x55fda3292320, abstime=0x7fcb559b1a10) at pthread_cond_wait.c:656
#3  0x00007fcb5f2eba7c in QWaitCondition::wait(QMutex*, QDeadlineTimer) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fcb5f2ebbcb in QWaitCondition::wait(QMutex*, unsigned long) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fcb5f2e9171 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fcb5f2e59d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fcb576b4700 (LWP 1990)):
#0  __GI___libc_read (nbytes=16, buf=0x7fcb576b38a0, fd=7) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=7, buf=0x7fcb576b38a0, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fcb5ceadb2f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcb5ce64ebe in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcb5ce65312 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcb5ce654a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fcb5f505583 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fcb5f4ac4db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fcb5f2e4785 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fcb5ed0aefa in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#10 0x00007fcb5f2e59d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#12 0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fcb58784700 (LWP 1989)):
#0  0x00007fcb5ef66aff in __GI___poll (fds=0x7fcb587839e8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fcb5cdf4c1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fcb5cdf690a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fcb58f5a298 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fcb5f2e59d2 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fcb5d680609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fcb5ef73293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fcb59611440 (LWP 1986)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50
#7  0x00007fcb5ee76859 in __GI_abort () at abort.c:79
#8  0x00007fcb5f0e1911 in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#9  0x00007fcb5f0ed38c in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#10 0x00007fcb5f0ed3f7 in std::terminate() () from /lib/x86_64-linux-gnu/libstdc++.so.6
#11 0x00007fcb5f0ed6a9 in __cxa_throw () from /lib/x86_64-linux-gnu/libstdc++.so.6
#12 0x00007fcb5f0e43ab in ?? () from /lib/x86_64-linux-gnu/libstdc++.so.6
#13 0x00007fcb5eaaaf49 in ?? () from /lib/x86_64-linux-gnu/libexiv2.so.27
#14 0x00007fcb5ea4c60f in Exiv2::Xmpdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /lib/x86_64-linux-gnu/libexiv2.so.27
#15 0x00007fcb60f42fd9 in ?? () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#16 0x00007fcb60f3ef23 in Gwenview::ImageMetaInfoModel::setExiv2Image(Exiv2::Image const*) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#17 0x00007fcb60efb470 in Gwenview::Document::setExiv2Image(std::unique_ptr<Exiv2::Image, std::default_delete<Exiv2::Image> >) () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#18 0x00007fcb60efa156 in ?? () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#19 0x00007fcb60f0553c in ?? () from /lib/x86_64-linux-gnu/libgwenviewlib.so.5
#20 0x00007fcb5f4d9458 in QMetaObject::activate(QObject*, int, int, void**) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007fcb5f2eff65 in QFutureWatcherBase::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007fcb600eea66 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#23 0x00007fcb600f80f0 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#24 0x00007fcb5f4ad93a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fcb5f4b05b8 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fcb5f505f67 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007fcb5ce6517d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fcb5ce65400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fcb5ce654a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fcb5f505565 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#31 0x00007fcb5f4ac4db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#32 0x00007fcb5f4b4246 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#33 0x000055fda288aaaa in ?? ()
#34 0x00007fcb5ee780b3 in __libc_start_main (main=0x55fda288a600, argc=2, argv=0x7ffc0fcda708, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffc0fcda6f8) at ../csu/libc-start.c:308
#35 0x000055fda288b04e in _start ()
[Inferior 1 (process 1986) detached]

Possible duplicates by query: bug 443069, bug 441542, bug 441121, bug 440777, bug 440257.

Reported using DrKonqi
Comment 1 Tony 2021-10-13 02:59:24 UTC

*** This bug has been marked as a duplicate of bug 441121 ***