Bug 412235 - gwenview crashes with samba shares
Summary: gwenview crashes with samba shares
Status: RESOLVED DUPLICATE of bug 341098
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-09-23 14:25 UTC by Patrick Silva
Modified: 2019-10-07 03:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2019-09-23 14:25:58 UTC
Application: gwenview (19.11.70)

Qt Version: 5.12.3
Frameworks Version: 5.63.0
Operating System: Linux 5.2.5-050205-generic x86_64
Distribution: KDE neon Unstable Edition

-- Information about the crash:
- What I was doing when the application crashed:
open gwenview, click on "Network in the right side, double click on "shared folders (smb), gwenview crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff5405ee500 (LWP 4081))]

Thread 4 (Thread 0x7ff511ed4700 (LWP 4084)):
#0  0x00007ff534b419f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5593dd4f9eb8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x5593dd4f9e68, cond=0x5593dd4f9e90) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x5593dd4f9e90, mutex=0x5593dd4f9e68) at pthread_cond_wait.c:655
#3  0x00007ff512f8d23b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007ff512f8cf67 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007ff534b3b6db in start_thread (arg=0x7ff511ed4700) at pthread_create.c:463
#6  0x00007ff53b03288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7ff51a243700 (LWP 4083)):
#0  0x00007ff534b41ed9 in futex_reltimed_wait_cancelable (private=<optimized out>, reltime=0x7ff51a242b20, expected=0, futex_word=0x5593dd3c0d34) at ../sysdeps/unix/sysv/linux/futex-internal.h:142
#1  __pthread_cond_wait_common (abstime=0x7ff51a242be0, mutex=0x5593dd3c0ce0, cond=0x5593dd3c0d08) at pthread_cond_wait.c:533
#2  __pthread_cond_timedwait (cond=0x5593dd3c0d08, mutex=0x5593dd3c0ce0, abstime=0x7ff51a242be0) at pthread_cond_wait.c:667
#3  0x00007ff53b739d36 in QWaitConditionPrivate::wait_relative (this=0x5593dd3c0ce0, deadline=...) at thread/qwaitcondition_unix.cpp:136
#4  QWaitConditionPrivate::wait (deadline=..., this=0x5593dd3c0ce0) at thread/qwaitcondition_unix.cpp:144
#5  QWaitCondition::wait (this=<optimized out>, mutex=0x5593dd3a8ba0, deadline=...) at thread/qwaitcondition_unix.cpp:225
#6  0x00007ff53b73a096 in QWaitCondition::wait (this=this@entry=0x5593dd3c0b20, mutex=mutex@entry=0x5593dd3a8ba0, time=<optimized out>) at thread/qwaitcondition_unix.cpp:209
#7  0x00007ff53b737740 in QThreadPoolThread::run (this=0x5593dd3c0b10) at thread/qthreadpool.cpp:139
#8  0x00007ff53b732c72 in QThreadPrivate::start (arg=0x5593dd3c0b10) at thread/qthread_unix.cpp:361
#9  0x00007ff534b3b6db in start_thread (arg=0x7ff51a243700) at pthread_create.c:463
#10 0x00007ff53b03288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7ff52398b700 (LWP 4082)):
#0  0x00007ff53b025bf9 in __GI___poll (fds=0x7ff51c003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ff5330355c9 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7ff51c003ce0, timeout=<optimized out>, context=0x7ff51c000bf0) at ../../../../glib/gmain.c:4203
#2  g_main_context_iterate (context=context@entry=0x7ff51c000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../../glib/gmain.c:3897
#3  0x00007ff5330356dc in g_main_context_iteration (context=0x7ff51c000bf0, may_block=may_block@entry=1) at ../../../../glib/gmain.c:3963
#4  0x00007ff53b968dcb in QEventDispatcherGlib::processEvents (this=0x7ff51c000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ff53b90a03a in QEventLoop::exec (this=this@entry=0x7ff52398acb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007ff53b7314ca in QThread::exec (this=this@entry=0x7ff53a22cd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:531
#7  0x00007ff539fb5015 in QDBusConnectionManager::run (this=0x7ff53a22cd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007ff53b732c72 in QThreadPrivate::start (arg=0x7ff53a22cd80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:361
#9  0x00007ff534b3b6db in start_thread (arg=0x7ff52398b700) at pthread_create.c:463
#10 0x00007ff53b03288f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ff5405ee500 (LWP 4081)):
[KCrash Handler]
#7  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:51
#8  0x00007ff53af51801 in __GI_abort () at abort.c:79
#9  0x00007ff53ec98192 in KCoreDirListerCache::printDebug (this=this@entry=0x7ff53ef0d400 <(anonymous namespace)::Q_QGS_kDirListerCache::innerFunction()::holder>) at ./src/core/kcoredirlister.cpp:2093
#10 0x00007ff53eca3321 in KCoreDirListerCache::slotUpdateResult (this=0x7ff53ef0d400 <(anonymous namespace)::Q_QGS_kDirListerCache::innerFunction()::holder>, j=<optimized out>) at ./src/core/kcoredirlister.cpp:1736
#11 0x00007ff53b93b98f in QtPrivate::QSlotObjectBase::call (a=0x7ffe437bc630, r=0x7ff53ef0d400 <(anonymous namespace)::Q_QGS_kDirListerCache::innerFunction()::holder>, this=0x5593dd2d45a0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 QMetaObject::activate (sender=sender@entry=0x5593dd765820, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffe437bc630) at kernel/qobject.cpp:3776
#13 0x00007ff53b93bf47 in QMetaObject::activate (sender=sender@entry=0x5593dd765820, m=m@entry=0x7ff53c2bc3e0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffe437bc630) at kernel/qobject.cpp:3648
#14 0x00007ff53c05cfdc in KJob::result (this=this@entry=0x5593dd765820, _t1=<optimized out>, _t1@entry=0x5593dd765820, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:573
#15 0x00007ff53c05db11 in KJob::finishJob (this=0x5593dd765820, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:107
#16 0x00007ff53c05f9ca in KJob::emitResult (this=<optimized out>) at ./src/lib/jobs/kjob.cpp:291
#17 0x00007ff53ec565f0 in KIO::SimpleJob::slotFinished (this=this@entry=0x5593dd765820) at ./src/core/simplejob.cpp:232
#18 0x00007ff53ec4b90b in KIO::ListJob::slotFinished (this=0x5593dd765820) at ./src/core/listjob.cpp:248
#19 0x00007ff53b93b98f in QtPrivate::QSlotObjectBase::call (a=0x7ffe437bc870, r=0x5593dd765820, this=0x5593dd2aeee0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#20 QMetaObject::activate (sender=sender@entry=0x5593dd795f50, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3776
#21 0x00007ff53b93bf47 in QMetaObject::activate (sender=sender@entry=0x5593dd795f50, m=m@entry=0x7ff53ef07620 <KIO::SlaveInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3648
#22 0x00007ff53ec29dc3 in KIO::SlaveInterface::finished (this=this@entry=0x5593dd795f50) at ./obj-x86_64-linux-gnu/src/core/KF5KIOCore_autogen/include/moc_slaveinterface.cpp:452
#23 0x00007ff53ec2de84 in KIO::SlaveInterface::dispatch (this=0x5593dd795f50, _cmd=<optimized out>, rawdata=...) at ./src/core/slaveinterface.cpp:156
#24 0x00007ff53ec2a538 in KIO::SlaveInterface::dispatch (this=0x5593dd795f50) at ./src/core/slaveinterface.cpp:85
#25 0x00007ff53ec308c1 in KIO::Slave::gotInput (this=0x5593dd795f50) at ./src/core/slave.cpp:406
#26 0x00007ff53b93b98f in QtPrivate::QSlotObjectBase::call (a=0x7ffe437bcb10, r=0x5593dd795f50, this=0x5593dd7dc5c0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#27 QMetaObject::activate (sender=0x5593dd795d20, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3776
#28 0x00007ff53b93bf47 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7ff53ef06380 <KIO::Connection::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3648
#29 0x00007ff53ebd1429 in KIO::Connection::readyRead (this=<optimized out>) at ./obj-x86_64-linux-gnu/src/core/KF5KIOCore_autogen/include/moc_connection_p.cpp:147
#30 KIO::ConnectionPrivate::dequeue (this=0x5593dd7c3e70) at ./src/core/connection.cpp:44
#31 0x00007ff53b93c3e2 in QObject::event (this=0x5593dd795d20, e=<optimized out>) at kernel/qobject.cpp:1260
#32 0x00007ff53d0f965c in QApplicationPrivate::notify_helper (this=this@entry=0x5593dcf9a4f0, receiver=receiver@entry=0x5593dd795d20, e=e@entry=0x5593dd663b40) at kernel/qapplication.cpp:3736
#33 0x00007ff53d100b90 in QApplication::notify (this=0x7ffe437bd220, receiver=0x5593dd795d20, e=0x5593dd663b40) at kernel/qapplication.cpp:3483
#34 0x00007ff53b90bd18 in QCoreApplication::notifyInternal2 (receiver=0x5593dd795d20, event=0x5593dd663b40) at kernel/qcoreapplication.cpp:1060
#35 0x00007ff53b90beee in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x5593dd663b40) at kernel/qcoreapplication.cpp:1450
#36 0x00007ff53b90e8d7 in QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x5593dcf90270) at kernel/qcoreapplication.cpp:1799
#37 0x00007ff53b90ee78 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1653
#38 0x00007ff53b969793 in postEventSourceDispatch (s=s@entry=0x5593dd018dd0) at kernel/qeventdispatcher_glib.cpp:276
#39 0x00007ff533035417 in g_main_dispatch (context=0x5593dcfefaf0) at ../../../../glib/gmain.c:3176
#40 g_main_context_dispatch (context=context@entry=0x5593dcfefaf0) at ../../../../glib/gmain.c:3829
#41 0x00007ff533035650 in g_main_context_iterate (context=context@entry=0x5593dcfefaf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../../glib/gmain.c:3902
#42 0x00007ff5330356dc in g_main_context_iteration (context=0x5593dcfefaf0, may_block=may_block@entry=1) at ../../../../glib/gmain.c:3963
#43 0x00007ff53b968daf in QEventDispatcherGlib::processEvents (this=0x5593dcfebb80, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#44 0x00007ff53b90a03a in QEventLoop::exec (this=this@entry=0x7ffe437bd120, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#45 0x00007ff53b913170 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1363
#46 0x00005593dc1515df in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:163

Possible duplicates by query: bug 412218, bug 411017, bug 408958, bug 407201, bug 407017.

Reported using DrKonqi
Comment 1 Nate Graham 2019-10-07 03:22:37 UTC

*** This bug has been marked as a duplicate of bug 341098 ***