Bug 367862

Summary: kwin crash when I first run firefox as a different user after login
Product: kwin Reporter: deviatov
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Keywords: drkonqi
Priority: NOR    
Version: 5.6.5   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description deviatov 2016-08-26 17:36:15 UTC
Application: kwin_x11 (5.6.5)
 (Compiled from sources)
Qt Version: 5.6.1
Frameworks Version: 5.23.0
Operating System: Linux 4.0.9-gentoo-gnu20160422 x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:
I logged in, then started konsole using alt+f2 (it started norramlly), then started firefox as a different user from konsole using kdesu. At this point, firefox started, but kwin crashed with segfault.

Also, (this is probably another bug in crash reporter), when I try to suggest duplicates, the crash reporter first allows me to do so (when I browse a specific report and press the button saying the crash is related), but later, when I close the related report and click "next", the crash reporter says that I didn't select any related reports (and allows ether to stay on the page with the possible duplicates, or to claim that there are no real duplicates).

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
84	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fd4aef2a800 (LWP 3408))]

Thread 6 (Thread 0x7fd49968c700 (LWP 3574)):
#0  0x00007fd4ae7f614d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd4acb8cac2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007fd4acb8e72f in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007fd49a137029 in QXcbEventReader::run (this=0xb09b60) at qxcbconnection.cpp:1325
#4  0x00007fd4ace4d88c in QThreadPrivate::start (arg=0xb09b60) at thread/qthread_unix.cpp:341
#5  0x00007fd4aeab9444 in start_thread (arg=0x7fd49968c700) at pthread_create.c:334
#6  0x00007fd4ae7ff12d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fd493905700 (LWP 3578)):
#0  0x00007fd4ae7f7e43 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd4ad037921 in qt_safe_select (nfds=8, fdread=fdread@entry=0x7fd48c000a78, fdwrite=fdwrite@entry=0x7fd48c000d08, fdexcept=fdexcept@entry=0x7fd48c000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fd4ad03900e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7fd48c000f98, writefds=0x7fd48c000d08, readfds=0x7fd48c000a78, nfds=<optimized out>, this=0x7fd48c0008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fd48c0008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fd4ad03954d in QEventDispatcherUNIX::processEvents (this=0x7fd48c0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fd4acfedc4a in QEventLoop::exec (this=this@entry=0x7fd493904d90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fd4ace49154 in QThread::exec (this=this@entry=0x7fd4af0ac240 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#7  0x00007fd4af03f235 in QDBusConnectionManager::run (this=0x7fd4af0ac240 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#8  0x00007fd4ace4d88c in QThreadPrivate::start (arg=0x7fd4af0ac240 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#9  0x00007fd4aeab9444 in start_thread (arg=0x7fd493905700) at pthread_create.c:334
#10 0x00007fd4ae7ff12d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fd4911b1700 (LWP 3588)):
#0  0x00007fd4ae7f7e43 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fd4ad037921 in qt_safe_select (nfds=13, fdread=fdread@entry=0x7fd488000a78, fdwrite=fdwrite@entry=0x7fd488000d08, fdexcept=fdexcept@entry=0x7fd488000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007fd4ad03900e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7fd488000f98, writefds=0x7fd488000d08, readfds=0x7fd488000a78, nfds=<optimized out>, this=0x7fd4880008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7fd4880008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007fd4ad03954d in QEventDispatcherUNIX::processEvents (this=0x7fd4880008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007fd4acfedc4a in QEventLoop::exec (this=this@entry=0x7fd4911b0da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fd4ace49154 in QThread::exec (this=this@entry=0xc42df0) at thread/qthread.cpp:500
#7  0x00007fd4a74b4a65 in QQmlThreadPrivate::run (this=0xc42df0) at qml/ftw/qqmlthread.cpp:141
#8  0x00007fd4ace4d88c in QThreadPrivate::start (arg=0xc42df0) at thread/qthread_unix.cpp:341
#9  0x00007fd4aeab9444 in start_thread (arg=0x7fd4911b1700) at pthread_create.c:334
#10 0x00007fd4ae7ff12d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fd48187a700 (LWP 3600)):
#0  pthread_cond_wait () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fd4abfe2884 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fd4ac0d0e40 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fd4abfe28c9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fd4aeab9444 in start_thread (arg=0x7fd48187a700) at pthread_create.c:334
#4  0x00007fd4ae7ff12d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd3fa34e700 (LWP 3728)):
#0  0x00007fd4ad039e32 in QTimerInfoList::timerWait (this=this@entry=0x7fd3f00010f8, tm=...) at kernel/qtimerinfo_unix.cpp:380
#1  0x00007fd4ad0394fa in QEventDispatcherUNIX::processEvents (this=0x7fd3f00be3b0, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#2  0x00007fd4acfedc4a in QEventLoop::exec (this=this@entry=0x7fd3fa34dda0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#3  0x00007fd4ace49154 in QThread::exec (this=this@entry=0xb1b2d0) at thread/qthread.cpp:500
#4  0x00007fd4a74b4a65 in QQmlThreadPrivate::run (this=0xb1b2d0) at qml/ftw/qqmlthread.cpp:141
#5  0x00007fd4ace4d88c in QThreadPrivate::start (arg=0xb1b2d0) at thread/qthread_unix.cpp:341
#6  0x00007fd4aeab9444 in start_thread (arg=0x7fd3fa34e700) at pthread_create.c:334
#7  0x00007fd4ae7ff12d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd4aef2a800 (LWP 3408)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7fd3ee78a320) at ../../src/qml/jsruntime/qv4value_p.h:348
#7  QQmlBinding::write (this=this@entry=0x1ec3bc0, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007fd4a74a0aba in QQmlBinding::update (this=0x1ec3bc0, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007fd4a74aa6a9 in QQmlObjectCreator::finalize (this=0x1a04c80, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007fd4a7431f7b in QQmlComponentPrivate::complete (enginePriv=0x1617070, state=0x16d2750) at qml/qqmlcomponent.cpp:919
#11 0x00007fd4a7432037 in QQmlComponentPrivate::completeCreate (this=0x16d26b0) at qml/qqmlcomponent.cpp:955
#12 0x00007fd4a7434c90 in QQmlComponent::completeCreate (this=0x16d2580) at qml/qqmlcomponent.cpp:948
#13 QQmlComponent::create (this=0x16d2580, context=0x1ec8a60) at qml/qqmlcomponent.cpp:781
#14 0x00007fd4913ef55b in Aurorae::Decoration::init (this=0x1b64de0) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/clients/aurorae/src/aurorae.cpp:316
#15 0x00007fd4ae41d798 in KWin::Decoration::DecorationBridge::createDecoration (this=0xbf97d0, client=client@entry=0x1ab7a50) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/decorations/decorationbridge.cpp:254
#16 0x00007fd4ae300059 in KWin::Client::createDecoration (this=this@entry=0x1ab7a50, oldgeom=...) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/client.cpp:393
#17 0x00007fd4ae300a8b in KWin::Client::updateDecoration (this=0x1ab7a50, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/client.cpp:380
#18 0x00007fd4ae35c722 in KWin::Client::manage (this=this@entry=0x1ab7a50, w=w@entry=69206180, isMapped=isMapped@entry=false) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/manage.cpp:385
#19 0x00007fd4ae2e0f65 in KWin::Workspace::createClient (this=this@entry=0xbf0830, w=69206180, is_mapped=is_mapped@entry=false) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/workspace.cpp:483
#20 0x00007fd4ae3437d1 in KWin::Workspace::workspaceEvent (this=0xbf0830, e=0x7fd494002cf0) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/events.cpp:417
#21 0x00007fd4acfecdfd in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7fd494002cf0, result=result@entry=0x7fff0be36dc8) at kernel/qabstracteventdispatcher.cpp:460
#22 0x00007fd49a135264 in QXcbConnection::handleXcbEvent (this=this@entry=0xafe210, event=event@entry=0x7fd494002cf0) at qxcbconnection.cpp:1091
#23 0x00007fd49a137453 in QXcbConnection::processXcbEvents (this=0xafe210) at qxcbconnection.cpp:1723
#24 0x00007fd4ad01765a in QObject::event (this=0xafe210, e=<optimized out>) at kernel/qobject.cpp:1256
#25 0x00007fd4ad88b5dc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0xafe210, e=0x7fd4940043a0) at kernel/qapplication.cpp:3804
#26 0x00007fd4ad88fd00 in QApplication::notify (this=0x7fff0be37400, receiver=0xafe210, e=0x7fd4940043a0) at kernel/qapplication.cpp:3561
#27 0x00007fd4acfef0b0 in QCoreApplication::notifyInternal2 (receiver=0xafe210, event=event@entry=0x7fd4940043a0) at kernel/qcoreapplication.cpp:1015
#28 0x00007fd4acff12e3 in QCoreApplication::sendEvent (event=0x7fd4940043a0, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xae81a0) at kernel/qcoreapplication.cpp:1650
#30 0x00007fd4ad039402 in QEventDispatcherUNIX::processEvents (this=0xb2f9f0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#31 0x00007fd49a19d04d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#32 0x00007fd4acfedc4a in QEventLoop::exec (this=this@entry=0x7fff0be372f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#33 0x00007fd4acff570c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#34 0x00007fd4ad31f89c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#35 0x00007fd4ad888235 in QApplication::exec () at kernel/qapplication.cpp:2979
#36 0x00007fd4aecd3abf in kdemain (argc=1, argv=0x7fff0be37588) at /usr/src/debug/kde-plasma/kwin-5.6.5-r1/kwin-5.6.5/main_x11.cpp:327
#37 0x00007fd4ae736620 in __libc_start_main (main=0x4007e0 <main(int, char**)>, argc=1, argv=0x7fff0be37588, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0be37578) at libc-start.c:289
#38 0x0000000000400819 in _start ()

Possible duplicates by query: bug 366240, bug 365593, bug 364842, bug 363221, bug 363196.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-08-27 06:34:47 UTC
As a workaround use the breeze window decoration

*** This bug has been marked as a duplicate of bug 361236 ***