Bug 323597

Summary: In workspace = netbook mode favorite icons disappear after logging out/in of KDE/rebooting.
Product: plasma4 Reporter: rvankessel
Component: plasma-netbookAssignee: Marco Martin <notmart>
Status: RESOLVED FIXED    
Severity: major CC: adaptee, b9anders, ferry.toth, gortab, grego.dadone, ianseeks, JimiJames.Bove, kletsen, macalko, rodion.kudryavtsev, roozbehonline, sergio, tiagodib
Priority: NOR Keywords: regression
Version: 4.11.0   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.11.2

Description rvankessel 2013-08-16 14:10:42 UTC
I use kde in netbook mode (Arch Linux) and upgraded to 4.11.0 yesterday. I picked several apps as favorites (clicking on gold star) so that their app icon is placed in the upper section of the 'Search and Launch' screen, These should persist after rebooting or logging out and back into kde, but they're not.

Reproducible: Always

Steps to Reproduce:
1. In settings, choose workspace = netbook
2. Pick some apps as favorites (click on gold star) so that their icon is placed in upper section of 'Search and Launch' screen.
3. Reboot or logout/in.
Actual Results:  
When logging back into kde, favorite icons aren't there anymore.

Expected Results:  
favorite icons should persist.
Comment 1 roelof 2013-08-16 22:44:47 UTC
The same with Kubuntu 12.04.
Comment 2 rvankessel 2013-08-25 20:52:58 UTC
The problem is in kdebase-workspace. I downgraded that package to 10.5 and now it's working.
Comment 3 Jekyll Wu 2013-08-26 04:35:50 UTC
*** Bug 323933 has been marked as a duplicate of this bug. ***
Comment 4 Ferry 2013-08-27 19:58:42 UTC
Me too with Kubuntu 13.04 + Kubuntu Backports PPA (KDE 4.11)
Comment 5 Grego D 2013-08-28 19:54:51 UTC
Same problem! Arch Linux x64 KDE 4.11
Comment 6 Jekyll Wu 2013-08-31 11:12:32 UTC
*** Bug 324311 has been marked as a duplicate of this bug. ***
Comment 7 Herbert Graeber 2013-09-01 10:29:40 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Alko89 2013-09-09 22:25:45 UTC
Same here with netbook plasma on Arch Linux i686 and also in search and launch on desktop workspace on Arch Linux x64. Both on KDE 4.11.
Comment 9 ray-ven 2013-09-10 15:22:55 UTC
same in 4.11.1 (Kubuntu raring)
any workaround?
Comment 10 ray-ven 2013-09-10 15:58:17 UTC
downgrade of kde-workspace to 10.5 didn't fix it
Comment 11 rvankessel 2013-09-11 00:19:41 UTC
I think downgrade of kdebase-workspace and kdebase-plasma (packages in Arch Linux) fixed it for me.
Comment 12 Jekyll Wu 2013-09-16 01:14:12 UTC
*** Bug 324934 has been marked as a duplicate of this bug. ***
Comment 13 ray-ven 2013-09-16 15:27:27 UTC
 downgrade of kdebase-workspace and kdebase-plasma didn't fix it in Kubuntu
Comment 14 Sergio Cambra 2013-09-17 22:00:35 UTC
same here with search and launch plasmoid in kde 4.11.1 on chakra
Comment 15 Jekyll Wu 2013-09-30 16:33:31 UTC
*** Bug 324783 has been marked as a duplicate of this bug. ***
Comment 16 rvankessel 2013-10-01 22:55:43 UTC
Seems fixed now in 4.11.2. Thanks to the person that fixed it!
Comment 17 roelof 2013-10-03 11:48:28 UTC
It is works  now in Kubuntu 12.04 + Kubuntu ackports ppa (4.11.2)
Thanks