Bug 306927

Summary: kwin crash
Product: [Plasma] kwin Reporter: Jannis Liapis <ahepas1999>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash Flags: thomas.luebking: Intel+
Priority: NOR    
Version: 4.9.1   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jannis Liapis 2012-09-17 13:09:03 UTC
Application: kwin (4.9.1)
KDE Platform Version: 4.9.1
Qt Version: 4.8.2
Operating System: Linux 3.6.0-030600rc2-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:kwin crashes whenever I activate a screensaver(GL). It crashes when exiting screensaver mode

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f537121d780 (LWP 2153))]

Thread 3 (Thread 0x7f5359f21700 (LWP 2163)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f53814b6222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f53814b6259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f53792d1e9a in start_thread (arg=0x7f5359f21700) at pthread_create.c:308
#4  0x00007f53845c239d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5368dae700 (LWP 2966)):
#0  0x00007f53845bb703 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f538021b846 in qt_safe_select (nfds=15, fdread=0x7f5360000ac8, fdwrite=0x7f5360000d60, fdexcept=0x7f5360000ff8, orig_timeout=<optimized out>) at kernel/qcore_unix.cpp:83
#2  0x00007f5380220c92 in QEventDispatcherUNIXPrivate::doSelect (this=0x7f5360000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f5380221183 in QEventDispatcherUNIX::processEvents (this=0x7f53600008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f53801ede42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f53801ee097 in QEventLoop::exec (this=0x7f5368daddd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f53800ed057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f53801cdb4f in QInotifyFileSystemWatcherEngine::run (this=0x226e130) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f53800f007b in QThreadPrivate::start (arg=0x226e130) at thread/qthread_unix.cpp:307
#9  0x00007f53792d1e9a in start_thread (arg=0x7f5368dae700) at pthread_create.c:308
#10 0x00007f53845c239d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f537121d780 (LWP 2153)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x7f5384cfd040, rb=0x1e3a7b0, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f535b777bf0 in brw_update_renderbuffer_surfaces (brw=0x7f5384cfd040) at brw_wm_surface_state.c:1052
#8  0x00007f535b761788 in brw_upload_state (brw=0x7f5384cfd040) at brw_state_upload.c:503
#9  0x00007f535b74e86f in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fff9e56f230, arrays=0x1eb3038, ctx=0x7f5384cfd040) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x7f5384cfd040, arrays=0x1eb3038, prim=0x7fff9e56f230, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f535b3bd0d4 in vbo_draw_arrays (ctx=0x7f5384cfd040, mode=4, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007f5380f09ddd in KWin::GLVertexBufferPrivate::corePainting (this=0x202d300, region=..., primitiveMode=4, hardwareClipping=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1218
#13 0x00007f5380f0a05d in KWin::GLVertexBuffer::render (this=0x2028570, region=..., primitiveMode=4, hardwareClipping=false) at ../../../kwin/libkwineffects/kwinglutils.cpp:1341
#14 0x00007f538495259e in renderQuads (hardwareClipping=false, normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at ../../kwin/scene_opengl.cpp:795
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>, hardwareClipping=false) at ../../kwin/scene_opengl.cpp:774
#16 0x00007f5384959477 in KWin::SceneOpenGL::Window::performPaint (this=0x2ddd690, mask=9, region=..., data=...) at ../../kwin/scene_opengl.cpp:593
#17 0x00007f5384942eae in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=9, region=..., data=...) at ../../kwin/scene.cpp:449
#18 0x00007f5384963cba in KWin::EffectsHandlerImpl::drawWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:308
#19 0x00007f5358f223d7 in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x2d767f0, mask=9, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:405
#20 0x00007f5384963c59 in KWin::EffectsHandlerImpl::drawWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:305
#21 0x00007f5382d6ba6b in KWin::Effect::drawWindow (this=<optimized out>, w=0x2d767f0, mask=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:182
#22 0x00007f5384963c59 in KWin::EffectsHandlerImpl::drawWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:305
#23 0x00007f538494227b in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/scene.cpp:434
#24 0x00007f5384963f3a in KWin::EffectsHandlerImpl::paintWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:271
#25 0x00007f5382d6bb6b in KWin::Effect::paintWindow (this=<optimized out>, w=0x2d767f0, mask=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:157
#26 0x00007f5384963ed9 in KWin::EffectsHandlerImpl::paintWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:268
#27 0x00007f5358f0beab in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0x2d767f0, mask=9, region=..., data=...) at ../../../kwin/effects/translucency/translucency.cpp:169
#28 0x00007f5384963ed9 in KWin::EffectsHandlerImpl::paintWindow (this=0x2164270, w=0x2d767f0, mask=9, region=..., data=...) at ../../kwin/effects.cpp:268
#29 0x00007f5384945326 in KWin::Scene::paintWindow (this=<optimized out>, w=0x2ddd690, mask=9, region=..., quads=...) at ../../kwin/scene.cpp:348
#30 0x00007f5384943604 in KWin::Scene::paintSimpleScreen (this=0x1dbff60, orig_mask=8, region=...) at ../../kwin/scene.cpp:334
#31 0x00007f53849421c2 in KWin::Scene::finalPaintScreen (this=0x1dbff60, mask=8, region=..., data=...) at ../../kwin/scene.cpp:192
#32 0x00007f5384964107 in KWin::EffectsHandlerImpl::paintScreen (this=0x2164270, mask=8, region=..., data=...) at ../../kwin/effects.cpp:244
#33 0x00007f5382d6bbd8 in KWin::Effect::paintScreen (this=<optimized out>, mask=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#34 0x00007f53849640ab in KWin::EffectsHandlerImpl::paintScreen (this=0x2164270, mask=8, region=..., data=...) at ../../kwin/effects.cpp:241
#35 0x00007f5382d6bbd8 in KWin::Effect::paintScreen (this=<optimized out>, mask=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#36 0x00007f53849640ab in KWin::EffectsHandlerImpl::paintScreen (this=0x2164270, mask=8, region=..., data=...) at ../../kwin/effects.cpp:241
#37 0x00007f5384944446 in KWin::Scene::paintScreen (this=0x1dbff60, mask=0x7fff9e570688, region=0x7fff9e570760) at ../../kwin/scene.cpp:146
#38 0x00007f538495a63e in KWin::SceneOpenGL::paint (this=0x1dbff60, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:481
#39 0x00007f538493d03a in performCompositing (this=0x1ded060) at ../../kwin/composite.cpp:440
#40 KWin::Workspace::performCompositing (this=0x1ded060) at ../../kwin/composite.cpp:398
#41 0x00007f5380208659 in QObject::event (this=0x1ded060, e=<optimized out>) at kernel/qobject.cpp:1157
#42 0x00007f537f5707b4 in notify_helper (e=0x7fff9e570e30, receiver=0x1ded060, this=0x1c2f560) at kernel/qapplication.cpp:4556
#43 QApplicationPrivate::notify_helper (this=0x1c2f560, receiver=0x1ded060, e=0x7fff9e570e30) at kernel/qapplication.cpp:4528
#44 0x00007f537f575583 in QApplication::notify (this=0x7fff9e571210, receiver=0x1ded060, e=0x7fff9e570e30) at kernel/qapplication.cpp:4417
#45 0x00007f538409c4a6 in KApplication::notify (this=0x7fff9e571210, receiver=0x1ded060, event=0x7fff9e570e30) at ../../kdeui/kernel/kapplication.cpp:311
#46 0x00007f53801ef30c in QCoreApplication::notifyInternal (this=0x7fff9e571210, receiver=0x1ded060, event=0x7fff9e570e30) at kernel/qcoreapplication.cpp:915
#47 0x00007f53802206d2 in sendEvent (event=0x7fff9e570e30, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#48 QTimerInfoList::activateTimers (this=0x1c30188) at kernel/qeventdispatcher_unix.cpp:611
#49 0x00007f5380221194 in QEventDispatcherUNIX::processEvents (this=0x1bc9ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#50 0x00007f537f619b78 in QEventDispatcherX11::processEvents (this=0x1bc9ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#51 0x00007f53801ede42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x00007f53801ee097 in QEventLoop::exec (this=0x7fff9e571190, flags=...) at kernel/qeventloop.cpp:204
#53 0x00007f53801f33e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#54 0x00007f53848f14f3 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:545
#55 0x00007f53844f176d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=3, ubp_av=0x7fff9e571908, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9e5718f8) at libc-start.c:226
#56 0x0000000000400661 in _start ()

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 306254, bug 304464, bug 304241, bug 304042, bug 303961.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2012-09-17 14:04:17 UTC
driver bug

*** This bug has been marked as a duplicate of bug 299333 ***