Bug 304464 - Kwin crash mplayer2
Summary: Kwin crash mplayer2
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-02 19:24 UTC by Leonid Zhaldybin
Modified: 2012-08-02 19:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
mgraesslin: Intel+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Zhaldybin 2012-08-02 19:24:26 UTC
Application: kwin (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.2
Operating System: Linux 3.4.6-2.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:

I opened a file with mplayer2 and pressed an 'f' key immediately to switch to the full screen mode.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f59263d8880 (LWP 1091))]

Thread 2 (Thread 0x7f5913fff700 (LWP 1095)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003a01f84ac7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3a022919a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x0000003a01f84af9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x0000003e3fe07d14 in start_thread (arg=0x7f5913fff700) at pthread_create.c:309
#4  0x0000003e3f6f197d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f59263d8880 (LWP 1091)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0xb47fe0, rb=0xae6480, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f591aa71bc0 in brw_update_renderbuffer_surfaces (brw=0xb47fe0) at brw_wm_surface_state.c:1052
#8  0x00007f591aa5be90 in brw_upload_state (brw=brw@entry=0xb47fe0) at brw_state_upload.c:503
#9  0x00007f591aa498b7 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fff90d2dac0, arrays=0xb8af78, ctx=0xb47fe0) at brw_draw.c:482
#10 brw_draw_prims (ctx=0xb47fe0, arrays=0xb8af78, prim=0x7fff90d2dac0, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f591ab6e613 in vbo_draw_arrays (ctx=0xb47fe0, mode=4, start=0, count=6, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x0000003f4ce0dc27 in KWin::GLVertexBufferPrivate::corePainting (this=0xd0c280, region=..., primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwinglutils.cpp:1188
#13 0x0000003f4ce0dd25 in KWin::GLVertexBuffer::render (this=0xaffa90, region=..., primitiveMode=4) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwinglutils.cpp:1297
#14 0x0000003f4d2b73e0 in renderQuads (normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene_opengl.cpp:788
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene_opengl.cpp:768
#16 0x0000003f4d2bdd18 in KWin::SceneOpenGL::Window::performPaint (this=0x11034a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene_opengl.cpp:592
#17 0x0000003f4d2a8f1e in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:438
#18 0x0000003f4d2c8415 in KWin::EffectsHandlerImpl::drawWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:286
#19 0x00007f5918beedcd in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects/blur/blur.cpp:389
#20 0x0000003f4d2c83ab in KWin::EffectsHandlerImpl::drawWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:283
#21 0x0000003f4d60ddaa in KWin::Effect::drawWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:181
#22 0x0000003f4d2c83ab in KWin::EffectsHandlerImpl::drawWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:283
#23 0x0000003f4d60ddaa in KWin::Effect::drawWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:181
#24 0x0000003f4d2c83ab in KWin::EffectsHandlerImpl::drawWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:283
#25 0x0000003f4d2a7f96 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0xe85690, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:429
#26 0x0000003f4d2c88d5 in KWin::EffectsHandlerImpl::paintWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:249
#27 0x0000003f4d60deaa in KWin::Effect::paintWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:156
#28 0x0000003f4d2c886b in KWin::EffectsHandlerImpl::paintWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:246
#29 0x00007f5918ba8f44 in KWin::FadeEffect::paintWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects/fade/fade.cpp:150
#30 0x0000003f4d2c886b in KWin::EffectsHandlerImpl::paintWindow (this=0xdb51d0, w=w@entry=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:246
#31 0x00007f5918bda448 in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0xe856a0, mask=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects/translucency/translucency.cpp:108
#32 0x0000003f4d2c886b in KWin::EffectsHandlerImpl::paintWindow (this=0xdb51d0, w=0xe856a0, mask=mask@entry=9, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:246
#33 0x0000003f4d2a897b in KWin::Scene::paintWindow (this=this@entry=0xafc640, w=0x11034a0, mask=9, region=..., quads=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:385
#34 0x0000003f4d2a9819 in KWin::Scene::paintSimpleScreen (this=this@entry=0xafc640, orig_mask=orig_mask@entry=8, region=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:330
#35 0x0000003f4d2a7ec4 in KWin::Scene::finalPaintScreen (this=0xafc640, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:198
#36 0x0000003f4d2c85e3 in KWin::EffectsHandlerImpl::paintScreen (this=0xdb51d0, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:222
#37 0x0000003f4d60df17 in KWin::Effect::paintScreen (this=this@entry=0xeed820, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:141
#38 0x0000003f4d2c858b in KWin::EffectsHandlerImpl::paintScreen (this=0xdb51d0, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:219
#39 0x0000003f4d60df17 in KWin::Effect::paintScreen (this=this@entry=0xeec080, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:141
#40 0x0000003f4d2c858b in KWin::EffectsHandlerImpl::paintScreen (this=0xdb51d0, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:219
#41 0x0000003f4d60df17 in KWin::Effect::paintScreen (this=this@entry=0xfc22b0, mask=mask@entry=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/libkwineffects/kwineffects.cpp:141
#42 0x0000003f4d2c858b in KWin::EffectsHandlerImpl::paintScreen (this=0xdb51d0, mask=8, region=..., data=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/effects.cpp:219
#43 0x0000003f4d2aaab8 in KWin::Scene::paintScreen (this=0xafc640, mask=0x7fff90d2ee8c, region=0x7fff90d2ef50) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene.cpp:156
#44 0x0000003f4d2be83d in KWin::SceneOpenGL::paint (this=0xafc640, damage=..., toplevels=...) at /usr/src/debug/kde-workspace-4.8.4/kwin/scene_opengl_glx.cpp:459
#45 0x0000003f4d2a4c3c in KWin::Workspace::performCompositing (this=0xc2ead0) at /usr/src/debug/kde-workspace-4.8.4/kwin/composite.cpp:412
#46 0x00000039f218ab1c in QObject::event (this=0xc2ead0, e=<optimized out>) at kernel/qobject.cpp:1157
#47 0x00000039f3dca37c in QApplicationPrivate::notify_helper (this=this@entry=0x8e6fb0, receiver=receiver@entry=0xc2ead0, e=e@entry=0x7fff90d2f630) at kernel/qapplication.cpp:4551
#48 0x00000039f3dce7fa in QApplication::notify (this=0x7fff90d2fc70, receiver=0xc2ead0, e=0x7fff90d2f630) at kernel/qapplication.cpp:4412
#49 0x00000039b8446756 in KApplication::notify (this=0x7fff90d2fc70, receiver=0xc2ead0, event=0x7fff90d2f630) at /usr/src/debug/kdelibs-4.8.4/kdeui/kernel/kapplication.cpp:311
#50 0x00000039f21763ee in QCoreApplication::notifyInternal (this=0x7fff90d2fc70, receiver=0xc2ead0, event=0x7fff90d2f630) at kernel/qcoreapplication.cpp:915
#51 0x00000039f21a6d52 in sendEvent (event=0x7fff90d2f630, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#52 QTimerInfoList::activateTimers (this=0x8e79a8) at kernel/qeventdispatcher_unix.cpp:611
#53 0x00000039f21a6db0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x899740) at kernel/qeventdispatcher_unix.cpp:868
#54 0x00000039f21a6f08 in QEventDispatcherUNIX::processEvents (this=0x899740, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#55 0x00000039f3e6b10f in QEventDispatcherX11::processEvents (this=0x899740, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#56 0x00000039f217513f in QEventLoop::processEvents (this=this@entry=0x7fff90d2f980, flags=...) at kernel/qeventloop.cpp:149
#57 0x00000039f21753c8 in QEventLoop::exec (this=0x7fff90d2f980, flags=...) at kernel/qeventloop.cpp:204
#58 0x00000039f217a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#59 0x0000003f4d25f4ee in kdemain (argc=3, argv=0x7fff90d2fdf8) at /usr/src/debug/kde-workspace-4.8.4/kwin/main.cpp:541
#60 0x0000003e3f621735 in __libc_start_main (main=0x4008c0 <main(int, char**)>, argc=3, ubp_av=0x7fff90d2fdf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff90d2fde8) at libc-start.c:226
#61 0x00000000004008f1 in _start ()

Possible duplicates by query: bug 304241, bug 304042, bug 303961, bug 303041, bug 302764.

Reported using DrKonqi
Comment 1 Martin Flöser 2012-08-02 19:28:20 UTC
Please see duplicate for workaround.

<devnote>This is a Fedora and not an Ubuntu!</devnote>

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Thomas Lübking 2012-08-02 19:37:12 UTC
<devnote class="review">
I'd say this is also rather bug #299333 which also has bug #303041 as fedora dupe.
(Not entirely sure whether #299333 is effectivley #252817)

Original bug #252817 report was on OpenSuSE btw.
</devnote>