Bug 306254 - kwin crashes when composition is enabled and 3D game is running
Summary: kwin crashes when composition is enabled and 3D game is running
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-04 16:15 UTC by Tom Kijas
Modified: 2012-09-04 16:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Kijas 2012-09-04 16:15:05 UTC
Application: kwin (4.9.00)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.2.0-29-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Hi, I run Heroes Of Newerth (native linux client) and after I try to change volume (with composition enabled), kwin crashes, or whole KDE freezes.
- Unusual behavior I noticed:
Strange flickering when changing window (alt+tab) when 3D game is running

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f24b4372780 (LWP 1937))]

Thread 2 (Thread 0x7f2491a67700 (LWP 1943)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f24b0a7e022 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f24b0a7e059 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f24a889be9a in start_thread (arg=0x7f2491a67700) at pthread_create.c:308
#4  0x00007f24b3b8a4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f24b4372780 (LWP 1937)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x7f2498339040, rb=0x113ad30, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f24939799e0 in brw_update_renderbuffer_surfaces (brw=0x7f2498339040) at brw_wm_surface_state.c:1052
#8  0x00007f2493963588 in brw_upload_state (brw=0x7f2498339040) at brw_state_upload.c:503
#9  0x00007f249395071f in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fff66a55a70, arrays=0x1200798, ctx=0x7f2498339040) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x7f2498339040, arrays=0x1200798, prim=0x7fff66a55a70, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f24935bf544 in vbo_draw_arrays (ctx=0x7f2498339040, mode=6, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007f24936652a7 in _mesa_meta_glsl_Clear (ctx=0x7f2498339040, buffers=<optimized out>) at drivers/common/meta.c:1913
#13 0x00007f24b3f1dc2c in KWin::SceneOpenGL::paintBackground (this=<optimized out>, region=...) at ../../kwin/scene_opengl.cpp:186
#14 0x00007f24b3f0bada in KWin::Scene::paintGenericScreen (this=0x11a34e0, orig_mask=32) at ../../kwin/scene.cpp:200
#15 0x00007f24b3f195ab in KWin::SceneOpenGL::paintGenericScreen (this=0x11a34e0, mask=32, data=...) at ../../kwin/scene_opengl.cpp:173
#16 0x00007f24b3f09b8a in KWin::Scene::finalPaintScreen (this=0x11a34e0, mask=32, region=..., data=...) at ../../kwin/scene.cpp:190
#17 0x00007f24b3f2b627 in KWin::EffectsHandlerImpl::paintScreen (this=0x14be350, mask=32, region=..., data=...) at ../../kwin/effects.cpp:244
#18 0x00007f24b2333bd8 in KWin::Effect::paintScreen (this=<optimized out>, mask=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#19 0x00007f24b3f2b5cb in KWin::EffectsHandlerImpl::paintScreen (this=0x14be350, mask=32, region=..., data=...) at ../../kwin/effects.cpp:241
#20 0x00007f24b2333bd8 in KWin::Effect::paintScreen (this=<optimized out>, mask=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#21 0x00007f24b3f2b5cb in KWin::EffectsHandlerImpl::paintScreen (this=0x14be350, mask=32, region=..., data=...) at ../../kwin/effects.cpp:241
#22 0x00007f24b2333bd8 in KWin::Effect::paintScreen (this=<optimized out>, mask=32, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#23 0x00007f24b3f2b5cb in KWin::EffectsHandlerImpl::paintScreen (this=0x14be350, mask=32, region=..., data=...) at ../../kwin/effects.cpp:241
#24 0x00007f2491adbad5 in KWin::CoverSwitchEffect::paintScreen (this=0x176edd0, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:135
#25 0x00007f24b3f2b5cb in KWin::EffectsHandlerImpl::paintScreen (this=0x14be350, mask=32, region=..., data=...) at ../../kwin/effects.cpp:241
#26 0x00007f24b3f0bdb6 in KWin::Scene::paintScreen (this=0x11a34e0, mask=0x7fff66a56968, region=0x7fff66a56a40) at ../../kwin/scene.cpp:146
#27 0x00007f24b3f21fae in KWin::SceneOpenGL::paint (this=0x11a34e0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:481
#28 0x00007f24b3f04a92 in performCompositing (this=0x10e6500) at ../../kwin/composite.cpp:432
#29 KWin::Workspace::performCompositing (this=0x10e6500) at ../../kwin/composite.cpp:397
#30 0x00007f24af7cf739 in QObject::event (this=0x10e6500, e=<optimized out>) at kernel/qobject.cpp:1157
#31 0x00007f24aeb377b4 in notify_helper (e=0x7fff66a57110, receiver=0x10e6500, this=0xfadaf0) at kernel/qapplication.cpp:4556
#32 QApplicationPrivate::notify_helper (this=0xfadaf0, receiver=0x10e6500, e=0x7fff66a57110) at kernel/qapplication.cpp:4528
#33 0x00007f24aeb3c583 in QApplication::notify (this=0x7fff66a574f0, receiver=0x10e6500, e=0x7fff66a57110) at kernel/qapplication.cpp:4417
#34 0x00007f24b3664456 in KApplication::notify (this=0x7fff66a574f0, receiver=0x10e6500, event=0x7fff66a57110) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f24af7b63ec in QCoreApplication::notifyInternal (this=0x7fff66a574f0, receiver=0x10e6500, event=0x7fff66a57110) at kernel/qcoreapplication.cpp:915
#36 0x00007f24af7e77b2 in sendEvent (event=0x7fff66a57110, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#37 QTimerInfoList::activateTimers (this=0xfae638) at kernel/qeventdispatcher_unix.cpp:611
#38 0x00007f24af7e8274 in QEventDispatcherUNIX::processEvents (this=0xf56ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#39 0x00007f24aebe0b78 in QEventDispatcherX11::processEvents (this=0xf56ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#40 0x00007f24af7b4f22 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007f24af7b5177 in QEventLoop::exec (this=0x7fff66a57470, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007f24af7ba4c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#43 0x00007f24b3eb8f93 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:545
#44 0x00007f24b3ab976d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff66a57be8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff66a57bd8) at libc-start.c:226
#45 0x0000000000400661 in _start ()

Possible duplicates by query: bug 304464, bug 304241, bug 304042, bug 303961, bug 303041.

Reported using DrKonqi
Comment 1 Martin Flöser 2012-09-04 16:34:36 UTC
Disable unredirection of full-screen windows

*** This bug has been marked as a duplicate of bug 252817 ***