Bug 299333 - kwin crash while disabling lvds1
Summary: kwin crash while disabling lvds1
Status: RESOLVED UPSTREAM
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 300886 301131 301403 303041 304241 306867 306927 307027 309569 310417 311671 311682 312335 312336 312468 312686 312797 313059 313416 314018 314196 314673 314730 316327 316866 317130 317160 317373 317761 317796 319007 319758 321352 322168 322487 322959 323133 323303 323424 325776 331031 331189 331837 331881 341556 348871 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-03 21:57 UTC by George
Modified: 2015-06-11 15:33 UTC (History)
41 users (show)

See Also:
Latest Commit:
Version Fixed In:
thomas.luebking: Intel+


Attachments
4.10 doesn't solve opengl problems (270 bytes, text/plain)
2013-03-22 01:24 UTC, stefan.walser
Details
New crash information added by DrKonqi (6.26 KB, text/plain)
2013-03-24 00:27 UTC, Kai Krakow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description George 2012-05-03 21:57:37 UTC
Application: kwin (4.8.2 (4.8.2))
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
1. Thinkpad T410 with Dell U2410 HDMI3 connected.
2. With HDMI3 set as primary output and applied.
3. Disabling LVDS1 and applying causes kwin crash with both monitor going into power saving mode.
4. Need to use FN+F7 combination to get screens back.

- Unusual behavior I noticed:
sometimes panel at bottom does not reappear and window trim not showing.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f07b043f780 (LWP 2265))]

Thread 3 (Thread 0x7f078da6b700 (LWP 2272)):
#0  0x00007f07afc44823 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f07ab446366 in qt_safe_select (nfds=23, fdread=0x7f0780000ac8, fdwrite=0x7f0780000d60, fdexcept=0x7f0780000ff8, orig_timeout=<optimized out>) at kernel/qcore_unix.cpp:83
#2  0x00007f07ab44b7b2 in QEventDispatcherUNIXPrivate::doSelect (this=0x7f0780000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f07ab44bca3 in QEventDispatcherUNIX::processEvents (this=0x7f07800008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f07ab418c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f07ab418ed7 in QEventLoop::exec (this=0x7f078da6add0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f07ab317fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f07ab3f89ff in QInotifyFileSystemWatcherEngine::run (this=0x2b167a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f07ab31afcb in QThreadPrivate::start (arg=0x2b167a0) at thread/qthread_unix.cpp:298
#9  0x00007f07a4545e9a in start_thread (arg=0x7f078da6b700) at pthread_create.c:308
#10 0x00007f07afc4b4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f078d246700 (LWP 2273)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f07ac704222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f07ac704259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f07a4545e9a in start_thread (arg=0x7f078d246700) at pthread_create.c:308
#4  0x00007f07afc4b4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f07b043f780 (LWP 2265)):
[KCrash Handler]
#6  brw_update_renderbuffer_surface (brw=0x27a3d50, rb=0x27a00a0, unit=0) at brw_wm_surface_state.c:919
#7  0x00007f0794831a80 in brw_update_renderbuffer_surfaces (brw=0x27a3d50) at brw_wm_surface_state.c:1016
#8  0x00007f079481b628 in brw_upload_state (brw=0x27a3d50) at brw_state_upload.c:503
#9  0x00007f07948087bf in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fff85bc0ec0, arrays=0x2818b18, ctx=0x27a3d50) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x27a3d50, arrays=0x2818b18, prim=0x7fff85bc0ec0, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f0794477544 in vbo_draw_arrays (ctx=0x27a3d50, mode=4, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007f07ac12ced7 in KWin::GLVertexBufferPrivate::corePainting (this=0x2995b00, region=..., primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1189
#13 0x00007f07ac12cfd5 in KWin::GLVertexBuffer::render (this=0x2956cf0, region=..., primitiveMode=4) at ../../../kwin/libkwineffects/kwinglutils.cpp:1298
#14 0x00007f07affd578f in renderQuads (normalized=<optimized out>, tex=<optimized out>, quads=..., region=..., this=<optimized out>) at ../../kwin/scene_opengl.cpp:788
#15 KWin::SceneOpenGL::Window::renderQuads (this=<optimized out>, region=..., quads=..., tex=<optimized out>, normalized=<optimized out>) at ../../kwin/scene_opengl.cpp:768
#16 0x00007f07affdcb82 in KWin::SceneOpenGL::Window::performPaint (this=0x2e24610, mask=513, region=..., data=...) at ../../kwin/scene_opengl.cpp:592
#17 0x00007f07affc5309 in KWin::Scene::finalDrawWindow (this=<optimized out>, w=<optimized out>, mask=513, region=..., data=...) at ../../kwin/scene.cpp:438
#18 0x00007f07affe7d35 in KWin::EffectsHandlerImpl::drawWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:286
#19 0x00007f07addb339b in KWin::Effect::drawWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:182
#20 0x00007f07affe7cc9 in KWin::EffectsHandlerImpl::drawWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:283
#21 0x00007f07addb339b in KWin::Effect::drawWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:182
#22 0x00007f07affe7cc9 in KWin::EffectsHandlerImpl::drawWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:283
#23 0x00007f07addb339b in KWin::Effect::drawWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:182
#24 0x00007f07affe7cc9 in KWin::EffectsHandlerImpl::drawWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:283
#25 0x00007f07affc4885 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x2e02670, mask=513, region=..., data=...) at ../../kwin/scene.cpp:429
#26 0x00007f07affe7fc5 in KWin::EffectsHandlerImpl::paintWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:249
#27 0x00007f078e2ed8b4 in KWin::FadeEffect::paintWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/effects/fade/fade.cpp:150
#28 0x00007f07affe7f59 in KWin::EffectsHandlerImpl::paintWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:246
#29 0x00007f078e323a68 in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/effects/translucency/translucency.cpp:108
#30 0x00007f07affe7f59 in KWin::EffectsHandlerImpl::paintWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:246
#31 0x00007f078e3030db in KWin::SlidingPopupsEffect::paintWindow (this=<optimized out>, w=0x2e02680, mask=513, region=..., data=...) at ../../../kwin/effects/slidingpopups/slidingpopups.cpp:222
#32 0x00007f07affe7f59 in KWin::EffectsHandlerImpl::paintWindow (this=0x2ad40a0, w=0x2e02680, mask=513, region=..., data=...) at ../../kwin/effects.cpp:246
#33 0x00007f07affc5508 in KWin::Scene::paintWindow (this=<optimized out>, w=0x2e24610, mask=513, region=..., quads=...) at ../../kwin/scene.cpp:385
#34 0x00007f07affc722a in KWin::Scene::paintGenericScreen (this=0x27994b0, orig_mask=512) at ../../kwin/scene.cpp:240
#35 0x00007f07affd4e3b in KWin::SceneOpenGL::paintGenericScreen (this=0x27994b0, mask=512, data=...) at ../../kwin/scene_opengl.cpp:167
#36 0x00007f07affc4812 in KWin::Scene::finalPaintScreen (this=0x27994b0, mask=512, region=..., data=...) at ../../kwin/scene.cpp:196
#37 0x00007f07affe8197 in KWin::EffectsHandlerImpl::paintScreen (this=0x2ad40a0, mask=512, region=..., data=...) at ../../kwin/effects.cpp:222
#38 0x00007f07addb3508 in KWin::Effect::paintScreen (this=<optimized out>, mask=512, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#39 0x00007f07affe813b in KWin::EffectsHandlerImpl::paintScreen (this=0x2ad40a0, mask=512, region=..., data=...) at ../../kwin/effects.cpp:219
#40 0x00007f07addb3508 in KWin::Effect::paintScreen (this=<optimized out>, mask=512, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#41 0x00007f07affe813b in KWin::EffectsHandlerImpl::paintScreen (this=0x2ad40a0, mask=512, region=..., data=...) at ../../kwin/effects.cpp:219
#42 0x00007f07addb3508 in KWin::Effect::paintScreen (this=<optimized out>, mask=512, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#43 0x00007f07affe813b in KWin::EffectsHandlerImpl::paintScreen (this=0x2ad40a0, mask=512, region=..., data=...) at ../../kwin/effects.cpp:219
#44 0x00007f07affc77c5 in KWin::Scene::paintScreen (this=0x27994b0, mask=0x7fff85bc27a8, region=0x7fff85bc2890) at ../../kwin/scene.cpp:156
#45 0x00007f07affdd68d in KWin::SceneOpenGL::paint (this=0x27994b0, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:459
#46 0x00007f07affc13c8 in KWin::Workspace::performCompositing (this=0x2957760) at ../../kwin/composite.cpp:417
#47 0x00007f07ab433179 in QObject::event (this=0x2957760, e=<optimized out>) at kernel/qobject.cpp:1157
#48 0x00007f07aa79c894 in notify_helper (e=0x7fff85bc2f70, receiver=0x2957760, this=0x25ef810) at kernel/qapplication.cpp:4559
#49 QApplicationPrivate::notify_helper (this=0x25ef810, receiver=0x2957760, e=0x7fff85bc2f70) at kernel/qapplication.cpp:4531
#50 0x00007f07aa7a1713 in QApplication::notify (this=0x7fff85bc3390, receiver=0x2957760, e=0x7fff85bc2f70) at kernel/qapplication.cpp:4420
#51 0x00007f07af726b46 in KApplication::notify (this=0x7fff85bc3390, receiver=0x2957760, event=0x7fff85bc2f70) at ../../kdeui/kernel/kapplication.cpp:311
#52 0x00007f07ab419e9c in QCoreApplication::notifyInternal (this=0x7fff85bc3390, receiver=0x2957760, event=0x7fff85bc2f70) at kernel/qcoreapplication.cpp:876
#53 0x00007f07ab44b1f2 in sendEvent (event=0x7fff85bc2f70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#54 QTimerInfoList::activateTimers (this=0x25f03c8) at kernel/qeventdispatcher_unix.cpp:611
#55 0x00007f07ab44bcb4 in QEventDispatcherUNIX::processEvents (this=0x25a2ad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#56 0x00007f07aa845bf8 in QEventDispatcherX11::processEvents (this=0x25a2ad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#57 0x00007f07ab418c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#58 0x00007f07ab418ed7 in QEventLoop::exec (this=0x7fff85bc32d0, flags=...) at kernel/qeventloop.cpp:204
#59 0x00007f07ab41df67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#60 0x00007f07aff76a06 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:541
#61 0x00007f07afb7a76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=3, ubp_av=0x7fff85bc3ab8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff85bc3aa8) at libc-start.c:226
#62 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2012-05-04 06:08:31 UTC
crashes in the driver. Which GPU and driver are you using?
Comment 2 George 2012-05-04 16:50:50 UTC
kinfocenter reports:
3D Accelerator
Vendor: Intel
Device: Core Processor Intergrated Graphic Controller 

Driver
Vendor: Tungsten Graphics, Inc
Renderer: Mesa DRI Intel Ironlake Mobile
OpenGL/ES Version: 2.1 Mesa 8.0.2
Kernel module: i915

From lspci:
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

From lsmod:
video                  19596  1 i915
Comment 3 Thomas Lübking 2012-05-04 19:32:46 UTC
I think it has ultimately even the same source as bug #252817 (there're many results for "gg:brw_update_renderbuffer_surface segfault" and esp. ubuntu 12)

With a little luck, 4.9 implicitly fixes this, because it doesn't restart the compositor on screensize changes.

@George
Before you detach the screen, simply suspend compositing (Shift+Alt+F12) and resume it afterwards (same combo) - you could also try with "kwin_gles --replace"
"Resolved upstream" does not mean it's fixed anywhere but that it's a bug in a dependency we cannot fix ourselves.
Comment 4 George 2012-05-04 21:59:57 UTC
Hi Thomas,
Thanks for the tips.  However Shift+Alt+F12 before and after screen detachment doesn't seem to help.  The command kwin_gles --replace works until I Ctrl+C then some windows do not have trim and can't be moved (even when using Alt+mouse left click hold).  Kickoff application launcher menu is visible but does not work.  Chrome browser still has window trim and can be moved around.

Understood about upstream dependencies.  I'll avoid detaching screens in the meantime.  Thanks all for you attention to this.

-George
Comment 5 Thomas Lübking 2012-05-05 08:28:20 UTC
(In reply to comment #4)
> Hi Thomas,
> However Shift+Alt+F12 before and after screen detachment doesn't seem to help.
You *cannot* get the same crash w/o a running (GL) compositor, what precisely happens when removing the screen while the compositor is suspended?

>  The command kwin_gles --replace works until I Ctrl+C
errr - yes. "kwin_gles" is the window manager compiled for GLES (OpenGL subset) - if you quit it, you've no window manager anymore ;-)
append and ampersand to run stuff from konsole forked to background "kwin_gles --replace &" - but you can remove the screen w/o getting a crash while running kwin_gles?
Comment 6 Martin Flöser 2012-05-30 18:22:41 UTC
*** Bug 300886 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Lübking 2012-06-03 23:05:14 UTC
*** Bug 301131 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Lübking 2012-06-07 22:03:17 UTC
*** Bug 301403 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Lübking 2012-06-09 20:07:21 UTC
*** Bug 301529 has been marked as a duplicate of this bug. ***
Comment 10 Thomas Lübking 2012-06-19 07:59:23 UTC
*** Bug 302169 has been marked as a duplicate of this bug. ***
Comment 11 Martin Flöser 2012-07-05 05:50:47 UTC
*** Bug 303041 has been marked as a duplicate of this bug. ***
Comment 12 Sérgio Basto 2012-07-05 06:22:25 UTC
(In reply to comment #1)
> crashes right inside the driver. Not much we can do about it. Make sure you
> have "unredirection of fullscreen windows" disabled.
> 
> *** This bug has been marked as a duplicate of bug 299333 ***

how I disable or enable  "unredirection of fullscreen windows" ?
Comment 13 Thomas Lübking 2012-07-29 12:01:07 UTC
*** Bug 304241 has been marked as a duplicate of this bug. ***
Comment 14 Sérgio Basto 2012-07-29 19:06:01 UTC
btw I have one Intel video card 

xorg-x11-drv-intel-2.19.0-5.fc17.x86_64
Comment 15 Thomas Lübking 2012-07-29 19:12:16 UTC
Everyone has, for this is an intel bug

about deactivating unredirection:
run "kcmshell4 kwincompositing" and uncheck it (advanced tab)
Comment 16 Sérgio Basto 2012-07-30 03:02:09 UTC
(In reply to comment #15)
> about deactivating unredirection:
> run "kcmshell4 kwincompositing" and uncheck it (advanced tab)

on "Configure desktop effects" on advance tab, I just see .
Composite type : Xrender or OpenGL
and two options , keep thumbs and scale method
one checkbox which says "suspend desktop effects on full windows" 
and two opengl options are disable . 
none  "unredirection" option
Comment 17 Martin Flöser 2012-07-30 04:25:31 UTC
(In reply to comment #16)
> one checkbox which says "suspend desktop effects on full windows" 
that's the one to disable. The technical feature is called "unredirection" of full-screen windows.
Comment 18 Thomas Lübking 2012-09-15 22:45:52 UTC
*** Bug 306867 has been marked as a duplicate of this bug. ***
Comment 19 Thomas Lübking 2012-09-17 14:04:17 UTC
*** Bug 306927 has been marked as a duplicate of this bug. ***
Comment 20 Thomas Lübking 2012-09-19 09:40:34 UTC
*** Bug 307027 has been marked as a duplicate of this bug. ***
Comment 21 Thomas Lübking 2012-11-05 14:48:56 UTC
*** Bug 309569 has been marked as a duplicate of this bug. ***
Comment 22 Martin Flöser 2012-11-20 18:50:39 UTC
*** Bug 310417 has been marked as a duplicate of this bug. ***
Comment 23 Thomas Lübking 2012-12-14 12:54:36 UTC
*** Bug 311671 has been marked as a duplicate of this bug. ***
Comment 24 Thomas Lübking 2012-12-14 12:54:40 UTC
*** Bug 311682 has been marked as a duplicate of this bug. ***
Comment 25 Bastian Senst 2012-12-26 11:12:51 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=58780 <- corresponding bug report for the intel driver
Comment 26 Thomas Lübking 2012-12-29 13:51:10 UTC
*** Bug 312335 has been marked as a duplicate of this bug. ***
Comment 27 Thomas Lübking 2012-12-29 14:36:13 UTC
*** Bug 312336 has been marked as a duplicate of this bug. ***
Comment 28 Thomas Lübking 2013-01-01 23:11:43 UTC
*** Bug 312468 has been marked as a duplicate of this bug. ***
Comment 29 Thomas Lübking 2013-01-02 18:00:15 UTC
Git commit 276dfc615030465f01358a11ac98b11075e5ddec by Thomas Lübking.
Committed on 29/12/2012 at 15:36.
Pushed by luebking into branch 'KDE/4.10'.

skip reset states if client untabbed for release
FIXED-IN: 4.10
REVIEW: 108003

M  +3    -1    kwin/client.cpp
M  +1    -1    kwin/client.h
M  +1    -1    kwin/workspace.cpp

http://commits.kde.org/kde-workspace/276dfc615030465f01358a11ac98b11075e5ddec
Comment 30 Thomas Lübking 2013-01-02 18:04:23 UTC
Wrong BUG in commit comment.
Comment 31 Thomas Lübking 2013-01-05 16:44:02 UTC
*** Bug 312686 has been marked as a duplicate of this bug. ***
Comment 32 Martin Flöser 2013-01-07 08:30:15 UTC
*** Bug 312797 has been marked as a duplicate of this bug. ***
Comment 33 Martin Flöser 2013-01-11 09:12:26 UTC
*** Bug 313059 has been marked as a duplicate of this bug. ***
Comment 34 Thomas Lübking 2013-01-17 19:26:41 UTC
*** Bug 313416 has been marked as a duplicate of this bug. ***
Comment 35 Thomas Lübking 2013-01-28 06:54:02 UTC
*** Bug 314018 has been marked as a duplicate of this bug. ***
Comment 36 Martin Flöser 2013-01-31 17:54:57 UTC
*** Bug 314196 has been marked as a duplicate of this bug. ***
Comment 37 Martin Flöser 2013-02-08 13:25:18 UTC
*** Bug 314673 has been marked as a duplicate of this bug. ***
Comment 38 Thomas Lübking 2013-02-08 23:37:19 UTC
*** Bug 314730 has been marked as a duplicate of this bug. ***
Comment 39 Thomas Lübking 2013-03-07 18:43:29 UTC
*** Bug 316327 has been marked as a duplicate of this bug. ***
Comment 40 Thomas Lübking 2013-03-07 18:47:53 UTC
Looking back at OP:
> 3. Disabling LVDS1 and applying causes [...] both monitor going into power saving mode.
> 4. Need to use FN+F7 combination to get screens back.

And the other bugs around xrandr i fear the bug isn't even in the intel driver but we get some memory corruption from calling XRRUpdateConfiguration()

See esp. bug #293209
Comment 41 Thomas Lübking 2013-03-16 20:39:06 UTC
*** Bug 316866 has been marked as a duplicate of this bug. ***
Comment 42 Martin Flöser 2013-03-21 15:05:06 UTC
*** Bug 317130 has been marked as a duplicate of this bug. ***
Comment 43 Thomas Lübking 2013-03-21 21:23:02 UTC
*** Bug 317160 has been marked as a duplicate of this bug. ***
Comment 44 stefan.walser 2013-03-22 01:24:53 UTC
Created attachment 78284 [details]
4.10 doesn't solve opengl problems

I have updated to KDE 4.10
opengl still doesn't work
Activating opengl nativ seems to be accepted. But after activating "Animation Arbeitsflächen-Würfel" it shows that this cannot be activated because of missing opengl.
Firefox and Thunderbird still look very ugly.
Comment 45 Thomas Lübking 2013-03-22 14:05:02 UTC
Sorry, the commit that set those vars didn't belong here.

This bug is in the driver - updating KDE won't fix it ever, sorry.
Comment 46 Kai Krakow 2013-03-24 00:27:29 UTC
Created attachment 78338 [details]
New crash information added by DrKonqi

kwin (4.9.5) on KDE Platform 4.9.5 using Qt 4.8.4

- What I was doing when the application crashed:

This crash happens almost everytime a leave a fullscreen opengl game. Maybe related: The option to disable compositing during fullscreen mode is enabled.

-- Backtrace (Reduced):
#6  brw_update_renderbuffer_surface (brw=0x156df40, rb=0x155e280, unit=0) at brw_wm_surface_state.c:1109
#7  0x00007f0d8269a3c0 in brw_update_renderbuffer_surfaces (brw=0x156df40) at brw_wm_surface_state.c:1205
#8  0x00007f0d826835c2 in brw_upload_state (brw=0x156df40) at brw_state_upload.c:498
#9  0x00007f0d826705c7 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x7fff802da758, nr_prims=22524616, prim=0x7fff802da740, arrays=<optimized out>, ctx=0x156df40) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x156df40, prim=0x7fff802da740, nr_prims=22524616, ib=0x7fff802da758, index_bounds_valid=<optimized out>, min_index=0, max_index=35, tfb_vertcount=0x0) at brw_draw.c:589
Comment 47 Thomas Lübking 2013-03-24 00:37:12 UTC
do the "fullscreen" games run a different resolution or do you have "suspend compositing for fullscreen windows" checked in "kcmshell4 kwincompositing", 3rd tab?
Comment 48 sparhawk 2013-03-24 02:11:13 UTC
I also get a lot of crashes when I come out of fullscreen from watching videos in smplayer. There is no resolution change there, but it doesn't happen all the time.
Comment 49 Kai Krakow 2013-03-24 02:33:19 UTC
@Thomas They run same resolution but I have indeed the suspend compositing setting set...
Comment 50 sparhawk 2013-03-24 03:09:20 UTC
I think we're talking about the same thing. I have "Suspend desktop effects for fullscreen windows" set in System Settings > Desktop Effects > Advanced.
Comment 51 Thomas Lübking 2013-03-24 06:53:28 UTC
disable that, your facing bug #252817
Comment 52 sparhawk 2013-03-25 02:01:28 UTC
@Thomas. Thanks. I seem to recall having the same problem even with this disabled, but I'll let you know if I hit it again.
Comment 53 Martin Flöser 2013-03-26 10:56:34 UTC
*** Bug 317373 has been marked as a duplicate of this bug. ***
Comment 54 Kai Krakow 2013-03-28 18:52:06 UTC
After disabling "unredirection" (what it really is, instead of what the words state in the UI), the crash now longer occurs. After reading Martin's blog post http://blog.martin-graesslin.com/blog/2011/04/turning-compositing-off-in-the-right-way/ I understand that unredirection of windows is only properly supported by drivers supporting two OpenGL contexts at the same time - what most drivers don't.

I've instead set a kwin rule to block compositing while Steam is running (actually that is what I run most games with) and it works fine since then (and performance is better, too). I've tried Steam on a Windows PC lately, using a two-monitor setup. And what did I discover?! Even Windows disables compositing (Aero) as soon as a game goes fullscreen. And a nice bonus is that the annoying flickering of the screen is gone now when watching fullscreen videos or playing games in fullscreen mode while some notification pops up (most annoying is Skype, I wished it had some switch to not do notifications during fullscreen sessions).

BTW: Why doesn't kwin detect fullscreen applications and blocks compositing? I've read the blog post but didn't actually get the point. If there's a WM hint since months/years why isn't it used by current games, or why isn't it detected if usedm why don't native KDE applications use it (e.g. the video player while watching fullscreen)? Not sure how to differentiate it. I wonder if there is some "magic" way to build a kwin script which detects fullscreen games and blocks compositing. I would really enjoy and favor it.
Comment 55 Thomas Lübking 2013-03-28 19:33:56 UTC
(In reply to comment #54)
> supported by drivers supporting two OpenGL contexts at the same time - what
> most drivers don't.
Actually they (should) do but are buggy on it, afair it's however more a MESA than a particular driver issue.
 
> BTW: Why doesn't kwin detect fullscreen applications and blocks compositing?
Matter of focus - it would be wrong for a fullscreened browser etc. (ie. when there will be popups and dialogs etc.)

> If there's a WM hint since months/years why isn't it used by current games, or why isn't it
> detected if usedm why don't native KDE applications use it
You'll have to ask app devs about that - most likely because it did not become NETWM canonical (iirc Sam was interested in it for compiz, but he's dropped compiz development - not sure what Canonical wants to do now)

It's however (for KDE apps) as simple as calling KWindowSystem::setBlockingCompositing(winId(), true); so just tell everybody when you're interested.

> wonder if there is some "magic" way to build a kwin script which detects
> fullscreen games and blocks compositing. I would really enjoy and favor it.
Automatic "game" detection isn't possible, but script is here:
http://kde-look.org/content/show.php/GameMode?content=156659
Comment 56 Martin Flöser 2013-04-03 06:33:59 UTC
*** Bug 317761 has been marked as a duplicate of this bug. ***
Comment 57 Thomas Lübking 2013-04-03 19:12:02 UTC
*** Bug 317796 has been marked as a duplicate of this bug. ***
Comment 58 Thomas Lübking 2013-04-03 19:13:07 UTC
FTR, bug #317796 has a slight deeper backtrace:

#6  gen7_update_renderbuffer_surface (brw=0x8c2a5d8, rb=0x8bd9050, unit=0) at gen7_wm_surface_state.c:471
#7  0xaeb8ac03 in brw_update_renderbuffer_surfaces (brw=0x8c2a5d8) at brw_wm_surface_state.c:1205
#8  0xaeb72795 in brw_upload_state (brw=brw@entry=0x8c2a5d8) at brw_state_upload.c:498
#9  0xaeb5eb47 in brw_try_draw_prims (max_index=11, min_index=0, ib=0x0, nr_prims=1, prim=0xbfc81e20, arrays=0x8c2a5d8, ctx=0x8c2a5d8) at brw_draw.c:493
#10 brw_draw_prims (ctx=0x8c2a5d8, prim=0xbfc81e20, nr_prims=1, ib=0x0, index_bounds_valid=1 '\001', min_index=0, max_index=11, tfb_vertcount=0x0) at brw_draw.c:589
#11 0xae5067b2 in vbo_draw_arrays (ctx=ctx@entry=0x8c2a5d8, mode=mode@entry=4, start=start@entry=0, count=count@entry=12, numInstances=numInstances@entry=1, baseInstance=baseInstance@entry=0) at ../../../src/mesa/vbo/vbo_exec_array.c:645
#12 0xae5068a4 in vbo_exec_DrawArrays (mode=4, start=0, count=12) at ../../../src/mesa/vbo/vbo_exec_array.c:675
#13 0xb64cede6 in KWin::GLVertexBufferPrivate::corePainting (this=0x8e14088, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.10.0/kwin/libkwineffects/kwinglutils.cpp:1254
#14 0xb64cf0b5 in KWin::GLVertexBuffer::render (this=0x8e13528, region=..., primitiveMode=4, hardwareClipping=false) at /usr/src/debug/kde-workspace-4.10.0/kwin/libkwineffects/kwinglutils.cpp:1363
Comment 59 Martin Flöser 2013-04-28 08:50:12 UTC
*** Bug 319007 has been marked as a duplicate of this bug. ***
Comment 60 Martin Flöser 2013-05-13 05:46:00 UTC
*** Bug 319758 has been marked as a duplicate of this bug. ***
Comment 61 Martin Flöser 2013-05-15 12:15:45 UTC
<dev note>I recently started to see problems like this crash on my notebook. They are triggered by a hung GPU (only solution to the problem: reboot). The reason for the hung GPU is an overflowing X event queue and dropped events. The reasons for the too many events is the synaptics (!) driver. So in future we might check in the duplicates whether the user has a touchpad and whether /var/log/Xorg.0.log contains information pointing to the problem.</dev note>
Comment 62 Martin Flöser 2013-06-19 08:44:04 UTC
*** Bug 321352 has been marked as a duplicate of this bug. ***
Comment 63 Martin Flöser 2013-07-10 06:01:52 UTC
*** Bug 322168 has been marked as a duplicate of this bug. ***
Comment 64 Thomas Lübking 2013-07-17 13:41:44 UTC
*** Bug 322487 has been marked as a duplicate of this bug. ***
Comment 65 Thomas Lübking 2013-07-29 19:13:39 UTC
*** Bug 322959 has been marked as a duplicate of this bug. ***
Comment 66 Stephan Diestelhorst 2013-07-31 08:55:14 UTC
My duplicate report asked for qdbus supportInformation.  Can be found here: http://paste.kde.org/p6a2655d8/
Comment 67 Thomas Lübking 2013-08-03 13:55:31 UTC
*** Bug 323133 has been marked as a duplicate of this bug. ***
Comment 68 Martin Flöser 2013-08-09 08:20:51 UTC
*** Bug 323303 has been marked as a duplicate of this bug. ***
Comment 69 Martin Flöser 2013-08-12 19:02:05 UTC
*** Bug 323424 has been marked as a duplicate of this bug. ***
Comment 70 Thomas Lübking 2013-10-08 16:50:57 UTC
*** Bug 325776 has been marked as a duplicate of this bug. ***
Comment 71 Thomas Lübking 2014-02-12 06:27:01 UTC
*** Bug 331031 has been marked as a duplicate of this bug. ***
Comment 72 Thomas Lübking 2014-02-16 13:46:34 UTC
*** Bug 331189 has been marked as a duplicate of this bug. ***
Comment 73 Thomas Lübking 2014-03-07 11:05:32 UTC
*** Bug 331837 has been marked as a duplicate of this bug. ***
Comment 74 Thomas Lübking 2014-03-08 17:56:00 UTC
*** Bug 331881 has been marked as a duplicate of this bug. ***
Comment 75 Thomas Lübking 2014-03-08 17:57:42 UTC
We've now driver crashes through primusrun in this as well.
Can anybody entountering this please attach the output of "xprop" and "xwininfo" on such window (maybe there's a way to detect them automatically)
Comment 76 Thomas Lübking 2014-12-04 21:12:02 UTC
*** Bug 341556 has been marked as a duplicate of this bug. ***
Comment 77 Thomas Lübking 2015-06-11 15:32:12 UTC
*** Bug 348871 has been marked as a duplicate of this bug. ***