Bug 304042 - Kwin crash
Summary: Kwin crash
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-25 08:10 UTC by Jannis Liapis
Modified: 2012-07-25 14:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
mgraesslin: Intel+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jannis Liapis 2012-07-25 08:10:27 UTC
Application: kwin (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Kwin crashes sometimes when entering screensaver, when watching flash content in fullscreen and sometimes crashes when using desktop effects like desktop grid, cube etc. I think its a intel driver problem. I have a dell inspiron n5110

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1afb740 (LWP 6714))]

Thread 4 (Thread 0xae759b40 (LWP 6719)):
#0  0xb77bc424 in __kernel_vsyscall ()
#1  0xb2a9cd13 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb759c434 in pthread_cond_timedwait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb5eb82df in wait (time=30000, this=0x96d4100) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x96d3500, mutex=0x96d34fc, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0xb5eaa474 in QThreadPoolThread::run (this=0x98ab708) at concurrent/qthreadpool.cpp:141
#6  0xb5eb7de0 in QThreadPrivate::start (arg=0x98ab708) at thread/qthread_unix.cpp:298
#7  0xb2a98d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb758eace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xacc6db40 (LWP 6723)):
#0  0xb77bc424 in __kernel_vsyscall ()
#1  0xb7587af1 in select () from /lib/i386-linux-gnu/libc.so.6
#2  0xb5ffc42a in qt_safe_select (nfds=23, fdread=0xac30058c, fdwrite=0xac3007a0, fdexcept=0xac3009b4, orig_timeout=0x0) at kernel/qcore_unix.cpp:83
#3  0xb6000a1b in QEventDispatcherUNIX::select (this=0xac300488, nfds=23, readfds=0xac30058c, writefds=0xac3007a0, exceptfds=0xac3009b4, timeout=0x0) at kernel/qeventdispatcher_unix.cpp:639
#4  0xb6001d2f in QEventDispatcherUNIXPrivate::doSelect (this=0xac300498, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#5  0xb60021f4 in QEventDispatcherUNIX::processEvents (this=0xac300488, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#6  0xb5fcb50d in QEventLoop::processEvents (this=0xacc6d240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb5fcb7a9 in QEventLoop::exec (this=0xacc6d240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5eb494c in QThread::exec (this=0x99e8ab8) at thread/qthread.cpp:501
#9  0xb5fa8b5d in QInotifyFileSystemWatcherEngine::run (this=0x99e8ab8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb5eb7de0 in QThreadPrivate::start (arg=0x99e8ab8) at thread/qthread_unix.cpp:298
#11 0xb2a98d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb758eace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac2ffb40 (LWP 6724)):
#0  0xb77bc424 in __kernel_vsyscall ()
#1  0xb2a9c96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb759c3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb66aa029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb66aa06f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2a98d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb758eace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1afb740 (LWP 6714)):
[KCrash Handler]
#7  brw_update_renderbuffer_surface (brw=0x96eade8, rb=0x98b2ac0, unit=0) at brw_wm_surface_state.c:959
#8  0xaeb88583 in brw_update_renderbuffer_surfaces (brw=0x96eade8) at brw_wm_surface_state.c:1052
#9  0xaeb7142f in brw_upload_state (brw=0x96eade8) at brw_state_upload.c:503
#10 0xaeb5c6f7 in brw_try_draw_prims (max_index=3, min_index=0, ib=0x0, nr_prims=1, prim=0xbfe66f18, arrays=0x974b130, ctx=0x96eade8) at brw_draw.c:482
#11 brw_draw_prims (ctx=0x96eade8, arrays=0x974b130, prim=0xbfe66f18, nr_prims=1, ib=0x0, index_bounds_valid=1 '\001', min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:566
#12 0xae9ba69e in vbo_draw_arrays (ctx=0x96eade8, mode=6, start=0, count=4, numInstances=1) at vbo/vbo_exec_array.c:600
#13 0xaea6d277 in _mesa_meta_glsl_Clear (ctx=0x96eade8, buffers=2) at drivers/common/meta.c:1913
#14 0xaeb3d484 in intelClear (ctx=0x96eade8, mask=2) at intel_clear.c:192
#15 0xae8e1189 in _mesa_Clear (mask=<optimized out>) at main/clear.c:242
#16 0xb7726438 in KWin::SceneOpenGL::paintBackground (this=0x98ab200, region=...) at ../../kwin/scene_opengl.cpp:180
#17 0xb7712fdb in KWin::Scene::paintGenericScreen (this=0x98ab200, orig_mask=520) at ../../kwin/scene.cpp:206
#18 0xb7721824 in KWin::SceneOpenGL::paintGenericScreen (this=0x98ab200, mask=520, data=...) at ../../kwin/scene_opengl.cpp:167
#19 0xb770f8d0 in KWin::Scene::finalPaintScreen (this=0x98ab200, mask=520, region=..., data=...) at ../../kwin/scene.cpp:196
#20 0xb77379c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x99988e0, mask=520, region=..., data=...) at ../../kwin/effects.cpp:222
#21 0xb695053a in KWin::Effect::paintScreen (this=0x9a35bd8, mask=520, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#22 0xb7737970 in KWin::EffectsHandlerImpl::paintScreen (this=0x99988e0, mask=520, region=..., data=...) at ../../kwin/effects.cpp:219
#23 0xb695053a in KWin::Effect::paintScreen (this=0x9a71f80, mask=520, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#24 0xb7737970 in KWin::EffectsHandlerImpl::paintScreen (this=0x99988e0, mask=520, region=..., data=...) at ../../kwin/effects.cpp:219
#25 0xb695053a in KWin::Effect::paintScreen (this=0x9badfd0, mask=520, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#26 0xb7737970 in KWin::EffectsHandlerImpl::paintScreen (this=0x99988e0, mask=520, region=..., data=...) at ../../kwin/effects.cpp:219
#27 0xb695053a in KWin::Effect::paintScreen (this=0x9a1a050, mask=520, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#28 0xb7737970 in KWin::EffectsHandlerImpl::paintScreen (this=0x99988e0, mask=520, region=..., data=...) at ../../kwin/effects.cpp:219
#29 0xb77123cf in KWin::Scene::paintScreen (this=0x98ab200, mask=0xbfe67824, region=0xbfe678b0) at ../../kwin/scene.cpp:156
#30 0xb772ab69 in KWin::SceneOpenGL::paint (this=0x98ab200, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:459
#31 0xb770b9db in KWin::Workspace::performCompositing (this=0x98beb68) at ../../kwin/composite.cpp:412
#32 0xb5fe7ac4 in QObject::event (this=0x98beb68, e=0xbfe67d9c) at kernel/qobject.cpp:1157
#33 0xb54b6ed4 in notify_helper (e=0xbfe67d9c, receiver=0x98beb68, this=0x95b04e8) at kernel/qapplication.cpp:4559
#34 QApplicationPrivate::notify_helper (this=0x95b04e8, receiver=0x98beb68, e=0xbfe67d9c) at kernel/qapplication.cpp:4531
#35 0xb54bc30d in QApplication::notify (this=0xbfe67d9c, receiver=0x98beb68, e=0xbfe67d9c) at kernel/qapplication.cpp:4288
#36 0xb724c401 in KApplication::notify (this=0xbfe680a8, receiver=0x98beb68, event=0xbfe67d9c) at ../../kdeui/kernel/kapplication.cpp:311
#37 0xb76b47ff in notify (e=0xbfe67d9c, o=0x98beb68, this=0xbfe680a8) at ../../kwin/main.cpp:368
#38 KWin::Application::notify (this=0xbfe680a8, o=0x98beb68, e=0xbfe67d9c) at ../../kwin/main.cpp:364
#39 0xb5fcc97e in QCoreApplication::notifyInternal (this=0xbfe680a8, receiver=0x98beb68, event=0xbfe67d9c) at kernel/qcoreapplication.cpp:876
#40 0xb6001990 in sendEvent (event=0xbfe67d9c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#41 QTimerInfoList::activateTimers (this=0x95b0dcc) at kernel/qeventdispatcher_unix.cpp:611
#42 0xb6002207 in QEventDispatcherUNIX::processEvents (this=0x9565ea0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#43 0xb5570b6e in QEventDispatcherX11::processEvents (this=0x9565ea0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#44 0xb5fcb50d in QEventLoop::processEvents (this=0xbfe67fe4, flags=...) at kernel/qeventloop.cpp:149
#45 0xb5fcb7a9 in QEventLoop::exec (this=0xbfe67fe4, flags=...) at kernel/qeventloop.cpp:204
#46 0xb5fd0eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#47 0xb54b4a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#48 0xb76b77c5 in kdemain (argc=3, argv=0xbfe68354) at ../../kwin/main.cpp:541
#49 0x0804850b in main (argc=3, argv=0xbfe68354) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 303961, bug 303041, bug 302764, bug 302169, bug 301529.

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-07-25 08:13:04 UTC
driver bug
"kcmshell4 kwincompositing", uncheck "suspend compositing for fullscreen windows" or try updated mesa

*** This bug has been marked as a duplicate of bug 252817 ***