Bug 298911

Summary: Reply to decrypted mail quotes encrypted text
Product: kmail2 Reporter: Axel Braun <axel.braun>
Component: cryptoAssignee: Sandro Knauß <sknauss>
Status: RESOLVED FIXED    
Severity: normal CC: aacid, cc, grote, hauke, maxi, montel, quazgar, robert, sknauss, wildcart
Priority: NOR    
Version: Git (master)   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In: 4.10.3

Description Axel Braun 2012-04-27 13:47:15 UTC
Receive an encrypted mail, decrypt it and hit reply: The encrypted text is quoted:
Am Freitag, 27. April 2012, 11:10:05 schrieben Sie:
> -----BEGIN PGP MESSAGE-----
> Version: PGP Desktop 10.0.3 (Build 1)
> Charset: UTF-8
> 
> qANQR1DBwU4DhehUJfpXo/kQB/9jl1v1txCN2mMy5K8STaOE4dGgH2pr/EoeoX75
> +v62UYAMzAzOPfIaQKVO1SB01OvaUD4IFpES4fA77W8jLj4UmgGCalR2xvMl4v5D
> lPDQ6DG92El5qBsR8fYE4aIlDx7lBw8kdEjeTY9zeqw6GHoVUvVEdBjboYuaBPlm
> aeXAivaXkiVR2eZdDgzpDUnpHU6FZpCd1Ma5uPyxLft5cgyc9h/2p9VQuRnM8iXI

Reproducible: Always

Steps to Reproduce:
1. see above
2.
3.
Actual Results:  
encryptred text is quoted

Expected Results:  
decrypted text is quoted
Comment 1 Laurent Montel 2012-04-27 14:03:15 UTC
Ah ?
It's time for me to test/debug crypto feature
Comment 2 Laurent Montel 2012-05-17 19:12:34 UTC
*** Bug 300175 has been marked as a duplicate of this bug. ***
Comment 3 Laurent Montel 2012-06-14 15:53:45 UTC
I confirm it.
It's wierd we can decrypt when we click on but reply doesn't call same function for decrypt.
Will look at
Comment 4 Robert Riemann 2012-08-30 09:19:55 UTC
I think it's weird to have the PGP Signature in the respond text as well. So this affects not only encrypted mails, but also signed mails.

Any progress on this bug so far?
Comment 5 Laurent Montel 2012-08-30 10:04:03 UTC
I continue to investigate it.
Comment 6 Axel Braun 2012-09-04 14:36:25 UTC
And by the way, if reply to an encrypted mail, the encrypt-flag on the mail should automatically be set. That was standard in KMAIL1 as well.
Comment 7 Maximilian Engelhardt 2012-09-04 15:26:28 UTC
Yes, I reported this as Bug #304940 a while ago.
Comment 8 Thomas Baumgart 2012-09-09 18:01:19 UTC
Ran into the same problem. Selecting all the text of the (de)crypted message and then using Reply-To serves as a work-around.
Comment 9 Sandro Knauß 2013-03-11 01:56:54 UTC
Same problem for forwarding mails
Comment 10 Sandro Knauß 2013-03-26 07:48:13 UTC
*** Bug 296521 has been marked as a duplicate of this bug. ***
Comment 11 Sandro Knauß 2013-03-30 16:48:40 UTC
*** Bug 308831 has been marked as a duplicate of this bug. ***
Comment 12 Sandro Knauß 2013-03-30 17:54:49 UTC
Git commit ad92ce480599b7f36586174883f7bc6bb7e0f5ca by Sandro Knauß.
Committed on 19/03/2013 at 03:33.
Pushed by knauss into branch 'KDE/4.10'.

Reply to decrypted mail quotes encrypted text

Replying messages with have the decrypted test in body and not the
encrypted message.
FIXED-IN: 4.10.2
REVIEW: 109575

M  +24   -25   messageviewer/objecttreeparser.cpp

http://commits.kde.org/kdepim/ad92ce480599b7f36586174883f7bc6bb7e0f5ca
Comment 13 Axel Braun 2013-03-31 06:21:19 UTC
Sandro, thanks for fixing this!
Comment 14 Albert Astals Cid 2013-04-01 20:43:50 UTC
If this was commited this saturday i guess it won't be in 4.10.2 since it was tagged on thursday, no?
Comment 15 Sandro Knauß 2013-04-07 14:36:18 UTC
@albert: yes you are right, but 4.10.2 wasn't tagged as I pushed to kdepim
Comment 16 Albert Astals Cid 2013-04-07 15:03:58 UTC
You got a mail (like all kde people) with a tag date. The git-tags are only created after release in case an emergency recreation of the tarballs needs to be done.
Comment 17 Sandro Knauß 2013-08-02 21:26:05 UTC
*** Bug 322138 has been marked as a duplicate of this bug. ***