Bug 296521 - Inline encrypted drafts don't decrypt on re-opening
Summary: Inline encrypted drafts don't decrypt on re-opening
Status: RESOLVED DUPLICATE of bug 298911
Alias: None
Product: kmail2
Classification: Unclassified
Component: crypto (show other bugs)
Version: 4.7
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 20:47 UTC by quazgar
Modified: 2013-03-26 07:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quazgar 2012-03-21 20:47:19 UTC
As the title says:
Saving mails which are marked to be inline-encrypted as drafts works correctly, the message is correctly shown after entering the decryption credentials. Yet editing does not work, since the message body is not decrypted in the editing window.

This happens with KMail 4.7.4 and is fullr reproducible here.
Comment 1 Sandro Knauß 2013-03-26 07:48:13 UTC
Internally the same methods are used for forwarding, replying and editing an email.

*** This bug has been marked as a duplicate of bug 298911 ***