Bug 308831 - Replying to inline signed emails adds the gpg header to the reply
Summary: Replying to inline signed emails adds the gpg header to the reply
Status: RESOLVED DUPLICATE of bug 298911
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-10-22 20:32 UTC by Albert Astals Cid
Modified: 2013-03-30 16:48 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The said email (7.08 KB, application/mbox)
2012-10-22 20:34 UTC, Albert Astals Cid
Details
How it looks when viewing the email (that is correct) (444.47 KB, image/png)
2012-11-11 15:56 UTC, Albert Astals Cid
Details
How it looks when replying the email (that is wrong, the gpg header text should not be there) (532.74 KB, image/png)
2012-11-11 15:56 UTC, Albert Astals Cid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2012-10-22 20:32:53 UTC
When replying to the attached message kmail1 (as confirmed by dfaure) strips the BEGIN PGP SIGNED MESSAGE headers and just put "the real text" in the reply

Reproducible: Always

Steps to Reproduce:
1. Get the attached email
2. Reply to it
Actual Results:  
3. See the BEGIN PGP SIGNED MESSAGE is there

Expected Results:  
3. Only the clear text is there

This does not happen with non inline signed messages
Comment 1 Albert Astals Cid 2012-10-22 20:34:34 UTC
Created attachment 74736 [details]
The said email
Comment 2 Laurent Montel 2012-10-24 06:49:35 UTC
Ok will look at it this week.

Regards
Comment 3 Laurent Montel 2012-10-25 07:58:31 UTC
it doesn't detect that it's signed. Wierd
Comment 4 Albert Astals Cid 2012-11-01 15:40:21 UTC
Laurent, do you mean you don't get the "html gpg header" when looking at the email?
Comment 5 Laurent Montel 2012-11-02 10:02:07 UTC
yes I don't know it.
I saw it as "normal" email.
Comment 6 Albert Astals Cid 2012-11-02 18:26:05 UTC
Weird, if i click in the link to the mbox in bugzilla and say to open it in with "KMail viewer" it is correctly detected as encrypted, anything i may do to help you?
Comment 7 Laurent Montel 2012-11-11 11:23:52 UTC
I retested it and can't see info about encrypted mails.
Could you paste screenshot to show how it must be show ?

(Will look at with my install why I can't show it as encrypted mail.)
Comment 8 Albert Astals Cid 2012-11-11 15:56:10 UTC
Created attachment 75174 [details]
How it looks when viewing the email (that is correct)
Comment 9 Albert Astals Cid 2012-11-11 15:56:51 UTC
Created attachment 75175 [details]
How it looks when replying the email (that is wrong, the gpg header text should not be there)
Comment 10 Christian Quast 2013-02-12 12:34:02 UTC
I have the same problem, also at the end of the reply the signature is added. So the compelte reply looks like this in the composer window:

On Tuesday 12 February 2013 10:10:00 you wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hallo
[...]
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2.0.19 (GNU/Linux)
[...]
> -----END PGP SIGNATURE-----


Cheers
 Christian
Comment 11 Christian Quast 2013-02-12 12:35:20 UTC
forgot to say that I am using KDE 4.10 on opensuse 12.2. Package versions are:

akonadi-runtime-1.9.0-127.1.x86_64
akonadi-4.10.0-380.1.x86_64
libakonadi4-4.10.0-317.1.x86_64
kmail-4.10.0-380.1.x86_64
libakonadiprotocolinternals1-1.9.0-127.1.x86_64
Comment 12 Allen Winter 2013-03-30 15:38:28 UTC
CC: Sandro
Comment 13 Sandro Knauß 2013-03-30 16:48:40 UTC

*** This bug has been marked as a duplicate of bug 298911 ***