Bug 294591

Summary: Muon Software Centre
Product: kde Reporter: sharulr <sharulriza>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee, theunbeliever73
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description sharulr 2012-02-22 01:12:21 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
i cant open Muon Software Centre. everytime i open it will automaticly close. please help me.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb785f930 (LWP 1909))]

Thread 2 (Thread 0xb5b61b70 (LWP 1910)):
#0  0x00aff416 in __kernel_vsyscall ()
#1  0x00c5340e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x082d834b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x082c9896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x082c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00ee1ada in QEventDispatcherGlib::processEvents (this=0x9893008, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#6  0x00eb21dd in QEventLoop::processEvents (this=0xb5b612b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00eb2421 in QEventLoop::exec (this=0xb5b612b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00db590b in QThread::exec (this=0x9833f20) at thread/qthread.cpp:498
#9  0x00e92e2d in QInotifyFileSystemWatcherEngine::run (this=0x9833f20) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00db87b3 in QThreadPrivate::start (arg=0x9833f20) at thread/qthread_unix.cpp:331
#11 0x00893d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00c620ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb785f930 (LWP 1909)):
[KCrash Handler]
#7  0x00e0ce11 in QtPrivate::QStringList_contains (that=0xbfe29244, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe29244) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x982ea20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x982ea20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe29464) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00eb9b7d in metacall (argv=0xbfe29464, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x982ea20) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x982ea20, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe29464) at kernel/qmetaobject.cpp:232
#13 0x00ec8a6a in QMetaObject::activate (sender=0x98b61a8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x98b61a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x98b61a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe295a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00eb9b7d in metacall (argv=0xbfe295a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x98b61a8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x98b61a8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe295a8) at kernel/qmetaobject.cpp:232
#18 0x00ec8a6a in QMetaObject::activate (sender=0x982ea20, m=0x80950c0, local_signal_index=0, argv=0xbfe295a8) at kernel/qobject.cpp:3278
#19 0x00b5c7c5 in MuonMainWindow::backendReady (this=0x982ea20, _t1=0x98354a0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00b5c933 in MuonMainWindow::initObject (this=0x982ea20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x982ea20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x982ea20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe296d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00eb9b7d in metacall (argv=0xbfe296d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x982ea20) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x982ea20, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe296d4) at kernel/qmetaobject.cpp:232
#25 0x00ec8a6a in QMetaObject::activate (sender=0x9890778, m=0xfe9238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00ed0375 in QSingleShotTimer::timeout (this=0x9890778) at .moc/release-shared/qtimer.moc:82
#27 0x00ed042c in QSingleShotTimer::timerEvent (this=0x9890778) at kernel/qtimer.cpp:308
#28 0x00ecb994 in QObject::event (this=0x9890778, e=0xbfe29acc) at kernel/qobject.cpp:1181
#29 0x051f0d84 in notify_helper (e=0xbfe29acc, receiver=0x9890778, this=0x972d8e8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x972d8e8, receiver=0x9890778, e=0xbfe29acc) at kernel/qapplication.cpp:4458
#31 0x051f6133 in QApplication::notify (this=0xbfe29acc, receiver=0x9890778, e=0xbfe29acc) at kernel/qapplication.cpp:3886
#32 0x011d5971 in KApplication::notify (this=0xbfe29de0, receiver=0x9890778, event=0xbfe29acc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00eb319e in QCoreApplication::notifyInternal (this=0xbfe29de0, receiver=0x9890778, event=0xbfe29acc) at kernel/qcoreapplication.cpp:787
#34 0x00ee3c10 in sendEvent (event=0xbfe29acc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9729a3c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ee1122 in timerSourceDispatch (source=0x9729a08) at kernel/qeventdispatcher_glib.cpp:184
#37 0x082c925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x082c9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x082c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ee1ada in QEventDispatcherGlib::processEvents (this=0x970b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x052a8e7a in QGuiEventDispatcherGlib::processEvents (this=0x970b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00eb21dd in QEventLoop::processEvents (this=0xbfe29d44, flags=...) at kernel/qeventloop.cpp:149
#43 0x00eb2421 in QEventLoop::exec (this=0xbfe29d44, flags=...) at kernel/qeventloop.cpp:201
#44 0x00eb719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x051ee924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294484, bug 294456, bug 294433, bug 294431, bug 294414.

Reported using DrKonqi
Comment 1 Charles Thomas 2012-02-22 02:54:18 UTC
Created attachment 68996 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
Opening the application, i tried both when i first booted up as well as after the system had been running for a few minutes.

-- Backtrace (Reduced):
#6  0x00007f057dd29a5e in QtPrivate::QStringList_contains (that=0x7fff8ade7d50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8ade7d50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1dfb9d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1dfb9d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8ade8320) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1fdd1c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8ade8480) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Jekyll Wu 2012-02-22 09:53:04 UTC

*** This bug has been marked as a duplicate of bug 291262 ***