Bug 293735

Summary: Reading emailsin different IMAP folders
Product: [Applications] kontact Reporter: Chris <crglasoe>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Chris 2012-02-09 18:22:28 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4) "release 5"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
I am switching between IMAP folders to read new messages that have arrived.  With each switch Kmail crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f63165b0760 (LWP 10933))]

Thread 6 (Thread 0x7f62f88d4700 (LWP 10936)):
#0  0x00007f630e47ee6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6312ddbc12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f6312ddbc49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f630e47af05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f6313aca63d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f62f7fc3700 (LWP 10937)):
#0  0x00007f6313ac1523 in poll () from /lib64/libc.so.6
#1  0x00007f630d104a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f630d104f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f6314f0f526 in QEventDispatcherGlib::processEvents (this=0x7f62f00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6314edf272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6314edf4c7 in QEventLoop::exec (this=0x7f62f7fc2e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6314de0137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6314de315b in QThreadPrivate::start (arg=0x63e530) at thread/qthread_unix.cpp:298
#8  0x00007f630e47af05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f6313aca63d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f62a904c700 (LWP 10940)):
#0  0x00007f630e47f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6314de35cf in wait (time=30000, this=0x1377680) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1318878, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6314dd69df in QThreadPoolThread::run (this=0xf00fb0) at concurrent/qthreadpool.cpp:141
#4  0x00007f6314de315b in QThreadPrivate::start (arg=0xf00fb0) at thread/qthread_unix.cpp:298
#5  0x00007f630e47af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6313aca63d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f62a208d700 (LWP 10960)):
#0  0x00007f630e47f1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6314de35cf in wait (time=30000, this=0x1377680) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1318878, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6314dd69df in QThreadPoolThread::run (this=0x7f62940093d0) at concurrent/qthreadpool.cpp:141
#4  0x00007f6314de315b in QThreadPrivate::start (arg=0x7f62940093d0) at thread/qthread_unix.cpp:298
#5  0x00007f630e47af05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f6313aca63d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f62a288e700 (LWP 10996)):
#0  0x00007f630e47ee6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f6314de366b in wait (time=18446744073709551615, this=0x7f62940088a0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f6294011de0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f6314ddf494 in QSemaphore::acquire (this=0x7f62a288bdb0, n=1) at thread/qsemaphore.cpp:144
#4  0x00007f6314ef482c in QMetaObject::activate (sender=0x4c840e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f62a288be20) at kernel/qobject.cpp:3525
#5  0x00007f630f445be4 in QHttpThreadDelegate::sslErrors (this=<optimized out>, _t1=<optimized out>, _t2=0x7f62a288be6f, _t3=0x7f62a288be60) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:192
#6  0x00007f630f3dfd1a in QHttpThreadDelegate::sslErrorsSlot (this=0x4c840e0, errors=...) at access/qhttpthreaddelegate.cpp:536
#7  0x00007f630f4463b1 in QHttpThreadDelegate::qt_static_metacall (_o=0x4c840e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:127
#8  0x00007f6314ef4331 in QMetaObject::activate (sender=0x7f62940322f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f62a288c080) at kernel/qobject.cpp:3547
#9  0x00007f630f444502 in QHttpNetworkReply::sslErrors (this=<optimized out>, _t1=<optimized out>) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:132
#10 0x00007f630f3a3c42 in QHttpNetworkConnectionChannel::_q_sslErrors (this=0x7f62940144e8, errors=...) at access/qhttpnetworkconnectionchannel.cpp:1150
#11 0x00007f6314ef4331 in QMetaObject::activate (sender=0x7f62940142d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f62a288c1e0) at kernel/qobject.cpp:3547
#12 0x00007f630f4320c5 in QSslSocket::sslErrors (this=<optimized out>, _t1=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:163
#13 0x00007f630f43c570 in QSslSocketBackendPrivate::startHandshake (this=0x7f6294014d70) at ssl/qsslsocket_openssl.cpp:1343
#14 0x00007f630f43dead in QSslSocketBackendPrivate::transmit (this=0x7f6294014d70) at ssl/qsslsocket_openssl.cpp:1084
#15 0x00007f630f437819 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:98
#16 QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:77
#17 0x00007f6314ef4331 in QMetaObject::activate (sender=0x7f6294032b20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#18 0x00007f630f4173ef in QAbstractSocketPrivate::canReadNotification (this=0x7f6294032b40) at socket/qabstractsocket.cpp:651
#19 0x00007f630f41ef41 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#20 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1148
#21 0x00007f6314266d84 in notify_helper (e=0x7f62a288dc10, receiver=0x7f629400f2b0, this=0x641a50) at kernel/qapplication.cpp:4550
#22 QApplicationPrivate::notify_helper (this=0x641a50, receiver=0x7f629400f2b0, e=0x7f62a288dc10) at kernel/qapplication.cpp:4522
#23 0x00007f631426bc03 in QApplication::notify (this=0x7fff365ea6e0, receiver=0x7f629400f2b0, e=0x7f62a288dc10) at kernel/qapplication.cpp:4411
#24 0x00007f6315957186 in KApplication::notify (this=0x7fff365ea6e0, receiver=0x7f629400f2b0, event=0x7f62a288dc10) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#25 0x00007f6314ee048c in QCoreApplication::notifyInternal (this=0x7fff365ea6e0, receiver=0x7f629400f2b0, event=0x7f62a288dc10) at kernel/qcoreapplication.cpp:876
#26 0x00007f6314f0eb17 in sendEvent (event=0x7f62a288dc10, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#27 socketNotifierSourceDispatch (source=0x7f6294012ab0) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007f630d10458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f630d104d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f630d104f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f6314f0f4bf in QEventDispatcherGlib::processEvents (this=0x7f6294030c10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007f6314edf272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f6314edf4c7 in QEventLoop::exec (this=0x7f62a288de20, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f6314de0137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#35 0x00007f6314de315b in QThreadPrivate::start (arg=0x4bc5aa0) at thread/qthread_unix.cpp:298
#36 0x00007f630e47af05 in start_thread () from /lib64/libpthread.so.0
#37 0x00007f6313aca63d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f63165b0760 (LWP 10933)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4c7fbf0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f630f444fc9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4c7fbf0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f6314ef94f6 in QObject::event (this=0x4c7fbf0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f6314266d84 in notify_helper (e=0x7f629402fbf0, receiver=0x4c7fbf0, this=0x641a50) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x641a50, receiver=0x4c7fbf0, e=0x7f629402fbf0) at kernel/qapplication.cpp:4522
#11 0x00007f631426bc03 in QApplication::notify (this=0x7fff365ea6e0, receiver=0x4c7fbf0, e=0x7f629402fbf0) at kernel/qapplication.cpp:4411
#12 0x00007f6315957186 in KApplication::notify (this=0x7fff365ea6e0, receiver=0x4c7fbf0, event=0x7f629402fbf0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007f6314ee048c in QCoreApplication::notifyInternal (this=0x7fff365ea6e0, receiver=0x4c7fbf0, event=0x7f629402fbf0) at kernel/qcoreapplication.cpp:876
#14 0x00007f6314ee3d2a in sendEvent (event=0x7f629402fbf0, receiver=0x4c7fbf0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60c7a0) at kernel/qcoreapplication.cpp:1500
#16 0x00007f6314f0f093 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f630d10458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f630d104d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f630d104f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f6314f0f4bf in QEventDispatcherGlib::processEvents (this=0x60c060, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f6314309dee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f6314edf272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f6314edf4c7 in QEventLoop::exec (this=0x7fff365ea670, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f6314ee4025 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f6313a1223d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e61 in _start ()

Possible duplicates by query: bug 293656, bug 293458, bug 293261, bug 293003, bug 292815.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-02-13 10:53:37 UTC

*** This bug has been marked as a duplicate of bug 208307 ***
Comment 2 Christophe Giboudeaux 2012-02-13 10:53:54 UTC

*** This bug has been marked as a duplicate of bug 286307 ***