Bug 293458

Summary: Kmail crashed while reading email
Product: [Applications] kontact Reporter: Chris <crglasoe>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Chris 2012-02-06 16:01:01 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4) "release 5"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
Kmail crashed while reading email.  Had recently added QT 4.8 following a discussion about webkit causing issues with IMAP.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb71309b760 (LWP 6601))]

Thread 5 (Thread 0x7fb6f53bf700 (LWP 6604)):
#0  0x00007fb70af69e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb70f8c6c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fb70f8c6c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fb70af65f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fb7105b563d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fb6f4ab6700 (LWP 6605)):
#0  0x00007fb70af68014 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fb709bee98d in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fb709bef92d in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fb709beff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fb7119fa526 in QEventDispatcherGlib::processEvents (this=0x7fb6f00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fb7119ca272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb7119ca4c7 in QEventLoop::exec (this=0x7fb6f4ab5e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fb7118cb137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fb7118ce15b in QThreadPrivate::start (arg=0x643dc0) at thread/qthread_unix.cpp:298
#9  0x00007fb70af65f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fb7105b563d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fb68f7fe700 (LWP 6776)):
#0  0x00007fb70af69e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb7118ce66b in wait (time=18446744073709551615, this=0x7fb6800273c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb6800133e0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb7118ca494 in QSemaphore::acquire (this=0x7fb68f7fbdb0, n=1) at thread/qsemaphore.cpp:144
#4  0x00007fb7119df82c in QMetaObject::activate (sender=0x6d7bc80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fb68f7fbe20) at kernel/qobject.cpp:3525
#5  0x00007fb70bf30be4 in QHttpThreadDelegate::sslErrors (this=<optimized out>, _t1=<optimized out>, _t2=0x7fb68f7fbe6f, _t3=0x7fb68f7fbe60) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:192
#6  0x00007fb70becad1a in QHttpThreadDelegate::sslErrorsSlot (this=0x6d7bc80, errors=...) at access/qhttpthreaddelegate.cpp:536
#7  0x00007fb70bf313b1 in QHttpThreadDelegate::qt_static_metacall (_o=0x6d7bc80, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qhttpthreaddelegate_p.cpp:127
#8  0x00007fb7119df331 in QMetaObject::activate (sender=0x7fb68000b110, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fb68f7fc080) at kernel/qobject.cpp:3547
#9  0x00007fb70bf2f502 in QHttpNetworkReply::sslErrors (this=<optimized out>, _t1=<optimized out>) at .moc/release-shared/moc_qhttpnetworkreply_p.cpp:132
#10 0x00007fb70be8ec42 in QHttpNetworkConnectionChannel::_q_sslErrors (this=0x7fb6800075d8, errors=...) at access/qhttpnetworkconnectionchannel.cpp:1150
#11 0x00007fb7119df331 in QMetaObject::activate (sender=0x7fb680006dc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fb68f7fc1e0) at kernel/qobject.cpp:3547
#12 0x00007fb70bf1d0c5 in QSslSocket::sslErrors (this=<optimized out>, _t1=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:163
#13 0x00007fb70bf27570 in QSslSocketBackendPrivate::startHandshake (this=0x7fb680007dc0) at ssl/qsslsocket_openssl.cpp:1343
#14 0x00007fb70bf28ead in QSslSocketBackendPrivate::transmit (this=0x7fb680007dc0) at ssl/qsslsocket_openssl.cpp:1084
#15 0x00007fb70bf22819 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:98
#16 QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qsslsocket.cpp:77
#17 0x00007fb7119df331 in QMetaObject::activate (sender=0x7fb68000b970, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#18 0x00007fb70bf023ef in QAbstractSocketPrivate::canReadNotification (this=0x7fb68000b990) at socket/qabstractsocket.cpp:651
#19 0x00007fb70bf09f41 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1151
#20 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1148
#21 0x00007fb710d51d84 in notify_helper (e=0x7fb68f7fdc10, receiver=0x7fb680006280, this=0x639050) at kernel/qapplication.cpp:4550
#22 QApplicationPrivate::notify_helper (this=0x639050, receiver=0x7fb680006280, e=0x7fb68f7fdc10) at kernel/qapplication.cpp:4522
#23 0x00007fb710d56c03 in QApplication::notify (this=0x7fff55b39410, receiver=0x7fb680006280, e=0x7fb68f7fdc10) at kernel/qapplication.cpp:4411
#24 0x00007fb712442186 in KApplication::notify (this=0x7fff55b39410, receiver=0x7fb680006280, event=0x7fb68f7fdc10) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#25 0x00007fb7119cb48c in QCoreApplication::notifyInternal (this=0x7fff55b39410, receiver=0x7fb680006280, event=0x7fb68f7fdc10) at kernel/qcoreapplication.cpp:876
#26 0x00007fb7119f9b17 in sendEvent (event=0x7fb68f7fdc10, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#27 socketNotifierSourceDispatch (source=0x7fb680001310) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007fb709bef58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fb709befd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#30 0x00007fb709beff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#31 0x00007fb7119fa4bf in QEventDispatcherGlib::processEvents (this=0x7fb6800008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007fb7119ca272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fb7119ca4c7 in QEventLoop::exec (this=0x7fb68f7fde20, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fb7118cb137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#35 0x00007fb7118ce15b in QThreadPrivate::start (arg=0x81aa6d0) at thread/qthread_unix.cpp:298
#36 0x00007fb70af65f05 in start_thread () from /lib64/libpthread.so.0
#37 0x00007fb7105b563d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fb694ac3700 (LWP 6777)):
#0  0x00007fb70af6a1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fb7118ce5cf in wait (time=30000, this=0xa92020) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x13857d8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb7118c19df in QThreadPoolThread::run (this=0x7fb6a0017830) at concurrent/qthreadpool.cpp:141
#4  0x00007fb7118ce15b in QThreadPrivate::start (arg=0x7fb6a0017830) at thread/qthread_unix.cpp:298
#5  0x00007fb70af65f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007fb7105b563d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fb71309b760 (LWP 6601)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x81aa350, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fb70bf2ffc9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x81aa350, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fb7119e44f6 in QObject::event (this=0x81aa350, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fb710d51d84 in notify_helper (e=0x7fb680011230, receiver=0x81aa350, this=0x639050) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639050, receiver=0x81aa350, e=0x7fb680011230) at kernel/qapplication.cpp:4522
#11 0x00007fb710d56c03 in QApplication::notify (this=0x7fff55b39410, receiver=0x81aa350, e=0x7fb680011230) at kernel/qapplication.cpp:4411
#12 0x00007fb712442186 in KApplication::notify (this=0x7fff55b39410, receiver=0x81aa350, event=0x7fb680011230) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007fb7119cb48c in QCoreApplication::notifyInternal (this=0x7fff55b39410, receiver=0x81aa350, event=0x7fb680011230) at kernel/qcoreapplication.cpp:876
#14 0x00007fb7119ced2a in sendEvent (event=0x7fb680011230, receiver=0x81aa350) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60c7a0) at kernel/qcoreapplication.cpp:1500
#16 0x00007fb7119fa093 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fb709bef58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fb709befd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fb709beff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fb7119fa4bf in QEventDispatcherGlib::processEvents (this=0x60c060, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fb710df4dee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fb7119ca272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fb7119ca4c7 in QEventLoop::exec (this=0x7fff55b393a0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fb7119cf025 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007fb7104fd23d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e61 in _start ()

Possible duplicates by query: bug 293261, bug 293003, bug 292815, bug 292500, bug 289879.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-02-06 17:07:21 UTC

*** This bug has been marked as a duplicate of bug 208307 ***
Comment 2 Christophe Marin 2012-02-06 17:07:32 UTC

*** This bug has been marked as a duplicate of bug 286307 ***