Bug 293153

Summary: kubuntu 64 crash
Product: kde Reporter: alocrius
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description alocrius 2012-02-02 15:55:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I had upgraded kde components and installed most all of the kde plasma packages.  Muon software center would not start after this.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbd6a6e2780 (LWP 3747))]

Thread 2 (Thread 0x7fbd55cb2700 (LWP 3751)):
#0  0x00007fbd672ad773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbd63b22f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbd63b23429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbd6946af3e in QEventDispatcherGlib::processEvents (this=0xa18f10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fbd6943ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbd6943eef7 in QEventLoop::exec (this=0x7fbd55cb1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fbd6935627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fbd69421cbf in QInotifyFileSystemWatcherEngine::run (this=0xa11f00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fbd69358d05 in QThreadPrivate::start (arg=0xa11f00) at thread/qthread_unix.cpp:331
#9  0x00007fbd64604efc in start_thread (arg=0x7fbd55cb2700) at pthread_create.c:304
#10 0x00007fbd672b989d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbd6a6e2780 (LWP 3747)):
[KCrash Handler]
#6  0x00007fbd693a6a5e in QtPrivate::QStringList_contains (that=0x7fff6e761e00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6e761e00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x830380) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x830380, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6e7623d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fbd69452eba in QMetaObject::activate (sender=0x899d00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x899d00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6e762530) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fbd69452eba in QMetaObject::activate (sender=0x830380, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6e762530) at kernel/qobject.cpp:3278
#13 0x00007fbd6a2c8e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x899c20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fbd6a2c8f8e in MuonMainWindow::initObject (this=0x830380) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x830380) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x830380, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6e762600) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fbd69452eba in QMetaObject::activate (sender=0x8ee420, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fbd6945af7f in QSingleShotTimer::timerEvent (this=0x8ee420) at kernel/qtimer.cpp:308
#19 0x00007fbd69456789 in QObject::event (this=0x8ee420, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fbd67a7a424 in notify_helper (e=0x7fff6e762b70, receiver=0x8ee420, this=0x6e41d0) at kernel/qapplication.cpp:4476
#21 QApplicationPrivate::notify_helper (this=0x6e41d0, receiver=0x8ee420, e=0x7fff6e762b70) at kernel/qapplication.cpp:4458
#22 0x00007fbd67a7f291 in QApplication::notify (this=0x7fff6e762e70, receiver=0x8ee420, e=0x7fff6e762b70) at kernel/qapplication.cpp:3858
#23 0x00007fbd68c5e466 in KApplication::notify (this=0x7fff6e762e70, receiver=0x8ee420, event=0x7fff6e762b70) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fbd6943fafc in QCoreApplication::notifyInternal (this=0x7fff6e762e70, receiver=0x8ee420, event=0x7fff6e762b70) at kernel/qcoreapplication.cpp:787
#25 0x00007fbd6946cd62 in sendEvent (event=0x7fff6e762b70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x6e5900) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fbd6946a514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fbd63b22a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fbd63b23258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fbd63b23429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fbd6946aed6 in QEventDispatcherGlib::processEvents (this=0x6c06f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fbd67b2207e in QGuiEventDispatcherGlib::~QGuiEventDispatcherGlib (this=0x0, __in_chrg=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:195
#33 0x00000000008ede30 in ?? ()
#34 0x00007fff6e762dc0 in ?? ()
#35 0x00007fbd6943ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007fbd6943eef7 in QEventLoop::exec (this=0x7fff6e762e00, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007fbd69443789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#38 0x000000000041bd67 in main (argc=5, argv=0x7fff6e7630e8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293118, bug 293113, bug 293102, bug 293080, bug 293071.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-02 15:58:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***