Bug 289950

Summary: KMail crashes on message select
Product: [Applications] kmail2 Reporter: graham
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: graham
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description graham 2011-12-27 19:37:24 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

Selecting a single message in KMail2.  Message in question had external HTML references, and I have Konqueror configured to use kwebkitpart instead of khtml.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f47cb229840 (LWP 24976))]

Thread 5 (Thread 0x7f47bd823700 (LWP 24982)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000304f3973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x304fd90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x000000304f3974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003029207d90 in start_thread (arg=0x7f47bd823700) at pthread_create.c:309
#4  0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f47bcf02700 (LWP 24983)):
#0  0x0000003028ae6a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x000000302b244f88 in g_main_context_poll (n_fds=1, fds=0x7f47b80013e0, priority=<optimized out>, timeout=9235, context=0x7f47b80009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f47b80009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000302b24544c in g_main_context_iteration (context=0x7f47b80009a0, may_block=1) at gmain.c:3136
#4  0x00000030337a79c6 in QEventDispatcherGlib::processEvents (this=0x7f47b80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003033777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003033778017 in QEventLoop::exec (this=0x7f47bcf01d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003033678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000303367bb1b in QThreadPrivate::start (arg=0x266b4d0) at thread/qthread_unix.cpp:298
#9  0x0000003029207d90 in start_thread (arg=0x7f47bcf02700) at pthread_create.c:309
#10 0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f476ffff700 (LWP 25544)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000303367bf8f in wait (time=30000, this=0x7f4770005ea0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f4770005e48, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000303366f55f in QThreadPoolThread::run (this=0x7f4770006120) at concurrent/qthreadpool.cpp:141
#4  0x000000303367bb1b in QThreadPrivate::start (arg=0x7f4770006120) at thread/qthread_unix.cpp:298
#5  0x0000003029207d90 in start_thread (arg=0x7f476ffff700) at pthread_create.c:309
#6  0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f4775093700 (LWP 25545)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000303367bf8f in wait (time=30000, this=0x7f4770005ea0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f4770005e48, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000303366f55f in QThreadPoolThread::run (this=0x7f477000a120) at concurrent/qthreadpool.cpp:141
#4  0x000000303367bb1b in QThreadPrivate::start (arg=0x7f477000a120) at thread/qthread_unix.cpp:298
#5  0x0000003029207d90 in start_thread (arg=0x7f4775093700) at pthread_create.c:309
#6  0x0000003028aef3dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f47cb229840 (LWP 24976)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x394e810, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000030358f4e99 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x394e810, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003033791b26 in QObject::event (this=0x394e810, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x00000030365c96f4 in notify_helper (e=0x7f476000f050, receiver=0x394e810, this=0x1675ef0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1675ef0, receiver=0x394e810, e=0x7f476000f050) at kernel/qapplication.cpp:4490
#11 0x00000030365ce573 in QApplication::notify (this=0x7fff85c22240, receiver=0x394e810, e=0x7f476000f050) at kernel/qapplication.cpp:4379
#12 0x0000003039650766 in KApplication::notify (this=0x7fff85c22240, receiver=0x394e810, event=0x7f476000f050) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x0000003033778c8c in QCoreApplication::notifyInternal (this=0x7fff85c22240, receiver=0x394e810, event=0x7f476000f050) at kernel/qcoreapplication.cpp:876
#14 0x000000303377c71a in sendEvent (event=0x7f476000f050, receiver=0x394e810) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x162d2d0) at kernel/qcoreapplication.cpp:1500
#16 0x00000030337a7533 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1684db0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000302b244a7d in g_main_dispatch (context=0x1684cc0) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1684cc0) at gmain.c:2995
#20 0x000000302b245278 in g_main_context_iterate (context=0x1684cc0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000302b24544c in g_main_context_iteration (context=0x1684cc0, may_block=1) at gmain.c:3136
#22 0x00000030337a795f in QEventDispatcherGlib::processEvents (this=0x162eaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000303666c2ce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003033777dc2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003033778017 in QEventLoop::exec (this=0x7fff85c22110, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000303377ca15 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 289946, bug 289179, bug 289030, bug 287990, bug 287970.

Reported using DrKonqi
Comment 1 graham 2011-12-27 19:40:51 UTC
Created attachment 67165 [details]
New crash information added by DrKonqi

kmail (4.7.4) on KDE Platform 4.7.4 (4.7.4) using Qt 4.8.0

- What I was doing when the application crashed:

Same action as before; was selecting a single message with external HTML references.

However... I had just reconfigured konqueror to use "khtml" instead of the webkitpart, and had then restarted KMail afterwards.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x39686b0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000030358f4e99 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x39686b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003033791b26 in QObject::event (this=0x39686b0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x00000030365c96f4 in notify_helper (e=0x7f65b8005600, receiver=0x39686b0, this=0x1e9de10) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1e9de10, receiver=0x39686b0, e=0x7f65b8005600) at kernel/qapplication.cpp:4490
Comment 2 Christophe Giboudeaux 2012-01-02 19:43:25 UTC

*** This bug has been marked as a duplicate of bug 286307 ***