Bug 274166

Summary: Marble consistently crashes shortly after running, possibly only after zooming.
Product: marble Reporter: JosephC <cjcolella>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description JosephC 2011-05-26 06:01:03 UTC
Application: marble (1.0.2 (Stable Release))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.39-999-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
Every time I run the program and zoom into the Earth, shortly thereafter Marble will crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0bd12d0780 (LWP 20931))]

Thread 6 (Thread 0x7f0bbca00700 (LWP 20932)):
#0  0x00007f0bc8db4489 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0bc8db500a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bc8db5639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bcf481446 in QEventDispatcherGlib::processEvents (this=0x12086c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f0bcf455882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0bcf455abc in QEventLoop::exec (this=0x7f0bbc9ffdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0bcf36c924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f0bcf437c2f in QInotifyFileSystemWatcherEngine::run (this=0x1207f60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0bcf36f175 in QThreadPrivate::start (arg=0x1207f60) at thread/qthread_unix.cpp:320
#9  0x00007f0bc9678d8c in start_thread (arg=0x7f0bbca00700) at pthread_create.c:304
#10 0x00007f0bcdd7a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f0bb468d700 (LWP 20933)):
#0  0x00007f0bcdd6cf03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0bc8db5104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bc8db5639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bcf481446 in QEventDispatcherGlib::processEvents (this=0x14ea7e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f0bcf455882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0bcf455abc in QEventLoop::exec (this=0x7f0bb468cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0bcf36c924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f0bcf437c2f in QInotifyFileSystemWatcherEngine::run (this=0x13d6520) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0bcf36f175 in QThreadPrivate::start (arg=0x13d6520) at thread/qthread_unix.cpp:320
#9  0x00007f0bc9678d8c in start_thread (arg=0x7f0bb468d700) at pthread_create.c:304
#10 0x00007f0bcdd7a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f0bb3e8c700 (LWP 20934)):
#0  0x00007f0bcf36f25f in QThreadData::current () at thread/qthread_unix.cpp:227
#1  0x00007f0bcf480e99 in postEventSourcePrepare (s=0x15146f0, timeout=0x7f0bb3e8bc4c) at kernel/qeventdispatcher_glib.cpp:254
#2  0x00007f0bc8db40a2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bc8db4f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0bc8db5639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0bcf481446 in QEventDispatcherGlib::processEvents (this=0x15148a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f0bcf455882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0bcf455abc in QEventLoop::exec (this=0x7f0bb3e8bdd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f0bcf36c924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007f0bcf437c2f in QInotifyFileSystemWatcherEngine::run (this=0x14defe0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f0bcf36f175 in QThreadPrivate::start (arg=0x14defe0) at thread/qthread_unix.cpp:320
#11 0x00007f0bc9678d8c in start_thread (arg=0x7f0bb3e8c700) at pthread_create.c:304
#12 0x00007f0bcdd7a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f0babfff700 (LWP 20941)):
#0  0x00007f0bcdd6cf03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0bc8db5104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0bc8db5639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0bcf481446 in QEventDispatcherGlib::processEvents (this=0xe5be50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f0bcf455882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0bcf455abc in QEventLoop::exec (this=0x7f0babffedb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0bcf36c924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f0bd0919a98 in Marble::FileStorageWatcher::run (this=0x1208a40) at ../../../../marble/src/lib/FileStorageWatcher.cpp:401
#8  0x00007f0bcf36f175 in QThreadPrivate::start (arg=0x1208a40) at thread/qthread_unix.cpp:320
#9  0x00007f0bc9678d8c in start_thread (arg=0x7f0babfff700) at pthread_create.c:304
#10 0x00007f0bcdd7a04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0bb1687700 (LWP 20953)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f0bb1686ae0 in ?? ()
#2  0x00007fff81b196ef in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f0bd12d0780 (LWP 20931)):
[KCrash Handler]
#6  0x00007f0bd090e9cd in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x157cc50, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7f0bbc10a010) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#7  0x00007f0bd091058d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x157cc50, viewParams=0x1225348, texColorizer=0x157f9f0) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#8  0x00007f0bd0910782 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x157cc50, painter=0x7fff81a2f6e0, viewParams=0x1225348, dirtyRect=..., texColorizer=<value optimized out>) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007f0bd088cd98 in Marble::MarbleMapPrivate::paintGround (this=0x1225330, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#10 0x00007f0bd087fb30 in Marble::MarbleWidget::paintEvent (this=0x11b9650, evt=0x7fff81a2ff90) at ../../../../marble/src/lib/MarbleWidget.cpp:805
#11 0x00007f0bce868c6a in QWidget::event (this=0x11b9650, event=0x7fff81a2ff90) at kernel/qwidget.cpp:8405
#12 0x00007f0bce8179e4 in QApplicationPrivate::notify_helper (this=0xe6e560, receiver=0x11b9650, e=0x7fff81a2ff90) at kernel/qapplication.cpp:4462
#13 0x00007f0bce81c3aa in QApplication::notify (this=<value optimized out>, receiver=0x11b9650, e=0x7fff81a2ff90) at kernel/qapplication.cpp:4341
#14 0x00007f0bcfe97866 in KApplication::notify (this=0x7fff81a32780, receiver=0x11b9650, event=0x7fff81a2ff90) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x00007f0bcf45649c in QCoreApplication::notifyInternal (this=0x7fff81a32780, receiver=0x11b9650, event=0x7fff81a2ff90) at kernel/qcoreapplication.cpp:731
#16 0x00007f0bce865abd in sendSpontaneousEvent (this=0x11b98a0, pdev=0x11c6518, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xf37700) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#17 QWidgetPrivate::drawWidget (this=0x11b98a0, pdev=0x11c6518, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xf37700) at kernel/qwidget.cpp:5492
#18 0x00007f0bcea2a29f in QWidgetBackingStore::sync (this=0xf37700) at painting/qbackingstore.cpp:1325
#19 0x00007f0bce85bf50 in QWidgetPrivate::syncBackingStore (this=0xfe2ba0) at kernel/qwidget.cpp:1842
#20 0x00007f0bce869184 in QWidget::event (this=0xfd7d60, event=0x7fff81a30ec0) at kernel/qwidget.cpp:8552
#21 0x00007f0bcec3251b in QMainWindow::event (this=0xfd7d60, event=0x7fff81a30ec0) at widgets/qmainwindow.cpp:1480
#22 0x00007f0bcff92d8e in KXmlGuiWindow::event (this=0xfd7d60, ev=0x7fff81a30ec0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#23 0x00007f0bce8179e4 in QApplicationPrivate::notify_helper (this=0xe6e560, receiver=0xfd7d60, e=0x7fff81a30ec0) at kernel/qapplication.cpp:4462
#24 0x00007f0bce81c3aa in QApplication::notify (this=<value optimized out>, receiver=0xfd7d60, e=0x7fff81a30ec0) at kernel/qapplication.cpp:4341
#25 0x00007f0bcfe97866 in KApplication::notify (this=0x7fff81a32780, receiver=0xfd7d60, event=0x7fff81a30ec0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f0bcf45649c in QCoreApplication::notifyInternal (this=0x7fff81a32780, receiver=0xfd7d60, event=0x7fff81a30ec0) at kernel/qcoreapplication.cpp:731
#27 0x00007f0bcea26f28 in sendEvent (this=0xf37700, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 sendUpdateRequest (this=0xf37700, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#29 QWidgetBackingStore::markDirty (this=0xf37700, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#30 0x00007f0bce85b7e8 in QWidget::repaint (this=0x11b9650, rect=...) at kernel/qwidget.cpp:10322
#31 0x00007f0bce85b8a3 in QWidget::repaint (this=<value optimized out>) at kernel/qwidget.cpp:10278
#32 0x00007f0bd0881b38 in repaint (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at ../../../../marble/src/lib/MarbleWidget.cpp:272
#33 Marble::MarbleWidget::flyTo (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at ../../../../marble/src/lib/MarbleWidget.cpp:1316
#34 0x00007f0bd08a4b32 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=<value optimized out>, marbleWidget=0x11b9650, pos=<value optimized out>, newDistance=575.76286887758329) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:271
#35 0x00007f0bd08a60f6 in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x12ac9a0, o=<value optimized out>, e=0x7fff81a31950) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:738
#36 0x00007f0bcf456627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x11b9650, event=0x7fff81a31950) at kernel/qcoreapplication.cpp:846
#37 0x00007f0bce8179b1 in QApplicationPrivate::notify_helper (this=0xe6e560, receiver=0x11b9650, e=0x7fff81a31950) at kernel/qapplication.cpp:4458
#38 0x00007f0bce81c7bb in QApplication::notify (this=<value optimized out>, receiver=0x11b9650, e=0x7fff81a31950) at kernel/qapplication.cpp:4078
#39 0x00007f0bcfe97866 in KApplication::notify (this=0x7fff81a32780, receiver=0x11b9650, event=0x7fff81a31950) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007f0bcf45649c in QCoreApplication::notifyInternal (this=0x7fff81a32780, receiver=0x11b9650, event=0x7fff81a31950) at kernel/qcoreapplication.cpp:731
#41 0x00007f0bce884bd2 in sendSpontaneousEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QETWidget::translateWheelEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4594
#43 0x00007f0bce8982bd in QETWidget::translateMouseEvent (this=0xfd7d60, event=0x7fff81a32410) at kernel/qapplication_x11.cpp:4371
#44 0x00007f0bce89704a in QApplication::x11ProcessEvent (this=0x7fff81a32780, event=0x7fff81a32410) at kernel/qapplication_x11.cpp:3678
#45 0x00007f0bce8bf162 in x11EventSourceDispatch (s=0xe6caa0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x00007f0bc8db4bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f0bc8db53a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007f0bc8db5639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007f0bcf4813ef in QEventDispatcherGlib::processEvents (this=0xe1b2b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#50 0x00007f0bce8bedfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007f0bcf455882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x00007f0bcf455abc in QEventLoop::exec (this=0x7fff81a32710, flags=...) at kernel/qeventloop.cpp:201
#53 0x00007f0bcf459ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#54 0x0000000000420755 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:351

This bug may be a duplicate of or related to bug 265599.

Possible duplicates by query: bug 273747, bug 273273, bug 272219, bug 272083, bug 272082.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-05-26 19:37:18 UTC

*** This bug has been marked as a duplicate of bug 265599 ***