Bug 271064

Summary: Kwin crashes
Product: [Plasma] kwin Reporter: Alan Teixeira <alansteixeira>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: linux
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description Alan Teixeira 2011-04-16 00:34:41 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-default x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
kwin closed unexpectedly while I was using alt tab with more than 10 applications open

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fbf45bb17a0 (LWP 2229))]

Thread 2 (Thread 0x7fbf2a60a700 (LWP 2241)):
#0  0x00007fbf413fd38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fbf44281044 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fbf4459a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fbf44281079 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fbf445a8254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fbf413f8a3f in start_thread () from /lib64/libpthread.so.0
#4  0x00007fbf4541367d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbf45bb17a0 (LWP 2229)):
[KCrash Handler]
#6  0x00007fbf45788c1f in operator== (this=0xa53a90, selection=...) at /usr/include/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0xa53a90, selection=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:1900
#8  0x00007fbf2b3fdcad in KWin::BoxSwitchEffect::paintWindowsBox (this=0xa55b60, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007fbf2b44ea5c in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007fbf4578a41c in KWin::EffectsHandlerImpl::paintScreen (this=0x837b70, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#11 0x00007fbf4386ff7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#12 0x00007fbf4578a41c in KWin::EffectsHandlerImpl::paintScreen (this=0x837b70, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#13 0x00007fbf4386ff7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#14 0x00007fbf4578a41c in KWin::EffectsHandlerImpl::paintScreen (this=0x837b70, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007fbf4386ff7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#16 0x00007fbf4578a41c in KWin::EffectsHandlerImpl::paintScreen (this=0x837b70, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007fbf2b444b7f in KWin::ZoomEffect::paintScreen (this=0xa18560, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#18 0x00007fbf4578a41c in KWin::EffectsHandlerImpl::paintScreen (this=0x837b70, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007fbf4576dfa5 in KWin::Scene::paintScreen (this=0x7341a0, mask=0x7fff5331ce5c, region=0x7fff5331cf70) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#20 0x00007fbf457824e9 in KWin::SceneOpenGL::paint (this=0x7341a0, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#21 0x00007fbf4576a5aa in KWin::Workspace::performCompositing (this=0x7fbf240f4aa0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:442
#22 0x00007fbf41784799 in QObject::event (this=0x7fbf240f4aa0, e=<value optimized out>) at kernel/qobject.cpp:1175
#23 0x00007fbf4091fd14 in QApplicationPrivate::notify_helper (this=0x635c60, receiver=0x7fbf240f4aa0, e=0x7fff5331d790) at kernel/qapplication.cpp:4445
#24 0x00007fbf4092822a in QApplication::notify (this=<value optimized out>, receiver=0x7fbf240f4aa0, e=0x7fff5331d790) at kernel/qapplication.cpp:4324
#25 0x00007fbf44e8b9e6 in KApplication::notify (this=0x7fff5331dc70, receiver=0x7fbf240f4aa0, event=0x7fff5331d790) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#26 0x00007fbf41770bfc in QCoreApplication::notifyInternal (this=0x7fff5331dc70, receiver=0x7fbf240f4aa0, event=0x7fff5331d790) at kernel/qcoreapplication.cpp:732
#27 0x00007fbf4179e4d8 in sendEvent (this=0x636670) at kernel/qcoreapplication.h:215
#28 QTimerInfoList::activateTimers (this=0x636670) at kernel/qeventdispatcher_unix.cpp:618
#29 0x00007fbf4179ebe0 in QEventDispatcherUNIX::processEvents (this=0x612a60, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#30 0x00007fbf409c5bac in QEventDispatcherX11::processEvents (this=0x612a60, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#31 0x00007fbf41770052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fbf41770265 in QEventLoop::exec (this=0x7fff5331db60, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007fbf417746ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#34 0x00007fbf45708c8a in kdemain (argc=<value optimized out>, argv=0x7fff5331dcd0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#35 0x00007fbf4535ebfd in __libc_start_main () from /lib64/libc.so.6
#36 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 265163, bug 265068, bug 263064, bug 253079.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-16 01:00:55 UTC
/possibly/ fixed in 4.6.1 - try if you can

*** This bug has been marked as a duplicate of bug 253079 ***
Comment 2 Xandersoft 2011-04-23 21:47:58 UTC
Created attachment 59256 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

Kwin crashed on using alt + tab, and even times the "HUD" doesn´t work it hangs. No aktion on use alt + F1.

-- Backtrace (Reduced):
#6  0x00007f4fe7a44c1f in operator== (this=0x8d8900, selection=...) at /usr/include/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x8d8900, selection=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:1900
#8  0x00007f4fcb7eccad in KWin::BoxSwitchEffect::paintWindowsBox (this=0x896bd0, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f4fcb83da5c in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f4fe7a4641c in KWin::EffectsHandlerImpl::paintScreen (this=0x785900, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169