Bug 270646

Summary: crash on fast zoom
Product: marble Reporter: Felix Möller <felix>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Felix Möller 2011-04-11 08:58:20 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38.2-9.fc15.i686.PAE i686
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:
turned my mouse wheel really fast on the marble map

I am not sure if this is a duplicate. Please check this. I have marked the most probable one as a candidate.

-- Backtrace:
Application: Marble – Virtueller Globus (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7756780 (LWP 6049))]

Thread 7 (Thread 0xb7462b70 (LWP 6052)):
#0  0x4c4b8b34 in __pthread_mutex_unlock_usercnt (mutex=0x9e8fd9c, decr=1) at pthread_mutex_unlock.c:53
#1  0x4c5a4e53 in g_main_context_poll (n_fds=1, fds=0x4c4b8be0, priority=<optimized out>, timeout=<optimized out>, context=0x9e8fd98) at gmain.c:3403
#2  g_main_context_iterate (context=0x9e8fd98, block=1281047728, dispatch=1, self=0x9e8fe28) at gmain.c:3086
#3  0x4c5a5697 in g_main_loop_run (loop=0x9e8fd88) at gmain.c:3299
#4  0x00203172 in gdbus_shared_thread_func (data=0x0) at gdbusprivate.c:276
#5  0x4c5cc755 in g_thread_create_proxy (data=0x9e8fe28) at gthread.c:1897
#6  0x4c4b5c5e in start_thread (arg=0xb7462b70) at pthread_create.c:305
#7  0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 6 (Thread 0xb4bf4b70 (LWP 6053)):
#0  0x4c503fa0 in clock_gettime (clock_id=1, tp=0xb4bf3fb8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x4d3b6016 in do_gettime (frac=0xb4bf3fb0, sec=0xb4bf3fa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x4d4896f7 in QTimerInfoList::updateCurrentTime (this=0xb4201a3c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x4d489a5b in QTimerInfoList::timerWait (this=0xb4201a3c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x4d4882e3 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb4bf40bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x4d48837d in timerSourcePrepare (source=0xb4201a08, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x4c5a3d9c in g_main_context_prepare (context=0xb42004e8, priority=0xb4bf4118) at gmain.c:2761
#8  0x4c5a4c18 in g_main_context_iterate (context=0xb42004e8, block=1, dispatch=1, self=0xb4200d78) at gmain.c:3071
#9  0x4c5a52af in g_main_context_iteration (context=0xb42004e8, may_block=1) at gmain.c:3154
#10 0x4d488de7 in QEventDispatcherGlib::processEvents (this=0xb4200468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x4d459a3e in QEventLoop::processEvents (this=0xb4bf4240, flags=...) at kernel/qeventloop.cpp:149
#12 0x4d459c91 in QEventLoop::exec (this=0xb4bf4240, flags=...) at kernel/qeventloop.cpp:201
#13 0x4d35b3cc in QThread::exec (this=0xa037df8) at thread/qthread.cpp:492
#14 0x4d439f6e in QInotifyFileSystemWatcherEngine::run (this=0xa037df8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x4d35e304 in QThreadPrivate::start (arg=0xa037df8) at thread/qthread_unix.cpp:320
#16 0x4c4b5c5e in start_thread (arg=0xb4bf4b70) at pthread_create.c:305
#17 0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 5 (Thread 0xb415ab70 (LWP 6054)):
#0  0x4c5a3bfb in g_main_context_prepare (context=0xb38004e8, priority=0xb415a118) at gmain.c:2689
#1  0x4c5a4c18 in g_main_context_iterate (context=0xb38004e8, block=1, dispatch=1, self=0xb3800d78) at gmain.c:3071
#2  0x4c5a52af in g_main_context_iteration (context=0xb38004e8, may_block=1) at gmain.c:3154
#3  0x4d488de7 in QEventDispatcherGlib::processEvents (this=0xb3800468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x4d459a3e in QEventLoop::processEvents (this=0xb415a240, flags=...) at kernel/qeventloop.cpp:149
#5  0x4d459c91 in QEventLoop::exec (this=0xb415a240, flags=...) at kernel/qeventloop.cpp:201
#6  0x4d35b3cc in QThread::exec (this=0x9fe0310) at thread/qthread.cpp:492
#7  0x4d439f6e in QInotifyFileSystemWatcherEngine::run (this=0x9fe0310) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x4d35e304 in QThreadPrivate::start (arg=0x9fe0310) at thread/qthread_unix.cpp:320
#9  0x4c4b5c5e in start_thread (arg=0xb415ab70) at pthread_create.c:305
#10 0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xb37ffb70 (LWP 6055)):
#0  0x4c4b8b17 in __pthread_mutex_unlock_usercnt (mutex=0xa1982bc, decr=1) at pthread_mutex_unlock.c:39
#1  0x4c5a52d4 in g_main_context_iteration (context=<optimized out>, may_block=1) at gmain.c:3155
#2  0x4d488de7 in QEventDispatcherGlib::processEvents (this=0xa1a0748, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x4d459a3e in QEventLoop::processEvents (this=0xb37ff240, flags=...) at kernel/qeventloop.cpp:149
#4  0x4d459c91 in QEventLoop::exec (this=0xb37ff240, flags=...) at kernel/qeventloop.cpp:201
#5  0x4d35b3cc in QThread::exec (this=0xa194978) at thread/qthread.cpp:492
#6  0x4d439f6e in QInotifyFileSystemWatcherEngine::run (this=0xa194978) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x4d35e304 in QThreadPrivate::start (arg=0xa194978) at thread/qthread_unix.cpp:320
#8  0x4c4b5c5e in start_thread (arg=0xb37ffb70) at pthread_create.c:305
#9  0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xb07f9b70 (LWP 6062)):
#0  0x4c503fa0 in clock_gettime (clock_id=1, tp=0xb07f8f98) at ../sysdeps/unix/clock_gettime.c:116
#1  0x4d3b6016 in do_gettime (frac=0xb07f8f90, sec=0xb07f8f88) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x4d4896f7 in QTimerInfoList::updateCurrentTime (this=0xb4204e54) at kernel/qeventdispatcher_unix.cpp:339
#4  0x4d489a5b in QTimerInfoList::timerWait (this=0xb4204e54, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x4d4882e3 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb07f909c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x4d48837d in timerSourcePrepare (source=0xb4204e20, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x4c5a3d9c in g_main_context_prepare (context=0xb4203620, priority=0xb07f90f8) at gmain.c:2761
#8  0x4c5a4c18 in g_main_context_iterate (context=0xb4203620, block=1, dispatch=1, self=0xb42036b0) at gmain.c:3071
#9  0x4c5a52af in g_main_context_iteration (context=0xb4203620, may_block=1) at gmain.c:3154
#10 0x4d488de7 in QEventDispatcherGlib::processEvents (this=0xb4201b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x4d459a3e in QEventLoop::processEvents (this=0xb07f9220, flags=...) at kernel/qeventloop.cpp:149
#12 0x4d459c91 in QEventLoop::exec (this=0xb07f9220, flags=...) at kernel/qeventloop.cpp:201
#13 0x4d35b3cc in QThread::exec (this=0xa04c880) at thread/qthread.cpp:492
#14 0x413151d0 in Marble::FileStorageWatcher::run (this=0xa04c880) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/FileStorageWatcher.cpp:401
#15 0x4d35e304 in QThreadPrivate::start (arg=0xa04c880) at thread/qthread_unix.cpp:320
#16 0x4c4b5c5e in start_thread (arg=0xb07f9b70) at pthread_create.c:305
#17 0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb2ffeb70 (LWP 6072)):
#0  0x00c11424 in __kernel_vsyscall ()
#1  0x4c4b9b04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_timedwait.S:238
#2  0x4d35e79f in wait (time=30000, this=0xa716ba8) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0xa69900c, mutex=0xa699008, time=30000) at thread/qwaitcondition_unix.cpp:160
#4  0x4d352264 in QThreadPoolThread::run (this=0xa69bea0) at concurrent/qthreadpool.cpp:140
#5  0x4d35e304 in QThreadPrivate::start (arg=0xa69bea0) at thread/qthread_unix.cpp:320
#6  0x4c4b5c5e in start_thread (arg=0xb2ffeb70) at pthread_create.c:305
#7  0x4c3f9b4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7756780 (LWP 6049)):
[KCrash Handler]
#7  0x41308ed9 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0xa1f2400, lon=0.13521499639060247, lat=1.2403515776798406, scanLine=0xb1718008) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0x4130aa25 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xa1f2400, viewParams=0xa01c86c, texColorizer=0xa20b7f8) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0x4130ac4e in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xa1f2400, painter=0xbffecae8, viewParams=0xa01c86c, dirtyRect=..., texColorizer=0xa20b7f8) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0x4130072a in Marble::TextureLayer::paintGlobe (this=0xa01c88c, painter=0xbffecae8, viewParams=0xa01c86c, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/TextureLayer.cpp:161
#11 0x4127c1b7 in Marble::MarbleMapPrivate::paintGround (this=0xa01c860, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleMap.cpp:188
#12 0x4126c34b in Marble::MarbleWidget::paintEvent (this=0xa03afd0, evt=0xbffed074) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:805
#13 0x4dc1856b in QWidget::event (this=0xa03afd0, event=0xbffed074) at kernel/qwidget.cpp:8405
#14 0x4dbbd784 in notify_helper (e=0xbffed074, receiver=0xa03afd0, this=0x9e5bc38) at kernel/qapplication.cpp:4462
#15 QApplicationPrivate::notify_helper (this=0x9e5bc38, receiver=0xa03afd0, e=0xbffed074) at kernel/qapplication.cpp:4434
#16 0x4dbc2c7a in QApplication::notify (this=0x9e5bc38, receiver=0xa03afd0, e=0xbffed074) at kernel/qapplication.cpp:4427
#17 0x4e7309e2 in KApplication::notify (this=0xbffeec84, receiver=0xa03afd0, event=0xbffed074) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#18 0x4d45a6fe in QCoreApplication::notifyInternal (this=0xbffeec84, receiver=0xa03afd0, event=0xbffed074) at kernel/qcoreapplication.cpp:731
#19 0x4dc1537b in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:218
#20 QWidgetPrivate::drawWidget (this=0x9fe2ef8, pdev=0x9fe8d44, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0xa1b09c8) at kernel/qwidget.cpp:5492
#21 0x4ddfad0f in QWidgetBackingStore::sync (this=0xa1b09c8) at painting/qbackingstore.cpp:1325
#22 0x4dc0a5eb in QWidgetPrivate::syncBackingStore (this=0x9fe9948) at kernel/qwidget.cpp:1842
#23 0x4dc18f03 in QWidget::event (this=0x9fcf3d0, event=0xbffedb54) at kernel/qwidget.cpp:8552
#24 0x4e036474 in QMainWindow::event (this=0x9fcf3d0, event=0xbffedb54) at widgets/qmainwindow.cpp:1480
#25 0x4e8148a4 in KMainWindow::event (this=0x9fcf3d0, ev=0xbffedb54) at /usr/src/debug/kdelibs-4.6.1/kdeui/widgets/kmainwindow.cpp:1100
#26 0x4e857433 in KXmlGuiWindow::event (this=0x9fcf3d0, ev=0xbffedb54) at /usr/src/debug/kdelibs-4.6.1/kdeui/xmlgui/kxmlguiwindow.cpp:126
#27 0x4dbbd784 in notify_helper (e=0xbffedb54, receiver=0x9fcf3d0, this=0x9e5bc38) at kernel/qapplication.cpp:4462
#28 QApplicationPrivate::notify_helper (this=0x9e5bc38, receiver=0x9fcf3d0, e=0xbffedb54) at kernel/qapplication.cpp:4434
#29 0x4dbc2c7a in QApplication::notify (this=0x9e5bc38, receiver=0x9fcf3d0, e=0xbffedb54) at kernel/qapplication.cpp:4427
#30 0x4e7309e2 in KApplication::notify (this=0xbffeec84, receiver=0x9fcf3d0, event=0xbffedb54) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#31 0x4d45a6fe in QCoreApplication::notifyInternal (this=0xbffeec84, receiver=0x9fcf3d0, event=0xbffedb54) at kernel/qcoreapplication.cpp:731
#32 0x4ddf6fac in sendEvent (event=0xbffedb50, receiver=0x9fcf3d0) at ../../src/corelib/kernel/qcoreapplication.h:215
#33 sendUpdateRequest (updateImmediately=true, widget=0x9fcf3d0) at painting/qbackingstore.cpp:507
#34 QWidgetBackingStore::markDirty (this=0xa1b09c8, rect=..., widget=0xa03afd0, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#35 0x4dc09bf2 in repaint (rect=..., this=0xa03afd0) at kernel/qwidget.cpp:10322
#36 QWidget::repaint (this=0xa03afd0, rect=...) at kernel/qwidget.cpp:10306
#37 0x4dc09d02 in QWidget::repaint (this=0xa03afd0) at kernel/qwidget.cpp:10278
#38 0x4126ae4f in Marble::MarbleWidgetPrivate::repaint (this=0xa0f9020) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:272
#39 0x41296d08 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0xa0f7b80, marbleWidget=0xa03afd0, pos=..., newDistance=471.39476723048256) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:271
#40 0x41298c6b in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0xa0ea530, o=0xa03afd0, e=0xbffee354) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:738
#41 0x4d45a8a6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9e5bc38, receiver=0xa03afd0, event=0xbffee354) at kernel/qcoreapplication.cpp:846
#42 0x4dbbd753 in notify_helper (e=0xbffee354, receiver=0xa03afd0, this=0x9e5bc38) at kernel/qapplication.cpp:4458
#43 QApplicationPrivate::notify_helper (this=0x9e5bc38, receiver=0xa03afd0, e=0xbffee354) at kernel/qapplication.cpp:4434
#44 0x4dbc33de in QApplication::notify (this=0xa03afd0, receiver=0xa03afd0, e=0xbffee354) at kernel/qapplication.cpp:4078
#45 0x4e7309e2 in KApplication::notify (this=0xbffeec84, receiver=0xa03afd0, event=0xbffee354) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#46 0x4d45a6fe in QCoreApplication::notifyInternal (this=0xbffeec84, receiver=0xa03afd0, event=0xbffee354) at kernel/qcoreapplication.cpp:731
#47 0x4dc37d60 in sendSpontaneousEvent (event=0xbffee354, receiver=0xa03afd0) at ../../src/corelib/kernel/qcoreapplication.h:218
#48 QETWidget::translateWheelEvent (this=0x9fcf3d0, global_x=419, global_y=334, delta=600, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4499
#49 0x4dc48c1e in QETWidget::translateMouseEvent (this=0x9fcf3d0, event=0xbffee8dc) at kernel/qapplication_x11.cpp:4276
#50 0x4dc4795d in QApplication::x11ProcessEvent (this=0xbffeec84, event=0xbffee8dc) at kernel/qapplication_x11.cpp:3587
#51 0x4dc72315 in x11EventSourceDispatch (s=0x9e5c618, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#52 0x4c5a47ff in g_main_dispatch (context=0x9e43e70) at gmain.c:2440
#53 g_main_context_dispatch (context=0x9e43e70) at gmain.c:3013
#54 0x4c5a4f70 in g_main_context_iterate (context=0x9e43e70, block=1281047728, dispatch=1, self=0x9e41cb0) at gmain.c:3091
#55 0x4c5a52af in g_main_context_iteration (context=0x9e43e70, may_block=1) at gmain.c:3154
#56 0x4d488d88 in QEventDispatcherGlib::processEvents (this=0x9e41bb8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#57 0x4dc71fab in QGuiEventDispatcherGlib::processEvents (this=0x9e41bb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#58 0x4d459a3e in QEventLoop::processEvents (this=0xbffeebe4, flags=...) at kernel/qeventloop.cpp:149
#59 0x4d459c91 in QEventLoop::exec (this=0xbffeebe4, flags=...) at kernel/qeventloop.cpp:201
#60 0x4d45e3fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#61 0x4dbbb565 in QApplication::exec () at kernel/qapplication.cpp:3736
#62 0x0805c770 in main (argc=) at /usr/src/debug/kdeedu-4.6.1/marble/src/kdemain.cpp:351

This bug may be a duplicate of or related to bug 265599.

Possible duplicates by query: bug 270499, bug 269181, bug 269003, bug 266690, bug 266406.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-04-11 19:45:39 UTC
As a workaround, enlarge the Marble window (e.g. maximize it) or disable the status bar.

*** This bug has been marked as a duplicate of bug 265599 ***