Bug 266690 - Crashed whilst zooming
Summary: Crashed whilst zooming
Status: RESOLVED DUPLICATE of bug 266406
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-19 22:04 UTC by Alex Burll
Modified: 2011-02-19 22:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Burll 2011-02-19 22:04:24 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-gentoo i686
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Zooming into Great Britain, program suddenly crashed. Also provided is a backtrace prior to the crash. I hope this is useful in debugging.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb38a6ab0 (LWP 10932))]

Thread 5 (Thread 0xb1562b70 (LWP 10933)):
#0  0xb3fd6266 in clock_gettime (clock_id=1, tp=0xb1561fa0) at ../sysdeps/unix/clock_gettime.c:100
#1  0xb67d2348 in qt_gettime() () from /usr/lib/qt4/libQtCore.so.4
#2  0xb68ad6e5 in QTimerInfoList::updateCurrentTime() () from /usr/lib/qt4/libQtCore.so.4
#3  0xb68ad72a in QTimerInfoList::timerWait(timeval&) () from /usr/lib/qt4/libQtCore.so.4
#4  0xb68ab558 in timerSourcePrepareHelper(GTimerSource*, int*) () from /usr/lib/qt4/libQtCore.so.4
#5  0xb68ab5ed in timerSourcePrepare(_GSource*, int*) () from /usr/lib/qt4/libQtCore.so.4
#6  0xb3f1fd61 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb3f20179 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#8  0xb3f20768 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb68ab26f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#10 0xb687a569 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#11 0xb687a9fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#12 0xb676e26c in QThread::exec() () from /usr/lib/qt4/libQtCore.so.4
#13 0xb685843a in QInotifyFileSystemWatcherEngine::run() () from /usr/lib/qt4/libQtCore.so.4
#14 0xb6771615 in QThreadPrivate::start(void*) () from /usr/lib/qt4/libQtCore.so.4
#15 0xb56a4ec2 in start_thread (arg=0xb1562b70) at pthread_create.c:301
#16 0xb598f1ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xb0ae1b70 (LWP 10934)):
#0  0xb56a75eb in __pthread_mutex_lock (mutex=0x8332f04) at pthread_mutex_lock.c:61
#1  0xb599d386 in pthread_mutex_lock (mutex=0x8332f04) at forward.c:182
#2  0xb3f1fa7b in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0xb3f2035e in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#4  0xb3f20768 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb68ab26f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#6  0xb687a569 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#7  0xb687a9fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#8  0xb676e26c in QThread::exec() () from /usr/lib/qt4/libQtCore.so.4
#9  0xb685843a in QInotifyFileSystemWatcherEngine::run() () from /usr/lib/qt4/libQtCore.so.4
#10 0xb6771615 in QThreadPrivate::start(void*) () from /usr/lib/qt4/libQtCore.so.4
#11 0xb56a4ec2 in start_thread (arg=0xb0ae1b70) at pthread_create.c:301
#12 0xb598f1ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xb02e0b70 (LWP 10935)):
#0  0xb3f1fa78 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#1  0xb3f2035e in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0xb3f20768 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0xb68ab26f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#4  0xb687a569 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#5  0xb687a9fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#6  0xb676e26c in QThread::exec() () from /usr/lib/qt4/libQtCore.so.4
#7  0xb685843a in QInotifyFileSystemWatcherEngine::run() () from /usr/lib/qt4/libQtCore.so.4
#8  0xb6771615 in QThreadPrivate::start(void*) () from /usr/lib/qt4/libQtCore.so.4
#9  0xb56a4ec2 in start_thread (arg=0xb02e0b70) at pthread_create.c:301
#10 0xb598f1ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xad2dab70 (LWP 10942)):
#0  0xb3f48b20 in g_thread_self () from /usr/lib/libglib-2.0.so.0
#1  0xb3f20753 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#2  0xb68ab26f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#3  0xb687a569 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#4  0xb687a9fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#5  0xb676e26c in QThread::exec() () from /usr/lib/qt4/libQtCore.so.4
#6  0xb7594da8 in Marble::FileStorageWatcher::run (this=0x82513b8) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#7  0xb6771615 in QThreadPrivate::start(void*) () from /usr/lib/qt4/libQtCore.so.4
#8  0xb56a4ec2 in start_thread (arg=0xad2dab70) at pthread_create.c:301
#9  0xb598f1ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb38a6ab0 (LWP 10932)):
[KCrash Handler]
#7  0xb7585477 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0xae1024d8, lon=-0.10367684017657172, lat=0.97623472252059762, scanLine=0xae266008) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0xb758717d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xae1024d8, viewParams=0x82585bc, texColorizer=0x83a91d8) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0xb7587416 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xae1024d8, painter=0xbfe001fc, viewParams=0x82585bc, dirtyRect=..., texColorizer=0x83a91d8) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0xb7579e86 in Marble::TextureLayer::paintGlobe (this=0x82585dc, painter=0xbfe001fc, viewParams=0x82585bc, dirtyRect=...) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/TextureLayer.cpp:161
#11 0xb74dd190 in Marble::MarbleMapPrivate::paintGround (this=0x82585b0, painter=..., dirtyRect=...) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleMap.cpp:188
#12 0xb74ce237 in Marble::MarbleWidget::paintEvent (this=0x823f6b0, evt=0xbfe007f4) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#13 0xb5de5693 in QWidget::event(QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#14 0xb5d861cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#15 0xb5d8bd69 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#16 0xb6eda44a in KApplication::notify (this=0xbfe024e4, receiver=0x823f6b0, event=0xbfe007f4) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#17 0xb687bb92 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/qt4/libQtCore.so.4
#18 0xb5dec9e4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/qt4/libQtGui.so.4
#19 0xb5fea5ac in QWidgetBackingStore::sync() () from /usr/lib/qt4/libQtGui.so.4
#20 0xb5ddea2b in QWidgetPrivate::syncBackingStore() () from /usr/lib/qt4/libQtGui.so.4
#21 0xb5de5bf8 in QWidget::event(QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#22 0xb6218a2f in QMainWindow::event(QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#23 0xb6feb7b5 in KMainWindow::event (this=0x817ee20, ev=0xbfe011f4) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/widgets/kmainwindow.cpp:1100
#24 0xb703b23c in KXmlGuiWindow::event (this=0x817ee20, ev=0xbfe011f4) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#25 0xb5d861cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#26 0xb5d8bd69 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#27 0xb6eda44a in KApplication::notify (this=0xbfe024e4, receiver=0x817ee20, event=0xbfe011f4) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#28 0xb687bb92 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/qt4/libQtCore.so.4
#29 0xb5fe7658 in sendUpdateRequest(QWidget*, bool) () from /usr/lib/qt4/libQtGui.so.4
#30 0xb5feadb9 in QWidgetBackingStore::markDirty(QRect const&, QWidget*, bool, bool) () from /usr/lib/qt4/libQtGui.so.4
#31 0xb5de14fc in QWidget::repaint(QRect const&) () from /usr/lib/qt4/libQtGui.so.4
#32 0xb5de160e in QWidget::repaint() () from /usr/lib/qt4/libQtGui.so.4
#33 0xb74d1b03 in repaint (this=0x823f6b0, newLookAt=..., mode=Marble::Linear) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#34 Marble::MarbleWidget::flyTo (this=0x823f6b0, newLookAt=..., mode=Marble::Linear) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidget.cpp:1316
#35 0xb74fc8c9 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0x828c268, marbleWidget=0x823f6b0, pos=..., newDistance=575.76286887758329) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidgetInputHandler.cpp:271
#36 0xb74ff94b in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x8258ca8, o=0x823f6b0, e=0xbfe01b14) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/lib/MarbleWidgetInputHandler.cpp:738
#37 0xb687b2d0 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/qt4/libQtCore.so.4
#38 0xb5d861a9 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#39 0xb5d8c34b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/qt4/libQtGui.so.4
#40 0xb6eda44a in KApplication::notify (this=0xbfe024e4, receiver=0x823f6b0, event=0xbfe01b14) at /var/tmp/portage/kde-base/kdelibs-4.6.0-r1/work/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#41 0xb687bb92 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/qt4/libQtCore.so.4
#42 0xb5e0bed8 in QETWidget::translateWheelEvent(int, int, int, QFlags<Qt::MouseButton>, QFlags<Qt::KeyboardModifier>, Qt::Orientation) () from /usr/lib/qt4/libQtGui.so.4
#43 0xb5e1d52c in QETWidget::translateMouseEvent(_XEvent const*) () from /usr/lib/qt4/libQtGui.so.4
#44 0xb5e1c35c in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/qt4/libQtGui.so.4
#45 0xb5e4a664 in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib/qt4/libQtGui.so.4
#46 0xb3f1c694 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#47 0xb3f20578 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#48 0xb3f20768 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#49 0xb68ab235 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#50 0xb5e49ed5 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtGui.so.4
#51 0xb687a569 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#52 0xb687a9fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/qt4/libQtCore.so.4
#53 0xb687f24f in QCoreApplication::exec() () from /usr/lib/qt4/libQtCore.so.4
#54 0xb5d84ef7 in QApplication::exec() () from /usr/lib/qt4/libQtGui.so.4
#55 0x080670cc in main (argc=1, argv=0xbfe02af4) at /var/tmp/portage/kde-base/marble-4.6.0/work/marble-4.6.0/marble/src/kdemain.cpp:351

Possible duplicates by query: bug 266406, bug 259258.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-02-19 22:29:56 UTC

*** This bug has been marked as a duplicate of bug 266406 ***