Bug 270499

Summary: marble was crashed
Product: marble Reporter: Alexander Serdts <serdtsev>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Alexander Serdts 2011-04-09 14:39:19 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.11-83.fc14.i686.PAE i686
Distribution: "RFRemix release 14.1 (Laughlin)"

-- Information about the crash:
I turned the wheel on a mouse scroll to zoom the globe.
after this program was crashed

-- Backtrace:
Application: Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7889780 (LWP 3374))]

Thread 5 (Thread 0xb5747b70 (LWP 3375)):
#0  0x06734e56 in clock_gettime (clock_id=1, tp=0xb5746f70) at ../sysdeps/unix/clock_gettime.c:100
#1  0x077d74b9 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x078a6083 in updateCurrentTime (this=0xb4e01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xb4e01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x078a4882 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb574705c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x078a491d in timerSourcePrepare (source=0xb4e01a00, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01c226b6 in g_main_context_prepare (context=<value optimized out>, priority=0xb57470cc) at gmain.c:2469
#8  0x01c2355b in g_main_context_iterate (context=0xb4e004e8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2760
#9  0x01c23c35 in g_main_context_iteration (context=0xb4e004e8, may_block=1) at gmain.c:2843
#10 0x078a50e7 in QEventDispatcherGlib::processEvents (this=0xb4e00468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0787654a in QEventLoop::processEvents (this=0xb5747220, flags=...) at kernel/qeventloop.cpp:149
#12 0x078767fa in QEventLoop::exec (this=0xb5747220, flags=...) at kernel/qeventloop.cpp:201
#13 0x0777d36b in QThread::exec (this=0x83672c8) at thread/qthread.cpp:490
#14 0x07857bcc in QInotifyFileSystemWatcherEngine::run (this=0x83672c8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0777fe6a in QThreadPrivate::start (arg=0x83672c8) at thread/qthread_unix.cpp:285
#16 0x004afe99 in start_thread (arg=0xb5747b70) at pthread_create.c:301
#17 0x05f04d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xb4d29b70 (LWP 3376)):
#0  0x00d9c424 in __kernel_vsyscall ()
#1  0x05ef9c36 in __poll (fds=0xb4401ae0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x01c33dac in g_poll (fds=0xb4401ae0, nfds=1, timeout=-1) at gpoll.c:132
#3  0x01c238b7 in g_main_context_poll (context=0xb44004e8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3093
#4  g_main_context_iterate (context=0xb44004e8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
#5  0x01c23c35 in g_main_context_iteration (context=0xb44004e8, may_block=1) at gmain.c:2843
#6  0x078a50e7 in QEventDispatcherGlib::processEvents (this=0xb4400468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x0787654a in QEventLoop::processEvents (this=0xb4d29220, flags=...) at kernel/qeventloop.cpp:149
#8  0x078767fa in QEventLoop::exec (this=0xb4d29220, flags=...) at kernel/qeventloop.cpp:201
#9  0x0777d36b in QThread::exec (this=0x8327108) at thread/qthread.cpp:490
#10 0x07857bcc in QInotifyFileSystemWatcherEngine::run (this=0x8327108) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0777fe6a in QThreadPrivate::start (arg=0x8327108) at thread/qthread_unix.cpp:285
#12 0x004afe99 in start_thread (arg=0xb4d29b70) at pthread_create.c:301
#13 0x05f04d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xb43ffb70 (LWP 3377)):
#0  0x06734e56 in clock_gettime (clock_id=1, tp=0xb43fef70) at ../sysdeps/unix/clock_gettime.c:100
#1  0x077d74b9 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x078a6083 in updateCurrentTime (this=0xb3a01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xb3a01a34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x078a4882 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb43ff05c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x078a491d in timerSourcePrepare (source=0xb3a01a00, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01c226b6 in g_main_context_prepare (context=<value optimized out>, priority=0xb43ff0cc) at gmain.c:2469
#8  0x01c2355b in g_main_context_iterate (context=0xb3a004e8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2760
#9  0x01c23c35 in g_main_context_iteration (context=0xb3a004e8, may_block=1) at gmain.c:2843
#10 0x078a50e7 in QEventDispatcherGlib::processEvents (this=0xb3a00468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0787654a in QEventLoop::processEvents (this=0xb43ff220, flags=...) at kernel/qeventloop.cpp:149
#12 0x078767fa in QEventLoop::exec (this=0xb43ff220, flags=...) at kernel/qeventloop.cpp:201
#13 0x0777d36b in QThread::exec (this=0x845b360) at thread/qthread.cpp:490
#14 0x07857bcc in QInotifyFileSystemWatcherEngine::run (this=0x845b360) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0777fe6a in QThreadPrivate::start (arg=0x845b360) at thread/qthread_unix.cpp:285
#16 0x004afe99 in start_thread (arg=0xb43ffb70) at pthread_create.c:301
#17 0x05f04d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb29fdb70 (LWP 3384)):
#0  0x004b36ff in __pthread_mutex_unlock_usercnt (mutex=0xb3a035bc) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0xb3a035bc) at pthread_mutex_unlock.c:290
#2  0x01c22dfc in g_main_context_check (context=0xb3a035b8, max_priority=2147483647, fds=0xb3a03900, n_fds=1) at gmain.c:2656
#3  0x01c23742 in g_main_context_iterate (context=0xb3a035b8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2777
#4  0x01c23c35 in g_main_context_iteration (context=0xb3a035b8, may_block=1) at gmain.c:2843
#5  0x078a50e7 in QEventDispatcherGlib::processEvents (this=0xb3a01b50, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x0787654a in QEventLoop::processEvents (this=0xb29fd210, flags=...) at kernel/qeventloop.cpp:149
#7  0x078767fa in QEventLoop::exec (this=0xb29fd210, flags=...) at kernel/qeventloop.cpp:201
#8  0x0777d36b in QThread::exec (this=0x836bef8) at thread/qthread.cpp:490
#9  0x002bc9b0 in Marble::FileStorageWatcher::run (this=0x836bef8) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/FileStorageWatcher.cpp:401
#10 0x0777fe6a in QThreadPrivate::start (arg=0x836bef8) at thread/qthread_unix.cpp:285
#11 0x004afe99 in start_thread (arg=0xb29fdb70) at pthread_create.c:301
#12 0x05f04d2e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7889780 (LWP 3374)):
[KCrash Handler]
#7  0x002afb16 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x849abe8, lon=0.51582941955288664, lat=1.030360639365242, scanLine=0xb3b29008) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0x002b17b0 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x849abe8, viewParams=0x8372144, texColorizer=0x84ba630) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0x002b19d4 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x849abe8, painter=0xbfc250bc, viewParams=0x8372144, dirtyRect=..., texColorizer=0x84ba630) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0x002a6cc7 in Marble::TextureLayer::paintGlobe (this=0x8372164, painter=0xbfc250bc, viewParams=0x8372144, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/TextureLayer.cpp:161
#11 0x0021a979 in Marble::MarbleMapPrivate::paintGround (this=0x8372138, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleMap.cpp:188
#12 0x0020a387 in Marble::MarbleWidget::paintEvent (this=0x8361948, evt=0xbfc25684) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:805
#13 0x021a08af in QWidget::event (this=0x8361948, event=0xbfc25684) at kernel/qwidget.cpp:8346
#14 0x0214726c in QApplicationPrivate::notify_helper (this=0x81cb3e0, receiver=0x8361948, e=0xbfc25684) at kernel/qapplication.cpp:4445
#15 0x0214bf7f in QApplication::notify (this=0xbfc273a4, receiver=0x8361948, e=0xbfc25684) at kernel/qapplication.cpp:4410
#16 0x0116192b in KApplication::notify (this=0xbfc273a4, receiver=0x8361948, event=0xbfc25684) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#17 0x078773b3 in QCoreApplication::notifyInternal (this=0xbfc273a4, receiver=0x8361948, event=0xbfc25684) at kernel/qcoreapplication.cpp:732
#18 0x0219d4bd in sendSpontaneousEvent (this=0x8366868, pdev=0x84771ec, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8475930) at ../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x8366868, pdev=0x84771ec, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8475930) at kernel/qwidget.cpp:5433
#20 0x0237ca62 in QWidgetBackingStore::sync (this=0x8475930) at painting/qbackingstore.cpp:1325
#21 0x02192c13 in QWidgetPrivate::syncBackingStore (this=0x82b01f0) at kernel/qwidget.cpp:1816
#22 0x021a0f0d in QWidget::event (this=0x8244bb8, event=0xbfc261b8) at kernel/qwidget.cpp:8493
#23 0x025bb557 in QMainWindow::event (this=0x8244bb8, event=0xbfc261b8) at widgets/qmainwindow.cpp:1478
#24 0x01242204 in KMainWindow::event (this=0x8244bb8, ev=0xbfc261b8) at /usr/src/debug/kdelibs-4.6.1/kdeui/widgets/kmainwindow.cpp:1100
#25 0x01284020 in KXmlGuiWindow::event (this=0x8244bb8, ev=0xbfc261b8) at /usr/src/debug/kdelibs-4.6.1/kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0x0214726c in QApplicationPrivate::notify_helper (this=0x81cb3e0, receiver=0x8244bb8, e=0xbfc261b8) at kernel/qapplication.cpp:4445
#27 0x0214bf7f in QApplication::notify (this=0xbfc273a4, receiver=0x8244bb8, e=0xbfc261b8) at kernel/qapplication.cpp:4410
#28 0x0116192b in KApplication::notify (this=0xbfc273a4, receiver=0x8244bb8, event=0xbfc261b8) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#29 0x078773b3 in QCoreApplication::notifyInternal (this=0xbfc273a4, receiver=0x8244bb8, event=0xbfc261b8) at kernel/qcoreapplication.cpp:732
#30 0x023790e4 in sendEvent (this=0x8475930, rect=..., widget=0x8361948, updateImmediately=true, invalidateBuffer=false) at ../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (this=0x8475930, rect=..., widget=0x8361948, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#32 QWidgetBackingStore::markDirty (this=0x8475930, rect=..., widget=0x8361948, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0x02192386 in QWidget::repaint (this=0x8361948, rect=...) at kernel/qwidget.cpp:10250
#34 0x0219249d in QWidget::repaint (this=0x8361948) at kernel/qwidget.cpp:10206
#35 0x0020cd74 in repaint (this=0x8361948, newLookAt=..., mode=Marble::Linear) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::flyTo (this=0x8361948, newLookAt=..., mode=Marble::Linear) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidget.cpp:1316
#37 0x0023695c in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0x83bb878, marbleWidget=0x8361948, pos=..., newDistance=575.76286887758329) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:271
#38 0x002381ca in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x839aa80, o=0x8361948, e=0xbfc26a14) at /usr/src/debug/kdeedu-4.6.1/marble/src/lib/MarbleWidgetInputHandler.cpp:738
#39 0x0787756a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x81cb3e0, receiver=0x8361948, event=0xbfc26a14) at kernel/qcoreapplication.cpp:847
#40 0x02147241 in QApplicationPrivate::notify_helper (this=0x81cb3e0, receiver=0x8361948, e=0xbfc26a14) at kernel/qapplication.cpp:4441
#41 0x0214c51f in QApplication::notify (this=0xbfc273a4, receiver=0x8361948, e=0xbfc26a14) at kernel/qapplication.cpp:4061
#42 0x0116192b in KApplication::notify (this=0xbfc273a4, receiver=0x8361948, event=0xbfc26a14) at /usr/src/debug/kdelibs-4.6.1/kdeui/kernel/kapplication.cpp:311
#43 0x078773b3 in QCoreApplication::notifyInternal (this=0xbfc273a4, receiver=0x8361948, event=0xbfc26a14) at kernel/qcoreapplication.cpp:732
#44 0x021be685 in sendSpontaneousEvent (this=0x8244bb8, global_x=401, global_y=252, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../src/corelib/kernel/qcoreapplication.h:218
#45 QETWidget::translateWheelEvent (this=0x8244bb8, global_x=401, global_y=252, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4476
#46 0x021d1038 in QETWidget::translateMouseEvent (this=0x8244bb8, event=0xbfc2702c) at kernel/qapplication_x11.cpp:4253
#47 0x021cf957 in QApplication::x11ProcessEvent (this=0xbfc273a4, event=0xbfc2702c) at kernel/qapplication_x11.cpp:3564
#48 0x021fa790 in x11EventSourceDispatch (s=0x81c9d48, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#49 0x01c23192 in g_main_dispatch (context=0x81b1af8) at gmain.c:2149
#50 g_main_context_dispatch (context=0x81b1af8) at gmain.c:2702
#51 0x01c23978 in g_main_context_iterate (context=0x81b1af8, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#52 0x01c23c35 in g_main_context_iteration (context=0x81b1af8, may_block=1) at gmain.c:2843
#53 0x078a50ad in QEventDispatcherGlib::processEvents (this=0x81af9d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0x021fa406 in QGuiEventDispatcherGlib::processEvents (this=0x81af9d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#55 0x0787654a in QEventLoop::processEvents (this=0xbfc27304, flags=...) at kernel/qeventloop.cpp:149
#56 0x078767fa in QEventLoop::exec (this=0xbfc27304, flags=...) at kernel/qeventloop.cpp:201
#57 0x0787b3a7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0x02145078 in QApplication::exec () at kernel/qapplication.cpp:3719
#59 0x0806425d in main (argc=) at /usr/src/debug/kdeedu-4.6.1/marble/src/kdemain.cpp:351

This bug may be a duplicate of or related to bug 265599.

Possible duplicates by query: bug 269181, bug 269003, bug 266690, bug 266406, bug 259258.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-04-09 22:18:41 UTC

*** This bug has been marked as a duplicate of bug 265599 ***