Bug 249820

Summary: KSnapshot should save its temporary file in lossless (PNG) compression when opened with another application
Product: ksnapshot Reporter: Kai Uwe Broulik <KaiUweBroulik2>
Component: generalAssignee: Richard Moore <rich>
Status: RESOLVED UNMAINTAINED    
Severity: wishlist CC: cfeck, friiduh, kde, sankeytms, simon.eu, zorael
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Kai Uwe Broulik 2010-09-02 03:41:00 UTC
Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

(Using ksnapshot 0.81 which is not listed)

I like pressing Print Screen key, choose “Grab window under mouse cursor”, click “Take screenshot” and open that file in kolourpaint for further editing and then save it and send it to a friend for example.
But if I use Open With Kolourpaint, kolourpaint is given a jpeg file which shows strong compression artefacts (not that strong, that is not the point of this bugreport, but you can see it‘s a jpeg file). Save that temp file kolourpaint is given as PNG (or let me choose).

Reproducible: Always
Comment 1 Christoph Feck 2010-09-02 14:31:09 UTC
Does this also happen with a clean configuration (remove .kde/share/config/ksnapshotrc)?

From looking at the source, it explicitly requests PNG format.
Comment 2 Kai Uwe Broulik 2010-09-02 14:49:07 UTC
Now I deleted ksnapshotrc and now kolourpaint is given an empty PNG file „Screenshot1.png” (don‘t know the exact term, have german version).

Ok, it seems that if I just press PrintScreen and then directly use “open with kolourpaint” there‘s an empty file given to colourpaint (well kolourpaint states it is displaying file ~/Documents/Screenshot1.png) but this file does not exist and I am given with the same look as if I had opened a new istance of kolourpaint, so a white picture with the size of the last edited one.

If I now press “New screenshot” and then choose “Open with kolourpaint” it is indeed given a PNG file. Seems I have got another bug besides the JPEG-one.
Comment 3 Christoph Feck 2010-09-02 15:43:57 UTC
It remembers the last used file name to increase the number on it (Screenshot1.png -> Screenshot2.png etc.)

You probably saved it once in JPEG format, as such all subsequent files are in JPEG format.

As for the initial snapshot file not being passed to applications correctly, that is bug 240051.

*** This bug has been marked as a duplicate of bug 240051 ***
Comment 4 Kai Uwe Broulik 2010-09-02 15:48:18 UTC
But it shouldn‘t care about the last used file format and for the instant open option it should use PNG no matter what was used the last time, because if I open it directly I am likely to edit it and there I don‘t want compression artefacts.
Comment 5 Christoph Feck 2010-09-02 15:58:33 UTC
You are right. Changed request accordingly.
Comment 6 Kai Uwe Broulik 2010-09-02 16:04:56 UTC
Great :) Thanks.
Comment 7 Christoph Feck 2010-09-23 14:02:53 UTC
*** Bug 252122 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2010-12-21 15:36:12 UTC
*** Bug 260859 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2011-11-24 12:55:53 UTC
*** Bug 287402 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2012-10-21 03:53:59 UTC
*** Bug 308736 has been marked as a duplicate of this bug. ***
Comment 11 Andrew Crouthamel 2018-09-04 04:17:59 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years and I will be closing this bug. Spectacle is the replacement for ksnapshot now. Please test again and file a new bug for Spectacle if you still have issues. Thank you!