Bug 252122 - KSnapshot saves temporary file with lossy format
Summary: KSnapshot saves temporary file with lossy format
Status: RESOLVED DUPLICATE of bug 249820
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 3.0
Platform: Archlinux Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-23 12:46 UTC by Fri13
Modified: 2010-09-23 14:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fri13 2010-09-23 12:46:16 UTC
Version:           3.0 (using KDE 4.5.1) 
OS:                Linux


KSnapshot allows easily user to choose different fileformats how to save the file. And the file naming follows the last used + growing number with smart way. 
One of the greatest feature in KSnapshot is possibility to drag and drop the snapshot to other application or open it with other application.

But when user first saves screenshot with lossy format and later (example on next day) takes a new screenshot but does not save it but clicks "Opens With" button and then selects example a GIMP or Krita, the ksnapshot saves the file to $tmp in last used format. 

This causes that when user earlier saved snapshot with jpeg format, the new "open with" function saves the new snapshot as well with jpeg format and it is about 75% compression rate. So the snapshot what is opened in image manipulation program, does not even be lossless from the screen.

Fix for this is to save the file always in temporary place as BMP or TIFF (PNG would be best, but it is slow to save, especially with fullscreen screenshots).



Reproducible: Always

Steps to Reproduce:
Open a KSnapshot with printscreen button, save a snapshot as filename.png
Close the KSnapshot.

Open a KSnapshot with printscreen button, save a snapshot as filename.jpeg
Close the KSnapshot.

Open a KSnapshot again same way, click "open with" and select the image manipulation program.

Compare the snapshot file from first saved PNG file and the "open with" way opened temporary stored file what use JPEG compression.

Actual Results:  
Temporary stored snapshot follows the last used file format what was JPEG and the image is compressed 75% quality (very bad looking with linearts or fonts).

Expected Results:  
The temporary file what KSnapshot saves and offers to "open with" launched application program would be lossless format. Like PNG, BMP or TIFF.
Comment 1 Christoph Feck 2010-09-23 14:02:53 UTC

*** This bug has been marked as a duplicate of bug 249820 ***