Bug 308736 - "Send To..." should send the correct image type
Summary: "Send To..." should send the correct image type
Status: RESOLVED DUPLICATE of bug 249820
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-21 03:36 UTC by sankeytms
Modified: 2012-10-21 03:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sankeytms 2012-10-21 03:36:28 UTC
The "Send To..." option does not provide an image type selection (e.g. jpeg, png, gif, etc.). It just uses the type that the user specified in the "Save As..." dialog for the previous screenshot. The user's last choice for a previous screenshot is irrelevant to what the user wants for the current screenshot.

Proposed solutions:
1. default to png or some other lossless format.
2. provide another drop-down menu somewhere for selecting the type.

Reproducible: Always

Steps to Reproduce:
1. take screenshot
2. save as jpeg
3. take screenshot again
4. "Send To..." gimp

Actual Results:  
ksnapshot provides a jpeg to gimp

Expected Results:  
ksnapshot provides a png to gimp, or asks the user for an image type to send to gimp.
Comment 1 Christoph Feck 2012-10-21 03:53:59 UTC

*** This bug has been marked as a duplicate of bug 249820 ***