Bug 287402 - When sending to application, new screenshots are sent in lossy formats if last screenshot was saved lossy
Summary: When sending to application, new screenshots are sent in lossy formats if las...
Status: RESOLVED DUPLICATE of bug 249820
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 0.8.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-23 20:59 UTC by JR
Modified: 2011-11-24 12:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Image saved with intent to be png turned lossy as it was sent to GIMP as jpeg (25.80 KB, image/png)
2011-11-23 20:59 UTC, JR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JR 2011-11-23 20:59:55 UTC
Created attachment 65998 [details]
Image saved with intent to be png turned lossy as it was sent to GIMP as jpeg

Version:           0.8.2 (using KDE 4.7.3) 
OS:                Linux

Kubuntu 11.10, KDE 4.7.3 from Kubuntu PPAs. ksnapshot package version is 4:4.7.3-0ubuntu0.1~ppa1.

Let's say I save a screenshot containing a photography picture as a jpeg, as I want to keep the file size low for web use. I directly save it to the disk as pretty-landscape.jpeg.

Next I want to take a screenshot of a piece of text which would benefit from the lossness qualities of png. Saving it as jpeg would make the text fuzzy upon closer examination. However, this time I want to send it to GIMP for further editing, before I finalize it as cool-quote.png.

What gets sent to GIMP is a temporary lossy jpeg named pretty-landscape1.jpeg, and information is lost.

Reproducible: Always

Steps to Reproduce:
1. Use KSnapshot to take a screenshot with the intent of saving it as a jpeg
2. Save it as a jpeg!
3. Use KSnapshot to take a screenshot with the intent of sending it to an external application before finally saving it as a png

Actual Results:  
4. Temporary file sent to application is in a lossy format (jpeg) and all hopes of keeping the information lossless are foiled

Expected Results:  
4. Temporary file sent to application is sent in a lossless format

I frankly don't know how to solve this in a neat way if you don't want to *assume* every application in the Send To menu accepts pngs. A dropdown menu in which to check jpeg/png? KSnapshot support a frightful lot of filetypes.

In the case of image editors, a workaround is to *also* use the Copy function and then paste it onto the image, replacing the contents with the lossy clipboard contents.
Comment 1 JR 2011-11-23 21:01:45 UTC
>replacing the contents with the lossy
>clipboard contents.

Replace lossy with lossless there, apologies.
Comment 2 Christoph Feck 2011-11-24 12:55:53 UTC

*** This bug has been marked as a duplicate of bug 249820 ***