Bug 245249

Summary: crash while starting the application
Product: kdelibs Reporter: Paul <paulwillems>
Component: knotifyAssignee: Olivier Goffart <ogoffart>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 4.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Paul 2010-07-20 20:32:36 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Just starting the application results in a crash of the application

 -- Backtrace:
Application: KNotify (knotify4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76eb710 (LWP 3302))]

Thread 2 (Thread 0xb09a3b70 (LWP 3306)):
#0  0x00abc422 in __kernel_vsyscall ()
#1  0x083ccb86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x02732502 in ?? () from /usr/lib/libpulse.so.0
#3  0x0271ea59 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x02720a13 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x02720ae4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x027322a3 in ?? () from /usr/lib/libpulse.so.0
#7  0x03d7ae02 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0x00a2f96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#9  0x083daa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76eb710 (LWP 3302)):
[KCrash Handler]
#6  0x01c10e5c in ?? () from /usr/lib/libasound.so.2
#7  0x01bcde9e in snd_pcm_close () from /usr/lib/libasound.so.2
#8  0x06901662 in gst_alsasink_close (asink=0x9f304a0) at gstalsasink.c:804
#9  0x0262f512 in gst_audioringbuffer_close_device (buf=0x9c973e0) at gstaudiosink.c:365
#10 0x0261f6f0 in gst_ring_buffer_close_device (buf=0x9c973e0) at gstringbuffer.c:714
#11 0x02629e42 in gst_base_audio_sink_change_state (element=0x9f304a0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbaseaudiosink.c:1879
#12 0x05feb435 in gst_element_change_state (element=0x9f304a0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#13 0x05fee928 in gst_element_set_state_func (element=0x9f304a0, state=GST_STATE_NULL) at gstelement.c:2504
#14 0x05fea7f0 in gst_element_set_state (element=0x9f304a0, state=GST_STATE_NULL) at gstelement.c:2405
#15 0x05fda827 in gst_bin_element_set_state (element=0x9f281a0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2118
#16 gst_bin_change_state_func (element=0x9f281a0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2417
#17 0x05feb435 in gst_element_change_state (element=0x9f281a0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#18 0x05fee928 in gst_element_set_state_func (element=0x9f281a0, state=GST_STATE_NULL) at gstelement.c:2504
#19 0x05fea7f0 in gst_element_set_state (element=0x9f281a0, state=GST_STATE_NULL) at gstelement.c:2405
#20 0x05fda827 in gst_bin_element_set_state (element=0x9f2d178, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2118
#21 gst_bin_change_state_func (element=0x9f2d178, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2417
#22 0x03fe811e in gst_switch_sink_change_state (element=0x9f2d178, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstswitchsink.c:255
#23 0x03fe4f56 in gst_gconf_audio_sink_change_state (element=0x9f2d178, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstgconfaudiosink.c:298
#24 0x05feb435 in gst_element_change_state (element=0x9f2d178, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2548
#25 0x05fee928 in gst_element_set_state_func (element=0x9f2d178, state=GST_STATE_NULL) at gstelement.c:2504
#26 0x05fea7f0 in gst_element_set_state (element=0x9f2d178, state=GST_STATE_NULL) at gstelement.c:2405
#27 0x03041e1c in Phonon::Gstreamer::AudioOutput::setOutputDevice (this=0x9f38388, newDevice=...) at ../../gstreamer/audiooutput.cpp:217
#28 0x004e1621 in callSetOutputDevice (this=0x9db67e8) at ../3rdparty/phonon/phonon/audiooutput.cpp:67
#29 Phonon::AudioOutputPrivate::setupBackendObject (this=0x9db67e8) at ../3rdparty/phonon/phonon/audiooutput.cpp:281
#30 0x004e1d22 in Phonon::AudioOutputPrivate::createBackendObject (this=0x9db67e8) at ../3rdparty/phonon/phonon/audiooutput.cpp:124
#31 0x004de284 in Phonon::AudioOutputPrivate::init (this=0x9db67e8, c=Phonon::NotificationCategory) at ../3rdparty/phonon/phonon/audiooutput.cpp:106
#32 0x004de929 in AudioOutput (this=0x9d977b0, category=Phonon::NotificationCategory, parent=0x0) at ../3rdparty/phonon/phonon/audiooutput.cpp:76
#33 0x080535b4 in Player (this=0x9d8ba34) at ../../knotify/notifybysound.cpp:59
#34 PlayerPool::getPlayer (this=0x9d8ba34) at ../../knotify/notifybysound.cpp:99
#35 0x08053b01 in NotifyBySound::notify (this=0x9d8e458, eventId=2, config=0x9c6e278) at ../../knotify/notifybysound.cpp:243
#36 0x0804f475 in KNotify::emitEvent (this=0xbfeb2b74, e=0x9c6e270) at ../../knotify/knotify.cpp:179
#37 0x0804f70b in KNotify::event (this=0xbfeb2b74, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=79705811) at ../../knotify/knotify.cpp:128
#38 0x0804fa05 in KNotifyAdaptor::event (this=0x9d8ccd0, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=<value optimized out>)
    at ../../knotify/knotify.cpp:236
#39 0x080505ad in KNotifyAdaptor::qt_metacall (this=0x9d8ccd0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfeb215c) at ./knotify.moc:227
#40 0x0053cb34 in QDBusConnectionPrivate::deliverCall (this=0x9bc8c68, object=0x9d8ccd0, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:904
#41 0x0053de45 in QDBusConnectionPrivate::activateCall (this=0x9bc8c68, object=0x9d8ccd0, flags=273, msg=...) at qdbusintegrator.cpp:816
#42 0x0053e880 in QDBusConnectionPrivate::activateObject (this=0x9bc8c68, node=..., msg=..., pathStartPos=7) at qdbusintegrator.cpp:1364
#43 0x0053eb1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9c82980) at qdbusintegrator.cpp:1477
#44 0x0070e3fe in QObject::event (this=0xbfeb2b74, e=0x9c82980) at kernel/qobject.cpp:1248
#45 0x00f4f4dc in QApplicationPrivate::notify_helper (this=0x9bd0d08, receiver=0xbfeb2b74, e=0x9c82980) at kernel/qapplication.cpp:4300
#46 0x00f5605e in QApplication::notify (this=0xbfeb2b88, receiver=0xbfeb2b74, e=0x9c82980) at kernel/qapplication.cpp:3704
#47 0x002eff2a in KApplication::notify (this=0xbfeb2b88, receiver=0xbfeb2b74, event=0x9c82980) at ../../kdeui/kernel/kapplication.cpp:302
#48 0x006fda3b in QCoreApplication::notifyInternal (this=0xbfeb2b88, receiver=0xbfeb2b74, event=0x9c82980) at kernel/qcoreapplication.cpp:704
#49 0x00700473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9bb4420) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9bb4420) at kernel/qcoreapplication.cpp:1345
#51 0x007005dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#52 0x00729adf in QCoreApplication::sendPostedEvents (s=0x9bd2f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#53 postEventSourceDispatch (s=0x9bd2f10) at kernel/qeventdispatcher_glib.cpp:276
#54 0x059005e5 in g_main_dispatch (context=0x9bd2e90) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#55 IA__g_main_context_dispatch (context=0x9bd2e90) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#56 0x059042d8 in g_main_context_iterate (context=0x9bd2e90, block=<value optimized out>, dispatch=1, self=0x9bd01f8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#57 0x059044b8 in IA__g_main_context_iteration (context=0x9bd2e90, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#58 0x007295d5 in QEventDispatcherGlib::processEvents (this=0x9bb4118, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#59 0x0100f135 in QGuiEventDispatcherGlib::processEvents (this=0x9bb4118, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#60 0x006fc059 in QEventLoop::processEvents (this=0xbfeb2ad4, flags=) at kernel/qeventloop.cpp:149
#61 0x006fc4aa in QEventLoop::exec (this=0xbfeb2ad4, flags=...) at kernel/qeventloop.cpp:201
#62 0x0070069f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#63 0x00f4f577 in QApplication::exec () at kernel/qapplication.cpp:3579
#64 0x0804e52f in main (argc=1, argv=0xbfeb2d04) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 244298, bug 244191, bug 241334, bug 240428, bug 240181.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-07-20 22:09:31 UTC

*** This bug has been marked as a duplicate of bug 232068 ***