Bug 95897 - wish: display or link enclosures
Summary: wish: display or link enclosures
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0-beta8
Platform: unspecified Linux
: NOR wishlist with 86 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 105511 132520 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-27 23:28 UTC by techieone
Modified: 2008-10-26 19:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description techieone 2004-12-27 23:28:30 UTC
Version:           1.0-beta8 (using KDE 3.3.1,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-3)
OS:                Linux (i686) release 2.6.9

what about a link to the <enclosure> in a item (if present)
or simply display the enclosure if it's an image (with the possibility to omit this behaviuor...)
Comment 1 Eckhart Wörner 2005-03-30 01:48:23 UTC
I second this, regarding the current growth of "podcasts" which rely on this technique.
Comment 2 Eckhart Wörner 2005-05-12 10:43:19 UTC
*** Bug 105511 has been marked as a duplicate of this bug. ***
Comment 3 Shift 2005-06-11 22:35:49 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Teemu Rytilahti 2005-06-12 00:10:57 UTC
Example feed here: http://www.jazzpodcasts.net/de/wp-rss2.php
Comment 5 Frank Osterfeld 2005-06-26 09:14:25 UTC
SVN commit 429033 by osterfeld:

hack enclosure support into the backend. This should do for 3.5, as we don't get the new parser written and tested until freeze.
CCBUG: 95897


 M  +26 -4     article.cpp  
 M  +4 -0      article.h  
 M  +3 -1      feedstorage.h  
 M  +47 -0     feedstoragedummyimpl.cpp  
 M  +3 -0      feedstoragedummyimpl.h  
 M  +2 -2      librss/Makefile.am  
 M  +12 -1     librss/article.cpp  
 M  +4 -0      librss/article.h  
 A             librss/enclosure.cpp   [License: GPL (v2+) (+Qt exception)]
 A             librss/enclosure.h   [License: GPL (v2+) (+Qt exception)]
 M  +1 -0      librss/librss.h  
 M  +57 -3     mk4storage/feedstoragemk4impl.cpp  
 M  +4 -0      mk4storage/feedstoragemk4impl.h  
Comment 6 Fabio Bacigalupo 2005-06-27 07:11:11 UTC
Hey Frank,

you offered me to add my wishlist. Here it comes.

- if the enclosure is a media file, add the link of the enclosure to the playlist of my favorite mediaplayer
- add a little <play> / <button> button next to the enclosure icon, maybe integrate noatun functionality
- if the enclosure is not a media file, associate it with the appropriate launcher programm, e.g. PDF with kpdf
- if I wish to download the enclosure, integrate download with kget
- keep a record which enclosures I have already downloaded (maybe have an icon with two or more status colours)
- it would be nice to mark a feed as podcast / feed with enclosure for filtering and searching
- have a special view where only enclosure with indication of their type, status, file size are shown with special actions for playlists, instant playing, downloading, e.g. if I click on a folder I can choose a not to view the list of articles but as a new tab the enclosures

Thank you!

Ciao
Fabio
--
Podcast.de - Das deutschsprachige Podcast-Portal
Comment 7 Georg Sauthoff 2006-02-18 14:18:39 UTC
Hi,

i would be happy if akregator could replace iPodder. I read a mail from the akregator ml, that it is not intended to replace a full featured podcast client.

But e.g. iPodder does not have that much features. They are useful and IMHO would nicely fit into a general rss-feed viewer, such as akregator.

A concrete wishlist:
- possibility to add enclosed links to a download queue (destination is some directory structure)
- Tab which displays queue content and downloaded files -> possibility to add some downloaded files to some playlist or open them etc. (perhaps via a context menu)
- display link enclosures -> possibility to open them in a new tab (e.g. pdf-files) or add them directly to another program

Regards
Georg Sauthoff
Comment 8 Frank Osterfeld 2006-08-21 00:48:43 UTC
*** Bug 132520 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Meyer 2008-02-16 23:27:49 UTC
Is this going to be supported with the next akgrekator (main) release and kde4?
Comment 10 Frank Osterfeld 2008-10-26 19:03:25 UTC
SVN commit 876185 by osterfeld:

display enclosures in the viewer
FEATURE:95897


 M  +4 -0      interfaces/article.h  
 M  +49 -0     src/article.cpp  
 M  +51 -14    src/articleformatter.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=876185