Bug 95524 - Wrong number of unread articles - may even become negative
Summary: Wrong number of unread articles - may even become negative
Status: RESOLVED UNMAINTAINED
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 120 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 98349 129443 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-20 17:22 UTC by Andreas Kilgus
Modified: 2018-09-04 18:36 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kilgus 2004-12-20 17:22:37 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    SuSE RPMs
OS:                Linux

Knode miscalculates the number of unread articles in newsgroups. E.g.: At the moment, I have -8 unread articles in gmane.linux.alsa.user - I'm quite sure that knode is wrong. ;-)

AFAICS this behaviour seems to have to do with filtered posters and ignored threads. The more I use (resp. knode influences display of postings with) these two capabilities in a newsgroup, the faster the number of unread articles drifts away from the facts.
Comment 1 Volker Krause 2004-12-20 17:36:55 UTC
I haven't seen negative numbers so far, but the unread count is definitely wrong when using filters.
Comment 2 Volker Krause 2005-02-01 18:56:12 UTC
*** Bug 98349 has been marked as a duplicate of this bug. ***
Comment 3 Roland Schäfer 2005-02-24 08:26:27 UTC
Same for me.

I hat a group without any unread message (or only in "Ignore" threads), selected "Mark all as read" and then the number of unread messages was -21

Screenshot:
http://roland.oktopus.org/Bug_Knode.jpg
Comment 4 Christoph Bartoschek 2005-04-07 10:15:10 UTC
Since KDE 3.4 there are no negative unread article counts here anymore. However the unread article count is still wrong here.

I have no filters, but I often ignore threads.

The procedure to get an accurate count here is:  1. Fetch new articles for all groups. 2. "Expire all groups" 3. Quit kontact (or knode if it is standalone) 4. Restart kontact

After the four steps the article count is correct, but as soon as I fetch new articles it is plain wrong. There is no read of articles involved or timer expiring. Right after fetching new articles the count is wrong. And it stays wrong until restart.

Most of the time it is too low. This led to the negative numbers before KDE 3.4. But somtimes the count is too high.

It should be possible to get an accurate unread article counter without restarting the application.
Comment 5 C. Dominik Bódi 2007-06-09 12:05:51 UTC
I have the same problem with kde 3.5.7 on debian unstable i386. The unread count doesn't seem to get updated for new messages.
Comment 6 Olivier Trichet 2009-05-11 21:30:54 UTC
*** Bug 129443 has been marked as a duplicate of this bug. ***
Comment 7 Skander Morgenthaler 2009-08-08 02:49:33 UTC
This bug is still present in 4.3.0
Comment 8 Andrew Crouthamel 2018-09-04 18:36:24 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug.