Bug 92400 - Wish: Add advanced jump features to playlist
Summary: Wish: Add advanced jump features to playlist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Playlist (show other bugs)
Version: 2.3-GIT
Platform: Debian testing Linux
: NOR wishlist with 150 votes (vote)
Target Milestone: 2.3.1
Assignee: Kevin Funk
URL:
Keywords:
: 137906 139029 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-30 18:47 UTC by André F. Oliveira
Modified: 2009-09-29 17:45 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
context browser lists 70 tracks instead of 15 (198.02 KB, image/png)
2005-01-11 22:39 UTC, Roland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André F. Oliveira 2004-10-30 18:47:19 UTC
Version:            (using KDE KDE 3.3.1)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Amarok should have a Jump/Enqueue command, like the ones we have in Winamp and XMMS (the 'J' shortcut). It would also be useful if the Jump/Enqueue dialog could be accessed from a global shortcut. The dialog should be easily navigated with the keyboard alone.
Comment 1 Seb Ruiz 2004-11-14 12:44:54 UTC
I didn't know what the jump function did in xmms, so i just tried it.

It seems to me that this function pops up a window with every playlist entry in a box and a search filter at the top which allows to cull entries.

Isn't this exactly what the amarok playlist is?!

I don't understand the use or point of this.
Comment 2 Max Howell 2004-11-14 18:00:08 UTC
The only advantage is if amaroK is minimized and the user doesn't want to open the playlist.

I propose instead we make it so WIN-P (show playlist) focuses on the filter when it shows the playlist. Then the user can do WIN-P, start typing and push enter to do a "jump".

A more consistent solution if you ask me.
Comment 3 Leo 2004-12-18 16:15:49 UTC
Focus to the search filter on opening the playlist window sounds like a good and appriopriate fix to me.

In addition I suggest that a j key shortcut shows the playlist window for the _former_ xmms users. Note the emphasis! *grin* This could be made a seperate wishlist item if someone actually asks for it though.
Comment 4 Roland 2005-01-11 22:39:20 UTC
Created attachment 9045 [details]
context browser lists 70 tracks instead of 15
Comment 5 Roland 2005-01-11 22:40:45 UTC
Comment on attachment 9045 [details]
context browser lists 70 tracks instead of 15

sorry wrong bug
Comment 6 Thorsten Mühlfelder 2005-02-20 20:03:55 UTC
I would prefer exactly the same behaviour as in XMMS. A popup window with a filter.
The problem in amarok is: if i have a playlist and random play and want to find a song with the "filter here" search bar, then choose the next song only from the filtered playlist.
Furthermore the filter option of amarok is damn slow on _large_ plalists.
Comment 7 bonne 2005-08-19 08:06:31 UTC
Comment #6 makes a very good point:
If you are searching for a song to enqueue (or generally searching for a song in a playlist) and the previous song ends (and you're in random mode - which is common for anyone with a large playlist) then the song you've searched for plays
Even worse: If  your search results turn up nothing then the previous song repeats itself!

A solution would be an option which said "choose random songs from entire playlist" or something to that effect. The other solution is to implement the "jump to file" dialogue from winamp. 
Comment 8 bonne 2005-08-19 08:06:41 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Voggeneder Simon 2005-10-24 02:32:05 UTC
I would appreciate such an Function since the amarok search-filter is inferior, it limits the playlist to the searched items, and i cannot navigate without using the Mouse.

Under WMP5, I just pressed STRG/ALT/J (global Hotkey) typed in the wished Track's name and pressed Enter - a hundred times as comfortable als amaroK does handle this :/ 

Enqueuing the track by pressing Shift/Enter was also great, but this are some of the things, which make Winamp easier to control than amarok.

Cons for amarok without "Jump to File":

Mouse-needed navigation
Damn slow in big playlists
needs to maximize itself
not available from everywhere (no global hotkey)

I think, if you add this feature to amaroK, it would instantly advance to the smartest Audio Player in addition to the player with the most functions, which it already is. XMMS/Winamp still has its head in front of amaroK concerning just this one fact.. is this really a that big problem to program it?

It would be great to see this feature already in 1.4 :)

greetings

Simon
Comment 10 Gábor Lehel 2006-02-14 16:09:33 UTC
With 1.4:

> Mouse-needed navigation
After you type the filter you can use the up/down arrow keys to navigate the remaining items. Also you can press Esc to clear the filter even if the focus isn't on it (but on the playlist).

> Damn slow in big playlists
This is true, though it should be faster now.

> needs to maximize itself
This remains, but why is it a problem?

> not available from everywhere (no global hotkey) 
You can press Win+P to activate amaroK, and if the focus was on the filter or playlist before, you can just start typing; otherwise you can press Ctrl+Tab to set the focus to the playlist first.
I've thought of automatically focusing the filter or playlist when you press Win+P, but others might want the focus to stay where they left it and find this annoying, so I don't know.
Comment 11 bonne 2006-02-14 23:20:23 UTC
Still needs work though:

> After you type the filter you can use the up/down arrow keys to navigate
This is true, however if the currently playing item normally lies in the middle of the items that are filtered, then when you press down the selection goes to the middle. (Which is inconsistent since the currently playing item shouldn't have an impact on what you want to play next)

> needs to maximize itself
This is a problem because you need to shift focus to the desktop that has amarok on it, which can be terribly annoying.

The issue of the playlist effectively becoming shorter when you're filtering is still there. Seriously some people just want to be able to select a song with a minimum of stuffing around and multiple keypresses, and without this silly shortened playlist problem.
Comment 12 Alexandre Oliveira 2006-11-26 19:29:13 UTC
*** Bug 137906 has been marked as a duplicate of this bug. ***
Comment 13 Alexandre Oliveira 2006-12-20 01:12:43 UTC
*** Bug 139029 has been marked as a duplicate of this bug. ***
Comment 14 Eric 2007-04-03 20:43:41 UTC
I really wanted a function "jump to file" in amarok...
It's really what's missing for me. All the rest is alsome, but nothaving a "jump to file" function makes me lose much time! cause I always have to clean the search to listen all my playlist after enquee a song.
Oh, ang a shortkut to enquee will be very, very welcome!
Thanks =D
Comment 15 Rado 2008-01-22 03:50:16 UTC
I agree, I love the winamp feature "Jump To File" its easy, clean, and fast (Ctrl+J -> Search ->Enter) as opposed (Win-P->Focus to Search Panel->Search->Enter->Clear Search->Minimize). Plz Make this happen, it will be much appreciated.
Comment 16 Kevin Funk 2009-09-18 11:24:08 UTC
Enable "Show only matches" and you have that behaviour in Amarok2 series.
Comment 17 Kevin Funk 2009-09-18 13:03:46 UTC
Trying to implement a quick jump shortcut...
Comment 18 Myriam Schweingruber 2009-09-18 13:40:17 UTC
Don't forget the current feature freeze...
Comment 19 Kevin Funk 2009-09-29 17:45:13 UTC
commit 9793871c9c805332f275418218d5f92300754ad1                                                                        
Author: Kevin Funk <krf@electrostorm.net>                                                                              
Date:   Tue Sep 29 17:43:33 2009 +0200                                                                                 

    Implement jumpTo shortcut. Ctrl+J focusses playlist search.
    BUG: 92400