Bug 89855 - Don't prompt for Disposition Notifications to self.
Summary: Don't prompt for Disposition Notifications to self.
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: MDN (show other bugs)
Version: 1.9.7
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 122785 146672 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-20 05:46 UTC by Patrick Audley
Modified: 2007-10-24 21:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Audley 2004-09-20 05:46:52 UTC
Version:           HEAD (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

I'm labelling this a bug only because it worked until a few weeks ago on HEAD.  For some reason I'm now being prompted for return receipts on all my copied-to-self email.  Ideally, any address that is part of a configured identity should be excluded from asking for disposition notifications as they would be telling yourself that you've read a message.
Comment 1 Gilles Schintgen 2005-07-12 22:27:55 UTC
The problem also arises if "Send Later" is chosen in the composer and the message is viewed in the outbox. In this case, asking to send a disposition notification is just stupid.
Comment 2 Thomas McGuire 2007-06-11 19:05:44 UTC
See also bug 146672.
Comment 3 Jonathan Marten 2007-06-11 20:11:57 UTC
Another suggested resolution from 146672:

Since normally the "special" folders - outbox, sent-mail, trash, drafts and templates - only contain messages the user has originated, no MDNs need be sent for messages in these folders. 
Comment 4 Jonathan Marten 2007-06-11 20:12:45 UTC
*** Bug 146672 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-07-01 11:39:46 UTC
*** Bug 122785 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Marten 2007-10-24 14:15:33 UTC
SVN commit 728835 by marten:

Don't send or prompt for an MDN for a message in a special folder, which is
most likely to have been written by this very user: outbox, sent, trash, drafts,
templates.

BUG:89855


 M  +8 -0      kmreaderwin.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=728835
Comment 7 Jonathan Marten 2007-10-24 21:23:06 UTC
Backport of bugfix commit 728835 from trunk:

Don't send or prompt for an MDN for a message in a special folder, which is
most likely to have been written by this very user: outbox, sent, trash, drafts, templates.

http://websvn.kde.org/?view=rev&revision=728947