Bug 64740 - Wishlist - support for .hidden files
Summary: Wishlist - support for .hidden files
Status: RESOLVED DUPLICATE of bug 246260
Alias: None
Product: kfile
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 341 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 153864 219016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-22 17:25 UTC by kdebugs
Modified: 2014-09-14 22:58 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdebugs 2003-09-22 17:25:23 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    Compiled From Sources
Compiler:          n/a n/a
OS:          Linux

I would love if kdesktop would implement support for .hidden files ala the newest gnome release and OS X.

You can see an example of my desktop here:
http://www.lusis.org/static/screenshot-marked.png

The folders marked in red, I don't wish to see. I am aware that I can hide them with the ageold trick of renaming the folders with . in front but many applications such as evolution do not allow you to change the location of the datastore at all.

This desire is drawn out of my use of my home directory (~/) as my desktop root. I find it helps me keep things more organized when I'm forced to look at them cluttering up my desktop.

In the newest version of Gnome and OS X, one can create a file in any directory called ".hidden". The syntax of that file is simply a list of folders and files you wish to not be displayed on the desktop or within the file manager. Apple uses this to hide the disk volume folders from the Finder. Since I'm unable to move the evolution datastore, I would love to be able to at least HIDE it from my desktop view.
Comment 1 Jens 2005-02-23 09:42:23 UTC
Hi,

I second this wish. I would like to be able to do this as well.

Thank you!
Comment 2 uno 2005-08-23 18:23:59 UTC
This would also be very useful, when a specific folder is shared to other operating systems like windows. When a folder is used under e.g. windows that OS might add files that is of no use when viewed from the UNIX side.

It is also a good thing to use for a sysadmin that wants to give his users a more MacOS-X like user experience, where only the most important folders are shown.

This is a must have.
Comment 3 dlepiane 2006-12-14 20:29:23 UTC
Can I vote against this bug?  This type of behaviour obfuscates the file system adding basically no benefit at all.  Most users will stick to the default folders.  Especially on OS X where there are default folders called "Documents", "Pictures", "Movies", etc.  That is a much better way to improve the user experience.

The use of .hidden files is just going to cost processor cycles and disk accesses for every directory listing.  And it certainly does not protect the file system since file permissions are still required to prevent access to unauthorized users.

Please consider removing this wishlist item.  I've seen it show up in Kubuntu so if this is already something that has been created, I would consider it a bug that should be removed ASAP to prevent further confusion especially to power users and system administrators.  Having to "just know" about .hidden files is a barrier to these important groups of users.
Comment 4 uno 2006-12-14 22:36:49 UTC
Dlpiane, you are right in that .hidden files are not supposed to be a replacement for permissions, it is an extension of the normal dot-file system. Just like ordinary dotfiles, .hidden should be used to hide files that are of no use to ordinary users other than in some unfrequent situation.

Another thing, if sysadmins gets confused by this, they should consider some other way to make their living. Real power users would certainly be able to remove or add them to their liking if they can't they are not power users. 

To ordinary users, that know little or nothing of Unix, hiding files that only are of use to sysadmins and power users makes their lifes easier. Only seing things that are related to their work makes the system more focused. Given the fact, that in most workplaces I have seen, there are far more ordinary user than sysadmins. I would think it is much more important to cater for the needs of the ordinary user than the sysadmin.

All in all, it boils down to should we create a good user interface for Unix or should we just create a good user interface. If our goal was to increase the understanding of how Unix works, then perhaps we should remove the GUI altoghether.

As for wasted processor cycles, I would say that this is not much of a problem on modern hardware. If we have cycles enough to display shadows below our menus or having files instantly indexed by search engines, we certainly have cycles enough to process a few .hidden files, especially as there most likely would be no .hidden files in directories like Documents, Pictures, Movies,... where the user is most likely to browse. 



Comment 5 Jens 2006-12-15 01:00:35 UTC
It's just one .hidden file in each root directory, so the overhead would not be big - just keep that file in memory and filter every directory display through it. We already do that with dot files and with every file type selector, so it's not a big deal.

Second, I absolutely agree with comment #4: We need to care about people who do *not* customize everything. This is something that Gnome (I've been toying around with Ubuntu lately) has done really well - good, stable defaults, where "stable" means e.g. "I know where to find $FEATURE (e.g. my DVD drive) and it's not going to change".

You can't expect everybody to start searching for configuration options first thing. The ideal desktop is one that doesn't *need* to be configured. With .hidden files, we remove the need for the user to care about stuff that he can't do anything with anyway.
Comment 6 uno 2006-12-15 15:59:23 UTC
Actually, as I see it, it should be possible to put .hidden files in any directory not just the /, but even so, the overhead will not be much to worry about. Most directories ordinary users will visit contains stuff they want to see, so these directories will most likely not have a .hidden in them.

The most common use of this feature will probably be to hide things like /etc, /dev, /proc, /boot, /usr, /lib,... and other top level files that the sysadmin feels is disturbing to his users. Some of them could perhaps be hidden by default, but that is something that could be tested out on real users once the feature of supported .hidden files is included.
Comment 7 Ivo Emanuel Gonçalves 2008-02-23 03:59:19 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Ivo Emanuel Gonçalves 2008-02-23 04:04:17 UTC
Funny thing is, I pretty much remember seeing this feature working on KDE 3.5.6 under Kubuntu.  When I upgraded to 3.5.8, it vanished.  Why, I have no idea.

I personally like to hide the uglyness of the unix file system.  .hidden is perfect in that regard because we can disable it permanently by deleting the file, or temporarily by enabling an option in the file browser (aka Konqueror) to see hidden files.

Gtk applications, even when running under KDE, still show support for this, so why does KDE wish to fall behind GNOME by not implementing a feature that it had actually implemented BEFORE?  Makes no sense to me.

Also, isn't .hidden a proposal from freedesktop.org?
Comment 9 David Bailey 2009-09-17 14:06:30 UTC
Those interested in this bug may be interested in the related bug #3212. It requests the ability to hide specific file types and hide individual files at the user's request. https://bugs.kde.org/show_bug.cgi?id=3212
Comment 10 Jonathan Thomas 2009-12-28 21:06:29 UTC
*** Bug 219016 has been marked as a duplicate of this bug. ***
Comment 11 Jonathan Thomas 2009-12-28 21:07:31 UTC
*** Bug 153864 has been marked as a duplicate of this bug. ***
Comment 12 Adam 2010-03-02 03:28:18 UTC
The reason I'd like to see this implemented is in the case where a certain directory cannot be renamed but I'd still like it hidden. For example, I installed Battlefield 2 using Wine which puts a configuration directory in ~/Battlefield 2 (and can't be configured to be called anything else). I can hide this in Gnome by adding that directory to a .hidden file but this doesn't work in KDE.
Comment 13 Mark 2010-07-30 08:51:57 UTC
there's a patch at bug #245994 for kde4 dolphin hidden files; in case people have more current views to air they should consider restating them there :-)
Comment 14 Chao Feng 2014-05-24 09:28:13 UTC
Move to Kfile. There is another bug 246260 there. It has less votes.
Comment 15 brunombn 2014-07-15 19:44:36 UTC
Is this feature ever going to be added to KDE? It's 2014 already!

The standard way of hiding a file (prepending a dot) requires renaming it, so it's not always possible. That's why this feature would be a very nice addition!
And, to please everyone, you could add a configuration option to enable/disable this feature.

There is a patch in Bug #246260 (no idea if it works).
Comment 16 Christoph Feck 2014-08-16 11:49:45 UTC
I mark it as a duplicate, despite this being older and having more votes, because bug 246260 has recent discussion and a patch in the works.

Votes are not automatically transferred, see bug 265099.

*** This bug has been marked as a duplicate of bug 246260 ***