Bug 60265 - url highlighting in mail inconsistent
Summary: url highlighting in mail inconsistent
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: messageviewer (show other bugs)
Version: 1.5.2
Platform: unspecified Linux
: NOR wishlist with 37 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 53571 57631 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-23 10:49 UTC by Simon Huerlimann
Modified: 2009-09-04 22:28 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Huerlimann 2003-06-23 10:49:57 UTC
Version:           1.5.2 (using KDE 3.1.2)
Installed from:     (testing/unstable)
Compiler:          gcc version 3.3 (Debian)
OS:          Linux (i586) release 2.4.20-3-k6

If I recive a mail, email addresses, http and ftp urls are highlighted and are links. Even smb:// like addresses work as links. This is great.
But not all urls are recognized.

Check out the following (Send yourself a mail:-)

file:/home [not recognized]
file://home [not recognized]
http://www.home.ch
ftp://user:pwd@home.ch/home
mailto://user@home.ch
fish://home.ch/home [not recognized]
fish://user@home.ch/home [only user@home.ch recognized as mailto]
smb://home.ch/home
audiocd:/ [not recognized]

It would be nice (wishlist I guess:-) if kmail could recognize all urls. Or at least the ones with a registered kio service.

Simon
Comment 1 Simon Huerlimann 2003-06-23 10:52:21 UTC
Bugzilla's a little bit worse though:-) 
 
It seems to recognize the same url's in it's comments as kmail. BUT Kmail additionly knows 
about smb:-)  
1:0 for kmail 
Comment 2 Jonathan Marten 2006-11-23 21:21:18 UTC
*** Bug 53571 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Marten 2006-11-23 21:22:47 UTC
Bug 53571 also adds "vnc:"/"vnbc:" (Remote Desktop Connection invitation)
Comment 4 Jonathan Marten 2006-11-23 21:24:13 UTC
*** Bug 57631 has been marked as a duplicate of this bug. ***
Comment 5 JC Cardot 2007-03-04 16:48:14 UTC
as the developper for kmailpt (http://cardot.net/kmailpt), I find it's a pity that file:// uris are not recognised by kmail. Is there a good reason for this?
Indeed when my program detaches an attachment from an email, it writes (within the mail body) a line with the new location of the file on the disk, as a file:// uri. Of course this won't work.
Comment 6 FiNeX 2007-06-24 01:08:55 UTC
In Kmail 3.5.7 there is something new. The links:

fish://home.ch/home 
fish://user@home.ch/home 

are recognised correctly, instead:

file:/home 
file://home
audiocd:/

still they are not recognized.
Comment 7 Martin Koller 2009-09-04 22:28:38 UTC
KDE 4.3.1 contains a check for the following protocols:

    url == "http://" ||
    url == "https://" ||
    url == "fish://" ||
    url == "ftp://" ||
    url == "ftps://" ||
    url == "sftp://" ||
    url == "smb://" ||
    url == "vnc://" ||
    url == "mailto" ||
    url == "www" ||
    url == "ftp" ||
    url == "news" ||
    url == "news://";
}

file:/ strictly spoken is not a valid URL, as it must be file://<path>

With solving bug 202445 the link detection has been greatly improved.
And the only missing protocol mentioned here is audiocd. But hey, who will ever send you a link to your local CD drive ...
So I see this as fixed.