Bug 59478 - Ability to add custom header fields when composing a message
Summary: Ability to add custom header fields when composing a message
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: mime (show other bugs)
Version: unspecified
Platform: RedHat RPMs Linux
: NOR wishlist with 278 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 57392 66951 90663 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-06-07 19:10 UTC by Nicolas Bock
Modified: 2012-08-21 00:16 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Bock 2003-06-07 19:10:32 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    RedHat RPMs

One can add "custom mime header fields" to emails, and set their default values. It would be useful however if one would be able to set their value in the composer window instead of to some global default.
Comment 1 Nathanael Nerode 2004-02-23 17:05:41 UTC
This is crucially important when replying to a message on a web archive, in order to add "In-Reply-To" and/or "References" fields for that message, so as to keep threads working.
Comment 2 Michael Jahn 2004-09-01 23:26:08 UTC
*** Bug 66951 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Kitchen 2004-09-15 04:51:19 UTC
I think it would also be very nice to add this custom header functionality to the mailing list folders functionality.  I'd like to be able to set default Mail-Followup-To headers and such (but still be able to change them on the fly in the composer window) for messages sent from a specific folder.  I know it would probably take me some getting used to making sure I'm in the right folder when I begin to compose a message, but it would be EXTREMELY handy.  If I knew even where to begin on something like this I would do it myself, but unfortunately I can't.

Just to add: I love the latest version of kmail.  Detached pgp signatures woohoo!

Keep up the good work guys.  If you're ever in Galena, Illinois, let me know, I'll buy you a round at the bar.
Comment 4 Tom Albers 2004-10-02 21:02:15 UTC
*** Bug 90663 has been marked as a duplicate of this bug. ***
Comment 5 Olivier Trichet 2004-10-02 21:46:08 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Isaac Clerencia 2005-08-11 00:11:21 UTC
This is really useful for Debian developers because our bug tracking system supports sending CCs of bug reports including the bug number using a custom header X-Debbugs-Cc: .
I guess an option to be able to add custom headers like the current ones for selecting transport, add new recipientes, ..., would be great :)
Comment 7 Thomas McGuire 2007-08-01 18:23:15 UTC
*** Bug 57392 has been marked as a duplicate of this bug. ***
Comment 8 Thomas McGuire 2007-08-01 18:25:04 UTC
Costum headers per message: bug 59478
Costum headers per identity: bug 25315
Costum headers per template: bug 148407
Comment 9 Jaime Torres 2009-07-09 19:50:16 UTC
Isn't this already implemented in kmail 1.12?
I see custom headers in the settings|composer window.
They can be inserted by filters, and also by templates.
Comment 10 Magnus Holmgren 2009-07-09 20:30:33 UTC
(In reply to comment #9)
> Isn't this already implemented in kmail 1.12?
> I see custom headers in the settings|composer window.
> They can be inserted by filters, and also by templates.

Yes, but they can't be easily added to a single message. Opening the customization dialog to create a template, or add a custom field, then removing it after composing a message, is tedious.

Use case: In-Reply-To when replying to a message in a mailing list archive on the Web (sometimes, but not very often, you can download the message in RFC822 format, save it, and open it with KMail).
Comment 11 Anne-Marie Mahfouf 2011-11-27 13:33:23 UTC
Fixed but maybe hard to use. Closing and if you want a better implementation please suggest it precisely in a new bug report