Bug 462512 - [NVIDIA] Missing sensor information after driver update
Summary: [NVIDIA] Missing sensor information after driver update
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.26.4
Platform: Other Linux
: HI normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 461389 462024 462541 462624 462687 462689 462870 463094 464792 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-12-01 17:03 UTC by Marcelo Bossoni
Modified: 2023-01-27 17:24 UTC (History)
20 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.27


Attachments
nvidia smi output comparing 520 vs 525 (1.14 KB, text/plain)
2022-12-05 12:57 UTC, Marcelo Bossoni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Bossoni 2022-12-01 17:03:13 UTC
SUMMARY
After updating nvidia drivers to version 525, sensor information is missing

STEPS TO REPRODUCE
1. Install new nvidia drivers (525)

OBSERVED RESULT
Missing sensor information

EXPECTED RESULT
All sensor information is shown

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7
Kernel Version: 6.0.10-272-tkg-pds (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5700X 8-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1070/PCIe/SSE2
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7A37
System Version: 1.0

ADDITIONAL INFORMATION
Comment 1 Marcelo Bossoni 2022-12-05 12:57:46 UTC
Created attachment 154330 [details]
nvidia smi output comparing 520 vs 525

A bit more info
I've compared the output of "/usr/bin/nvidia-smi dmon -d 2 -s pucm" between driver versions and newer driver add some more spaces it seems... Maybe parser is broken?
Comment 2 Riccardo Robecchi 2022-12-08 10:14:53 UTC
*** Bug 462687 has been marked as a duplicate of this bug. ***
Comment 3 Riccardo Robecchi 2022-12-08 10:15:00 UTC
*** Bug 462689 has been marked as a duplicate of this bug. ***
Comment 4 Riccardo Robecchi 2022-12-08 10:15:07 UTC
*** Bug 462624 has been marked as a duplicate of this bug. ***
Comment 5 Riccardo Robecchi 2022-12-08 10:15:11 UTC
*** Bug 462024 has been marked as a duplicate of this bug. ***
Comment 6 Riccardo Robecchi 2022-12-08 10:24:45 UTC
This might actually be a duplicate of bug 461389, but I do not know enough to decide myself, so intervention by a developer would be welcome! :)
Comment 7 Mathias Homann 2022-12-08 11:43:46 UTC
I don't think it is - the GPU sensors are there, they just return nothing but zeros.
Comment 8 Antonio Rojas 2022-12-11 09:30:35 UTC
*** Bug 462870 has been marked as a duplicate of this bug. ***
Comment 9 David Redondo 2022-12-19 09:40:01 UTC
*** Bug 463094 has been marked as a duplicate of this bug. ***
Comment 10 David Edmundson 2023-01-04 17:54:26 UTC
*** Bug 461389 has been marked as a duplicate of this bug. ***
Comment 11 yizel7 2023-01-08 21:58:51 UTC
This is still issue with latest nvidia driver 525.78.01
Comment 12 Benjamin W. 2023-01-08 22:00:11 UTC
(In reply to yizel7 from comment #11)
> This is still issue with latest nvidia driver 525.78.01

Confirmed. I am still having the same issue.
Comment 13 David Redondo 2023-01-09 13:06:58 UTC
Git commit d42ab99437830c1c8aa1b6cd6a616d51fcd42916 by David Redondo.
Committed on 09/01/2023 at 12:48.
Pushed by davidre into branch 'master'.

plugins/gpu: Don't let a newline confuse the nvidia-smi output parsing

Newer versions of nvidia-smi add more spaces to the output. While
it doesn't matter for the middle parts, there is also an additional
space before the new line.
Use trimmmed to remove whitespace at the end to cope with both.
FIXED-IN:5.27

M  +2    -2    plugins/gpu/NvidiaSmiProcess.cpp

https://invent.kde.org/plasma/ksystemstats/commit/d42ab99437830c1c8aa1b6cd6a616d51fcd42916
Comment 14 yizel7 2023-01-09 14:31:35 UTC
(In reply to David Redondo from comment #13)
> Git commit d42ab99437830c1c8aa1b6cd6a616d51fcd42916 by David Redondo.
> Committed on 09/01/2023 at 12:48.
> Pushed by davidre into branch 'master'.
> 
> plugins/gpu: Don't let a newline confuse the nvidia-smi output parsing
> 
> Newer versions of nvidia-smi add more spaces to the output. While
> it doesn't matter for the middle parts, there is also an additional
> space before the new line.
> Use trimmmed to remove whitespace at the end to cope with both.
> FIXED-IN:5.27
> 
> M  +2    -2    plugins/gpu/NvidiaSmiProcess.cpp
> 
> https://invent.kde.org/plasma/ksystemstats/commit/
> d42ab99437830c1c8aa1b6cd6a616d51fcd42916

Tyvm David!
Comment 15 Oleksii Zolotarevskyi 2023-01-09 22:48:08 UTC
Thanks a lot David!
Comment 16 Benjamin W. 2023-01-22 13:50:10 UTC
I'm on the beta version (5.26.90) and it still doesn't seem to be getting any readings on my GPU.
Comment 17 Benjamin W. 2023-01-22 13:52:50 UTC
(In reply to Benjamin W. from comment #16)
> I'm on the beta version (5.26.90) and it still doesn't seem to be getting
> any readings on my GPU.

Using Nvidia driver version 525.85.05
Comment 18 Nate Graham 2023-01-27 17:24:45 UTC
*** Bug 464792 has been marked as a duplicate of this bug. ***
Comment 19 Nate Graham 2023-01-27 17:24:55 UTC
*** Bug 462541 has been marked as a duplicate of this bug. ***