Bug 455712 - Non-functional "Unlock" button sometimes shown after entering correct password
Summary: Non-functional "Unlock" button sometimes shown after entering correct password
Status: RESOLVED DUPLICATE of bug 456210
Alias: None
Product: kscreenlocker
Classification: Plasma
Component: greeter (show other bugs)
Version: 5.25.0
Platform: Other Linux
: VHI critical
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2022-06-21 11:50 UTC by Iyán Méndez Veiga
Modified: 2022-10-13 07:34 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iyán Méndez Veiga 2022-06-21 11:50:28 UTC
SUMMARY
After upgrading to Plasma 5.25, when unlocking the screen, and after entering the password, I get an extra step with a "unlock" button.

I believe this was introduced in this commit:
https://invent.kde.org/plasma/plasma-workspace/-/commit/dc6341bb3073ebe0beb945018cc7bb67ee2dd828

to solve the issue of passwordless accounts (bug 440055)


STEPS TO REPRODUCE
1. Lock screen
2. Unlock by introducing your password
3. New screen with unlock button appears

OBSERVED RESULT


EXPECTED RESULT
I would prefer previous behavior with this extra step.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.5-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × 11th Gen Intel® Core™ i5-1135G7 @ 2.40GHz
Memory: 15.4 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics
Manufacturer: LENOVO
Product Name: 20XYCTO1WW
System Version: ThinkPad X1 Yoga Gen 6
Comment 1 Nate Graham 2022-06-21 18:22:09 UTC
I get the same thing with fingerprint authentication. See Bug 454706.
Comment 2 Andrej Falout 2022-07-05 05:34:39 UTC
Same problem with face login (Howdy). 

This comes just after the "Screen locker is broken and unlocking is not possible" (455874)  was apparently fixed. Lost count how many times that one regressed. It even comes with it's own instructions screen, that's how "popular" it is. 

And this one seems to be intentional: "This patch adds an explicit button that must be pressed if no other prompts were given during the authentication process."

I am on the Neon "user" feed, and I must say, the stuff that ends up in it is not fit for daily use of an operating system.

:(
Comment 3 Iyán Méndez Veiga 2022-07-05 05:40:42 UTC
(In reply to Andrej Falout from comment #2)
> Same problem with face login (Howdy). 

Howdy stopped working for me a while ago, but it seems it's not Plasma's fault. Although it works with everything else (sudo, polkit)

https://bugs.kde.org/show_bug.cgi?id=449577
https://github.com/boltgolt/howdy/issues/551
Comment 4 mjasinski72 2022-07-11 19:40:02 UTC
Hello,

In my case, the same, after some update...

Maybe the following method will help:

$ /usr/lib/kscreenlocker_greet --testing

showed, among others:

file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/lockscreen/LockScreenUi.qml:75: Error: Cannot assign to non-existent property "showPassword"

So I deleted line 75 in that file:
mainBlock.showPassword = false;

and the additional screen with the "Unlock" button is no longer displayed.
Comment 5 Nate Graham 2022-07-12 17:26:50 UTC
*** Bug 456639 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-07-12 17:33:52 UTC
Marking as confirmed since multiple people are reporting it.
Comment 7 Nate Graham 2022-07-12 18:11:23 UTC
*** Bug 456639 has been marked as a duplicate of this bug. ***
Comment 8 matthewsha 2022-07-12 18:14:59 UTC
Same problem with 5.25.3, clicking unlock button does nothing. I have to re-enter my pw with the virtual keyboard and then click unlock. Using x11.
Comment 9 Vorpal 2022-07-12 18:46:00 UTC
This happens for me too. Arch Linux.

What is worse is that the unlock button actually only works on one of my computer (desktop). On my laptop the button does nothing making it impossible to get back into the session without logging into a vt and using loginctl to unlock the session that way!

The laptop with that issue is running hybrid graphics (but they are in intel-only mode). Happens with kscreenlocker 5.25.3-1 package as well as older 5.25.x versions too. Downgrading to kscreenlocker-5.24.90-1 fixes the issue.

I'm using X11.
Comment 10 sid8tive 2022-07-12 18:51:04 UTC
There is a temporary workaround as described in: https://www.reddit.com/r/archlinux/comments/vxho5o/most_recent_kdeplasma_update_prevents_unlocking/

Temporary workaround: Switching to another console (Ctrl + Alt + F2) and issuing the following command and then switching back to the main session by using Ctrl + Alt + F1:

loginctl unlock-session 2

(You can get the session list by just running loginctl without any arguments)
Comment 11 Nate Graham 2022-07-12 18:53:29 UTC
> Same problem with 5.25.3, clicking unlock button does nothing.
That's a different issue; see Bug 456639. This bug report is about the "Unlock" button appearing unnecessarily, not it being broken.
Comment 12 Vorpal 2022-07-12 18:58:25 UTC
(In reply to Nate Graham from comment #11)
> > Same problem with 5.25.3, clicking unlock button does nothing.
> That's a different issue; see Bug 456639. This bug report is about the
> "Unlock" button appearing unnecessarily, not it being broken.

It is kind of hard to tell these bugs apart. I seem to be having a combination of Bug 456210 and this or bug 456639. 

I see an unlock button after entering my password. Said button doesn't work unless I unplug the external monitor. Downgrading to any 5.25.x release does not fix it. Only going back to 5.24.x works.

For anyone on Arch Linux running into these issues I suggest for now downgrading using:

sudo pacman -U https://archive.archlinux.org/packages/k/kscreenlocker/kscreenlocker-5.24.90-1-x86_64.pkg.tar.zst
Comment 13 sid8tive 2022-07-12 19:00:25 UTC
Good call out. I am on multi-monitors too, on Arch. And the Unlock button is broken when all monitors are connected.
Comment 14 Antonio Rojas 2022-07-12 19:02:36 UTC
(In reply to Vorpal from comment #12)
> For anyone on Arch Linux running into these issues I suggest for now
> downgrading using:
> 
> sudo pacman -U
> https://archive.archlinux.org/packages/k/kscreenlocker/kscreenlocker-5.24.90-
> 1-x86_64.pkg.tar.zst

Please don't suggest doing partial upgrades on Arch, this is totally unsupported and has a high chance of totally breaking your system.
Comment 15 darcagn 2022-07-12 19:08:37 UTC
(In reply to Vorpal from comment #12)
> (In reply to Nate Graham from comment #11)
> > > Same problem with 5.25.3, clicking unlock button does nothing.
> > That's a different issue; see Bug 456639. This bug report is about the
> > "Unlock" button appearing unnecessarily, not it being broken.
> 
> It is kind of hard to tell these bugs apart. I seem to be having a
> combination of Bug 456210 and this or bug 456639. 
> 
> I see an unlock button after entering my password. Said button doesn't work
> unless I unplug the external monitor. Downgrading to any 5.25.x release does
> not fix it. Only going back to 5.24.x works.

Do you see a password prompt on all of your displays? 
In my situation, the lock screen appears on all monitors and the password entry prompt appears only on monitors the cursor has moved onto.
In my case, I have 3 displays, and if I move the cursor on all 3 displays to show a prompt on all 3 displays, the "unlock" button appears and when clicked, I can get into my session.
If I _do not_ move the cursor around to all 3 displays first before entering the password, the "unlock" button appears but does not function and I cannot get into my session.
Comment 16 Nate Graham 2022-07-12 19:10:46 UTC
Please update your system after Arch packagers apply the fix to bug 456639. It should be quite soon; they are awesomely super responsive about this sort of thing. After that, let's see if your issues with the Unlock button not working with multimonitor setups (not single-monitor setups) is fixed, or if they are still there. If that specific issue persists, we should get a new bug report about it to distinguish that from the issue fixed in bug 456639.
Comment 17 Nate Graham 2022-07-12 19:11:45 UTC
Actually no need for a new bug report; Bug 456210 tracks the multimonitor-specific issue.
Comment 18 Vorpal 2022-07-12 19:11:57 UTC
(In reply to Antonio Rojas from comment #14)
> (In reply to Vorpal from comment #12)
> > For anyone on Arch Linux running into these issues I suggest for now
> > downgrading using:
> > 
> > sudo pacman -U
> > https://archive.archlinux.org/packages/k/kscreenlocker/kscreenlocker-5.24.90-
> > 1-x86_64.pkg.tar.zst
> 
> Please don't suggest doing partial upgrades on Arch, this is totally
> unsupported and has a high chance of totally breaking your system.

This is true. However:
* being able to unlock the screen but a slightly no standard and unsupported setup
vs
* having a completely useless system where I can't use suspend in any meaningful way.
Comment 19 Vorpal 2022-07-12 19:13:38 UTC
(In reply to darcagn from comment #15)
> (In reply to Vorpal from comment #12)
> > (In reply to Nate Graham from comment #11)
> > > > Same problem with 5.25.3, clicking unlock button does nothing.
> > > That's a different issue; see Bug 456639. This bug report is about the
> > > "Unlock" button appearing unnecessarily, not it being broken.
> > 
> > It is kind of hard to tell these bugs apart. I seem to be having a
> > combination of Bug 456210 and this or bug 456639. 
> > 
> > I see an unlock button after entering my password. Said button doesn't work
> > unless I unplug the external monitor. Downgrading to any 5.25.x release does
> > not fix it. Only going back to 5.24.x works.
> 
> Do you see a password prompt on all of your displays? 
> In my situation, the lock screen appears on all monitors and the password
> entry prompt appears only on monitors the cursor has moved onto.
> In my case, I have 3 displays, and if I move the cursor on all 3 displays to
> show a prompt on all 3 displays, the "unlock" button appears and when
> clicked, I can get into my session.
> If I _do not_ move the cursor around to all 3 displays first before entering
> the password, the "unlock" button appears but does not function and I cannot
> get into my session.

I did not try this. I do believe I saw a password prompt on multiple displays and was not able to get in. I don't have time to test this further today though unfortunately.
Comment 20 sid8tive 2022-07-12 19:16:26 UTC
(arch) Updated to 5.25.3.1-1 (plasma-wayland-session, plasma-workspace) and its fixed for me!
Comment 21 Vorpal 2022-07-12 19:23:13 UTC
(In reply to sid8tive from comment #20)
> (arch) Updated to 5.25.3.1-1 (plasma-wayland-session, plasma-workspace) and
> its fixed for me!

Updating plasma-workspace to 5.25.3.1-1 seems to fix this in that I don't see the unlock button and multi screen unlock works. Works with both the password and fingerprint.

I have the following fragment in /etc/pam.d/kde: 

auth            sufficient      pam_unix.so          try_first_pass likeauth nullok
-auth           sufficient      pam_fprintd.so       max_tries=1 timeout=10
Comment 22 Bharadwaj Raju 2022-07-16 15:36:51 UTC
Can/should this be closed as RESOLVED FIXED now? Looks like with the patch it is now fixed.
Comment 23 K.J. Petrie 2022-07-17 21:28:10 UTC
Arch isn't the only distro using KDE!

So no, it isn't fixed, just worked around in Arch.
Comment 24 Bharadwaj Raju 2022-07-17 21:32:13 UTC
(In reply to K.J. Petrie from comment #23)
> Arch isn't the only distro using KDE!
> 
> So no, it isn't fixed, just worked around in Arch.

As I understand it, Arch just applied an upstream KDE commit to their version of the package. If that is correct, then it would indeed be *fixed*.
Comment 25 David Edmundson 2022-07-17 23:00:08 UTC
5.23.3.1  is available on all distros. It is a KDE release.
Comment 26 David Edmundson 2022-07-17 23:01:12 UTC
Note that this isn't the same as the author's original report about howdy, but we can track that in 454706.
Comment 27 Mika Norén 2022-07-23 14:16:00 UTC
(arch) Updated to 5.25.3.1-1 and this is still a problem. 
It seems random when it happens though. Sometimes it works. Sometimes it gets stuck with the unlock buttons that do nothing when clicked.
I suspect it's based on how long it has been locked. This seems to happen more often if I leave the computer locked overnight.

I'm downgrading to 5.24 as suggested earlier. I rather have an "unsupported system" than one I cannot unlock at all.
Comment 28 Nate Graham 2022-07-25 18:47:12 UTC
With current git master, I can reproduce this issue when using fingerprint authentication (which is Bug 454706), but not normal password authentication. I tested with a single monitor as well as multiple monitors.
Comment 29 David Edmundson 2022-07-26 09:31:28 UTC

*** This bug has been marked as a duplicate of bug 456210 ***
Comment 30 David Edmundson 2022-07-26 09:32:39 UTC
The original bug about a bad backport is fixed. There's discussions about other bugs. 
Reopening this is unhelpful at this point as it's just 

Lets fix the bug tagged as a duplicate for the other comments and see where we are from there.
Comment 31 henning 2022-10-05 16:34:41 UTC
Switched a gentoo box to 5.25.5 on the weekend and see that weird button every single time. I can already say that it seems clearly related to pam_u2f and other are also reporting special pam modules. If i have a yubikey plugged i need to touch it several times and hit that new "Unlock" button. If there is no yubikey plugged i can log in with my password like before.

Note that i am using the pam_u2f not as a 2nd factor but as an alternative to a password so "sufficient" and not "required" ... probably much like the face recognition someone talked about, or was it fingerprint ... or both?

This was marked as a duplicate of https://bugs.kde.org/show_bug.cgi?id=456210 but it really is not. The "Unlock" button seem to be an effect of any special pam, maybe one without a password.

> file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserList.qml:43:9: Unable to assign [undefined] to bool

Now when i have one screen i have to hit the button one time. A button i would not expect at all ...

Adding a second screen meens adding a second push of the new button, and a second touch of my yubikey. I did not try 3 screens but am willing to guess what might happen ...

So i open this one back up. That "new" "unlock" button came somewhere between 5.24.6 and 5.25.5, likely in relation to "special pam". And it seems you have to push it several times when having more than one screen.
Comment 32 Nate Graham 2022-10-05 22:51:40 UTC
> The "Unlock" button seem to be an effect of any special pam, maybe one without a password.
Indeed, that's what the last comment in Bug 456210 indicates, so I think it really is a duplicate. Could you add your information to Bug 456210? Thanks!

*** This bug has been marked as a duplicate of bug 456210 ***